Previous 1 2 Next 16 Replies Latest reply: Jan 15, 2013 8:24 PM by JimmyZCCK
Gordon Craig Level 1 (0 points)

I just upgraded to Mountain Lion (10.8.2), and now my Google calendar delegates no longer appear in iCal.  They show up in the menu of calendars, but not on the calendar itself.  They still show up on my iPhone and my Google calendar on the web. 

 

How do I get them back?  I've seen one solution for loading each delegate calendar as a separate calendar, but that seems unnecessarily painful, especially for something that was working fine 3 days ago. 

 

Thanks,

Gordon


MacBook Pro, OS X Mountain Lion (10.8.2)
  • balacobaco Level 1 (5 points)

    +1

     

    No upgrade. Fresh install for me. Had them working on Mountain Lion and suddenly they dissappeared. Currently looking for a solution.

  • balacobaco Level 1 (5 points)

    I deleted and re-added my Google Calendar from iCal and selected the delegates. Nothing improved. I rebooted and still could not see the delegates. However, I went back to (menu) Calendar > Preferences > Accounts > My Google Account > Delegation and clicked on the delegates again. They reappeared.

     

    I then went to my actual Google Calendar (in the browser, not iCal) and added a new Calendar. I switched back to iCal and added the new delegate. All delegates dissappeared, again!

     

    It seems like when your applying changes to your delegates they break in iCal. However, once all changes are done with, everything works fine.

     

    A few things to note:

     

    It's not necessary to reboot in order to restore the working order of Google delegates in iCal. You must exit iCal and force terminate the CalendarAgent process in the system monitor. When you re-open iCal the delegates slowly reappear.

     

    Under the View menu you can choose to see all delegates and calendars by clicking Show Calendar List. A left sidebar will appear with all calendars and delegates.

     

    By default your calendar will syncronize every 15 minutes. This can be changed under menu Calendar > Preferences > Accounts > Your Google Account under the Account tab. Nonetheless, you can force syncronize with the Cmd+R keys or clicking Refresh Calendars under the View menu.

     

    Calendars can be filtered under the Window menu. If your calendars aren't showing up, make sure that Calendar is ticked under the Window menu. You can also use the Cmd+0 keys.

     


  • Gordon Craig Level 1 (0 points)

    Thanks for the solution (force terminating CalendarAgent in Activity Monitor).  That did it for now, although I wonder if it's only a temporary solution.  I've seen other discussions about CalendarAgent being unstable and a memory hog.  We shall see. 

     

    Thanks again,

    Gordon

  • aljjsdad Level 1 (0 points)

    tried killing the calendar agent.  nothing.  still not showing all delegates.  weird part is when I woke the mac up from sleep mode, I actually saw them slowly being removed from the delegate list.

     

    strange.  at least the iPhone and iPad are good.

     

    May try adding account as exchange instead of CalDV to see if that matters

  • hipath Level 1 (0 points)

    Same here - had them working, then changed my Google password.

     

    Delegates appeared and disappeared with no pattern behind.

     

    It tried a lot, including clean caches, removing and adding accounts and so on.

     

    My current situation (which is stable for the last few days):

    -My "main" calendar is available

    -My "own" delegates (Read&Write) are available

    -My shared delegates (Read only) completely disappeared - haven't seen them for 5 days on and any effort to bring them back (to even see them in Accounts->Delegate-Config failed).

     

    I also tried to add my Goggle account as exchange which also failed (server is not responding...)

     

    Cheers

    Patrick

  • aljjsdad Level 1 (0 points)

    same issue here.  adding as exchange did not help.

  • antoniopironti Level 1 (0 points)

    Same issue for me on Mac OSX 10.7.5 (Lion), Calendar 5.0.3: I can't see my shared delegates (read only) anymore.

  • hipath Level 1 (0 points)

    I didn't mention: OSX 10.8.2 Calendar 6.0

     

    Another thing that turned out:

    There are two entries in KeyChain for calendar.google.com which differ in the url - https://calendar.google.com/calendar/dav/xxx@xxx.xxx/user/ vs. https://calendar.google.com/calendar/dav/xxx%40xxx.xxx/user/.

     

    So one of them is url encoded and one is not; maybe Calendar is not able to handle that; maybe it's unrelated to our problem.

    I also set up Caldav on my iPhone (using the mentioned url) and it's working flawless - so the problem is somewhere in Calendar, CalendarAgent, ...

    Up to https I'm not able to debug / see what's going on; there is also a "-LogHttp... " parameter around, which had no effect for me.

  • fisherfarm Level 1 (0 points)

    Perfect solution for me! Worked. Will bookmark this solution should it happen again. Thanks for the solve

  • antoniopironti Level 1 (0 points)

    Sorry, what solution are you talking about?

  • fisherfarm Level 1 (0 points)

    Oh sorry - trying to reply to this one ...

     

  • spacecaptain77 Level 1 (0 points)

    Hallelujah! This worked! Thank you!!!

  • antoniopironti Level 1 (0 points)

    I finally solved this annoying issue. You just have to visit https://www.google.com/calendar/syncselect and select the shared calendar you want see as iCal delegates.

  • balacobaco Level 1 (5 points)

    Thank you Antonio. Works perfectly.

Previous 1 2 Next