8 Replies Latest reply: Oct 17, 2012 2:44 PM by NickThompson
NickThompson Level 1 Level 1 (0 points)

I'm running Aperture 3.4.1 on  a late 2009, 27 inch iMac with 8GB of RAM.

 

Since I downloaded version 3.4.1 I'm finding that Aperture is incredibly slow in processing smallish batches of photos (e.g. 60 x 15.5MB RAW files).

 

I've left it running for 24 hours and find that as soon as I try to edit a photo adjustments don't show up in the preview, because it's either "loading" (and never stops loading) or "processing."

 

When I try to quit Aperture either by selecting Quit or the little x in the top left of the window, nothing happens. And yet, I'm not getting any indication that Aperture is "not responding" if I open Force Quit or the Activity Monitor.

 

Very frustrating, as I'm trying to edit some photos for family member, and can't really do a thing.

 

My library is 421GB and not referenced (maybe that's part of the problem; I don't know)

 

Any sage advice will be appreciated.

 

cheers,

 

Nick

  • Aaron Ryan Level 1 Level 1 (10 points)

    I'm having the exact same problem. It only started today. Wish I had the answers to fix it.

  • léonie Level 9 Level 9 (65,575 points)

    Nick,

    try to narrow down the problem.

    Is it system wide, is it bound to your user account, or bound to your Aperture Library?

     

    1. To check, if your Aperture Library needs fixing: Create a new, empty Aperture library by holding down the ⌥-key while launching Aperture. Select "Other/new" and create a new library; import some pictures and edit a bit. Is Aperture still slow with the new library?
      If not, try the Aperture Library First Aid Tools on your main Aperture Library and repair and rebuild the Library:
      Aperture 3 User Manual: Repairing and Rebuilding Your Aperture Library.
      The problem may also be, that you imported a corrupted image or video. Try to remember what your last import has been, before this behaviour started. Launch Aperture with the Shift-key held down. Does is now launch quicker?

    2. If a new, empty library does not help, your user settings may be faulty. Launch Aperture from a new, different User account. Does it work there? If yes, remove your user preferences and -if necessary - presets, see Aperture 3: Troubleshooting Basics
    3. If a new user account does not help, you may have system wide trouble, then report back with your findings. Probably you need to reinstall Aperture or MacOS.

     

     

    Regards

    Léonie

  • Aaron Ryan Level 1 Level 1 (10 points)

    The first step did nothing for me, but creating a new user account and using Aperture in that account worked fine. Switching back to my main account though and removing the user preferences did not change a thing though.

     

    I recently removed and reinstalled Aperture and that's when things started getting funny,

  • léonie Level 9 Level 9 (65,575 points)
    The first step did nothing for me,

     

    You really could not work with a new, empty library from your account?

     

     

    Switching back to my main account though and removing the user preferences did not change a thing though.

     

    o.k., did you also try to remove your presets, not only the preferences com.aperture.plist?

     

    The presets are in the folder:

    ~/Library/Application Support/Aperture/

     

    and especially the Raw decode Presets occasionally are causing trouble.

     

    Remove  the Image capture preferences as well; see this post by fof:

     

    Re: Aperture 3.4 will not open after 10.8.2 installed

     

     

      • Quit Aperture, if it is running:
      • Open the user library by using the Finder's "Go > Go to Folder" menu,
      • enter    ~/Library/Preferences/ByHost   into the textfield.
      • In the widow that will open, remove all files from the "ByHost" folder, that have "com.apple.ImageCapture......" in its name.
      • From the "Preferences" folder  remove "com.apple.Image_Capture.plist".
      • Then try to launch Aperture again.

    Regards

  • Aaron Ryan Level 1 Level 1 (10 points)

    You really could not work with a new, empty library from your account?

    Nope. A new, empty library hangs just the same as the main one.

     

    I also removed all the preset files, as well as tried your ByHost suggestion while no results.

  • léonie Level 9 Level 9 (65,575 points)

    Aaron, do you see any diagnostic messages in the Console window? Launch Console from applications > Utilities before starting Aperture.  And what is your MacOS and Aperture version?

  • Aaron Ryan Level 1 Level 1 (10 points)

    Screen Shot 2012-10-17 at 10.24.03 .png

    This is all the came up from when I initiated Aperture. I also had the Force Quit box open and almost immediately after starting Aperture it tells me it isn't responding.

  • NickThompson Level 1 Level 1 (0 points)

    I'm very grateful for your help, Léonie. Your suggestions eventually led me to what seems to have solved the problem.

     

    Repairing and rebuilding the library didn't seem to work, so I began to wonder whether it was a problem with corrupted data, so I deleted and trashed a batch of images I imported last week. After closing Aperture, I then tried re-importing the same batch, and the problem seems to have gone.

     

    I'll keep working on this new batch and hope that Aperture keeps working.

     

    Nick