3 Replies Latest reply: Oct 19, 2012 8:00 AM by blues_cook
bowerymarc Level 1 (0 points)

this is happening with both my thunderbolt display and thunderbolt<->ethernet adaptor....


the ether net in the t-bolt display WAS working.... but was having probs with the ethernet adaptor while on the road, so I tried deleting the thunderbolt ethernet entry from the Network Preferences panel.  Well, now when I hook up my thunderbolt Display, the option doesn't re-appear!  So now I'm thinking there's something in the system that's keeping that from re-appearing in the network preference panel, and it could be the reason for both items not working.


The controller is recognized at a low level by the system - in system report I get:


Apple 57761-B0:


  Name:          ethernet

  Type:          Ethernet Controller

  Bus:          PCI

  Slot:          Thunderbolt Slot 2@11,0,0

  Vendor ID:          0x14e4

  Device ID:          0x16b0

  Subsystem Vendor ID:          0x106b

  Subsystem ID:          0x00f1

  Revision ID:          0x0010

  Link Width:          x1

  BSD name:          en2

  Kext name:          AppleBCM5701Ethernet.kext

  Firmware version:          57761-a1.48, 0x2fe676f9

  Location:          /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleB CM5701Ethernet.kext

  mDNS offload capable:          c8:2a:14:4f:a3:90

  Version:          3.2.4b8



So it's a problem with the Network Preferences panel getting loaded, somehow.   I tried re-creating the kext cache, that didn't help.


Digging around a little in the system, I see this:


cd /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/

$ ls

AppleBCM5701Ethernet.kext          AppleYukon2.kext

AppleIntel8254XEthernet.kext          IOEthernetAVBController.kext

AppleUSBEthernet.kext                    Intel82574L.kext

AppleUSBGigEthernet.kext          nvenet.kext



But I'm out of ideas how to get the thunderbolt ethernet option back into the Network Preference panel.  help?!

MacBook Air, Mac OS X (10.7.5)
  • bowerymarc Level 1 (0 points)

    figures, just after posting this I figured out how to fix it.




    In the Network Preferences panel, I clicked on the little "+" sign at the bottom, and up came choices - Display Ethernet was one.  Picked that and got my icon back but it said not connected.  Until I hit "Apply", then it worked!


    So I disconnected the display and hooked up the thunderbolt ethernet adaptor, did the same thing, and hit apply and it worked too!  yay!

  • blues_cook Level 1 (0 points)

    I also tried disconnecting the display and adding it back and rebooting - nothing worked.


    But here's a bizarre twist: I show "Bluetooth PAN" connected and active, and it's coming from the Thunderbolt display! I can get online. Then I disconnect the network cable from the display, and test again - no network. So somehow, the driver for Bluetooth PAN is totally confused with the display Ethernet. In fact, the Bluetooth PAN shows connected, and "No PAN devices found". So I'm connected to a phantom device.


    Maybe deleting the PAN and display, adding back the display, will get it to recognize it properly.


    The short of it is I have Ethernet connected now through the display, but using the Bluetooth PAN device driver.

  • blues_cook Level 1 (0 points)

    Ha, that worked. Deleted Bluetooth PAN and all display drivers after disconnecting the display. Connected it back, added Display Ethernet, and it's working. The problem was that crazy Bluetooth pan connection.