0 Replies Latest reply: Oct 19, 2012 7:29 AM by amesj22
amesj22 Level 1 Level 1 (0 points)

I'm not sure if this is a server or dekstop question because I'm not sure where the problem is, but I'll start here.

 

I have a user that cannot delete files on his desktop, and now can't change his desktop background.  He is a networked user on a 10.6.2 iMac.  His account is on a Mac OS X 10.6.8 server.  When I try to delete the file, it prompts for administrator authentication.  I enter it in, but nothing happens.  No errors appear and the file doesn't delete.  When I look at the details, it says "com.apple.desktopservices".  I have done the following things:

 

1.  Reapplied rights to his folder in the Get Info Box

2.  Deleted him from Workgroup Manager and re-created his account

3.  Checked that the file isn't locked

4.  Checked that the desktop folder isn't locked

5.  Verified his permissions are correct on all folders

6.  Ran Disk Utility on his machine

7.  Tried his account on another machine (same result as on his machine)

 

Based on another forum, I moved the com.apple.desktop.plist file out of his library and logged him in again. The only thing that I noticed is the background picture changed back to default.  I moved the file back, but the desktop picture is still back to default and if I go into System Prefences, I can't change the background or screen saver.

 

Something is messed up somewhere with his desktop settings, but I can't figure out where.  Does anyone have any ideas?


iMac, Mac OS X (10.6.8)