Previous 1 2 Next 19 Replies Latest reply: Oct 4, 2013 7:37 AM by silvio d
das5473 Level 1 Level 1

Certain songs that play in my itunes library will not play on my ipod classic.  They used to play on my ipod, but no longer do.  I noticed that itunes said they were all encoded with unknown, so i encoded them with itune to aac.  I synced these, but they still did not play.  I reset my ipod and resynced, still no.  I restored my entire ipod, still no.  Any ideas?


iPod classic (120 GB), Windows Vista
  • planb77 Level 7 Level 7

    What format were these tracks originally encoded in and at what bitrate?  Do these tracks (old version and/or new version) play all the way through in iTunes without any issues?

     

    B-rock

  • das5473 Level 1 Level 1

    they were originally mp3 and256 kbps.  both old and new play flawlessly in iTunes.

  • planb77 Level 7 Level 7

    Run these MP3 files through MP3 validator to see if they are healthy files.

    http://www.gromkov.com/faq/repair/mp3_validator.html

     

    B-rock

  • iPoduser77 Level 1 Level 1

    Well, here's something interesting to consider. Bought a new iPod classic two months ago (old one's battery going bad). Put the exact same songs & playlists on the new iPod that I had on the old iPod. Started listening to it through my car's AUX input...but something didn't seem right. I started watching the screen and noticed certain songs were being skipped. Then, at home (listening as I type this), plugged it into the AUX input of my computer speakers instead of playing through iTunes on the computer. Same problem...certain songs were being skipped. I began making a list of the songs being skipped and here is what I am discovering: The songs I put on it from my own collection play fine; the ones I purchased on line from iTunes are the only ones (so far) that will not play. I reset the iPod, started playing again...same problem. I have yet to delete the songs from my iPod and reload them from iTunes...but this is really strange. I have no clue what is wrong.

  • planb77 Level 7 Level 7

    That is odd, but at least we know what files are causing the problems.  I assume these same files play okay in iTunes?  Some have been able this issue, by removing these tracks from their iTunes library and redownloading them (at no cost) via iCloud.  See here for more information on redownloading these past purchases.

    Downloading past purchases from the App Store, iBookstore, and iTunes Store

     

    B-rock

  • iPoduser77 Level 1 Level 1

    What I ended up doing is deleting the songs from my iPod, then add them back again from iTunes. So far, they are playing correctly.

  • planb77 Level 7 Level 7

    Good to know. Fingers crossed it stays that way.

     

    B-rock

  • bigmacj Level 1 Level 1

    I'm having the same problem (similar), but no resolution.

     

    All of the files that are older files won't play, mostly ripped from CDs. My last ipod classic played them just fine. I bought a new one last month and its not playing them.

     

    These files play perfectly on:

    itunes

    iphone 3G

    iphone 4

     

    I've even isolated it down to one song (for a sample) and put ONLY that song on the iphone 3G, ipod classic, and iphone 4, and the only problem is on the ipod classic.

     

    I have removed all songs from the classica, reset it, reformatted the hard drive, reinstalled softwared, just about everything i can think of. I'm happy to send the file to anyone who wants to trouble shoot with just a single song.

     

    This is really really frustrating, because i got the calssic so i can carry the old songs that I don't have room for on my iphone.

     

    Any help is appreciated.

     

    Thanks!

     

    Jeremy

  • planb77 Level 7 Level 7

    What format is the track in and what bit rate is it encoded?

     

    B-rock

  • bigmacj Level 1 Level 1

    MPEG-1, Layer 3

     

    192 kbps

  • planb77 Level 7 Level 7

    Try running this track through the MP3 Validator to make sure the file is not corrupted in any way. 

     

    Yes, it plays okay on other iDevices, but the iPod Classic handles audio playback different and can be a bit more picky about the files.

    http://www.gromkov.com/faq/repair/mp3_validator.html

     

    B-rock

  • bigmacj Level 1 Level 1

    Just did, file is good.

     

    Thanks for helping, btw.

  • planb77 Level 7 Level 7

    Try converting the file to another format and then syncing it over to your iPod to see if that makes a difference.

    iTunes: How to convert a song to a different file format

     

    B-rock

  • mthaynes Level 1 Level 1

    Just had the same problem with my iPod Classic.  After a bit of playing about I found that any song with a bit rate greater than 2000 kbps will not play on the classic, but will play on newer pods, iphones and in itunes.  I have about 30 of these.  I have reduced the bit rate on one of the files to 972kbps and it now plays fine.

     

    It appears the iPod classic software does not support a bit rate greater than 2000 kbps while the newer devices do.

     

    Not real happy about that since I just bought the classic for its capacity.  Since this is a current product, It would follow that Apple should provide a software update to manage this.  I can only assume that it would be software specific. 

Previous 1 2 Next