11 Replies Latest reply: Oct 25, 2012 8:35 AM by Ashley Aitken
Ashley Aitken Level 1 Level 1 (35 points)

Hi All,

 

I've diligently backed up our iPad and used TM to archive the backups. 

 

Unfortunately now, when I need to restore from a backup I am getting the following error from AppleMobileBackup:

 

ERROR: Restore message response: 102 mkdir error: No such file or directory (2) at path "/var/mobile/Library/SafeHarbor/com.omnigroup.OmniGraffle/Container/Documents/S ite Wireframe & Mockup.graffle/QuickLook" (MBErrorDomain/102)

 

From reading that it looks like it is having trouble creating a directory on the iPad for some reason. I guess something wasn't getting saved correctly in the backup and thus can't get restored properly or this iPad directory was in a strange state when it was backed up.

 

I've searched the Web and there are some similar problems to this with different details (e.g. can't rename file) for the 102 error but no real solution.

 

I've tried a number of my backups going back a number of months and they all seem to have this error. I guess something on the iPad got messed up a while back and all the backups since then have it included, unfortunatley.

 

I'm wondering if anyone has a solution that can help me complete this restore?

 

I'm really not worried about Omnigraffle, I would happily reinstall it, but don't want to lose the rest of the backup. 

 

I wonder if there is a way to make the backup continue / complete ignoring this error?

 

Or perhaps to remove everything with regards to Omnigraffle from the backup? 

 

Thanks for any suggestions.

 

Cheers,

Ashley.

 

PS Not really happy when I have backed up all these times and now it is not working.  I think Apple's restore software seems a bit too fragile and should work around issues like this to do the best it can.

 

This is for an iPad 1 with iOS5.1.1 restoring from latest iTunes on Mac OS X Server 10.6.8 Snow Leopard.

  • brassknucklenerd Level 1 Level 1 (10 points)

    I'm having the identical problem - iPad 1 (a brand new one, to replace my other one), restoring from a recent backup in iTunes, I get this error in the console:

     

    23/10/12 11:34:04.058 AM [0x0-0x183183].com.apple.iTunes: 2012-10-23 11:34:04.057 AppleMobileBackup[25584:503] ERROR: Restore message response: 102 mkdir error: No such file or directory (2) at path "/var/mobile/Library/SafeHarbor/com.omnigroup.OmniGraffle/Container/Documents/p scclean.com site architecture v1.graffle/QuickLook" (MBErrorDomain/102)

     

    which leads to these errors on the next lines:

     

    23/10/12 11:34:04.060 AM [0x0-0x183183].com.apple.iTunes: 2012-10-23 11:34:04.059 AppleMobileBackup[25584:503] WARNING: No MobileSync error code defined for error code: 102

     

    23/10/12 11:34:04.060 AM [0x0-0x183183].com.apple.iTunes: 2012-10-23 11:34:04.059 AppleMobileBackup[25584:503] ERROR: Restore error: -1

     

    23/10/12 11:34:26.817 AM iTunes: _NotificationSocketReadCallbackGCD (thread 0x7fff73995960): Unexpected connection closure...

     

    Common to our two errors:

     

    -- OmniGraffle app and an associated document (this is one of the documents I had synced between my iPad and MacBook Pro, I believe)

    -- I have a "." in the filename, you have a "&" - both sort of special characters

     

    Let's see what else might be common...

     

    -- That .graffle file for me isn't the only doc I had synced in the app (via iTunes), but I think it was the first in the list, alphabetically

    -- That .graffle file isn't the only doc I had synced in any app, but I think the others were all synced via iCloud (they were iWork files)

    -- I have Dropbox (the 3rd party app) running on my Mac and my iPad, and the parent folder for that .graffle file is in one of my Dropbox folders

     

    I'm going to try working with that file/directory, maybe sync my apps first, re-sync the OmniGraffle documents (they're un-synced with the hard resetting of my iPad), maybe try removing that file from my Mac or from the backup file itself.

     

    I spoke to Apple phone support, but they didn't have a solution for either forcing the restore to continue despite errors or for working around a particular file in the backup.

     

    Okay, here we go...

  • brassknucklenerd Level 1 Level 1 (10 points)

    Okay, tried manually creating the directory that was "not found" via Terminal (using sudo to create the directories, escaping the spaces with "\ "), the result is the same error in iTunes, but more errors (yay) in the console:

     

    23/10/12 12:34:18.511 PM [0x0-0x183183].com.apple.iTunes: 2012-10-23 12:34:18.510 AppleMobileBackup[28372:503] ERROR: Restore message response: 102 mkdir error: No such file or directory (2) at path "/var/mobile/Library/SafeHarbor/com.omnigroup.OmniGraffle/Container/Documents/p scclean.com site architecture v1.graffle/QuickLook" (MBErrorDomain/102)

     

    23/10/12 12:34:18.513 PM [0x0-0x183183].com.apple.iTunes: 2012-10-23 12:34:18.513 AppleMobileBackup[28372:503] WARNING: No MobileSync error code defined for error code: 102

     

    23/10/12 12:34:18.514 PM [0x0-0x183183].com.apple.iTunes: 2012-10-23 12:34:18.513 AppleMobileBackup[28372:503] ERROR: Restore error: -1

     

    23/10/12 12:34:26.639 PM com.apple.usbmuxd: MuxTCPInputSCE received RST for 0x9-49dbc6b2f91ca57ef06601a6010c66e0a83cd4d3@0x26200000:62078->0x100225230-iTun es/com.apple.iTunes:27651: handleConnectResult: failure - 61

     

    23/10/12 12:34:26.650 PM iTunes: AMDeviceConnect (thread 0x7fff73995960): Could not connect to lockdown port (62078) on device 9 - 49dbc6b2f91ca57ef06601a6010c66e0a83cd4d3: 0xe8000065.

     

    23/10/12 12:34:27.269 PM com.apple.usbmuxd: MuxTCPInputSCE received RST for 0x9-49dbc6b2f91ca57ef06601a6010c66e0a83cd4d3@0x26200000:62078->0x100225230-iTun es/com.apple.iTunes:27907: handleConnectResult: failure - 61

     

    23/10/12 12:34:27.270 PM iTunes: AMDeviceConnect (thread 0x7fff73995960): Could not connect to lockdown port (62078) on device 9 - 49dbc6b2f91ca57ef06601a6010c66e0a83cd4d3: 0xe8000065.

     

    23/10/12 12:34:41.282 PM iTunes: _NotificationSocketReadCallbackGCD (thread 0x7fff73995960): Unexpected connection closure...

     

    23/10/12 12:34:41.282 PM iTunes: _NotificationSocketReadCallbackGCD (thread 0x7fff73995960): Unexpected connection closure...

     

    23/10/12 12:34:42.293 PM [0x0-0x183183].com.apple.iTunes: Parent: Error or timeout on select

     

    23/10/12 12:34:42.303 PM [0x0-0x183183].com.apple.iTunes: Child with pid 26902 exited normally

     

    23/10/12 12:34:42.303 PM [0x0-0x183183].com.apple.iTunes: ATHostConnectionDestroy 0x7fd17c2919b0

     

     

    I notice we both have spaces in the filepath related to the error. Maybe something there, maybe not.

     

    I'm going to try syncing my apps, then re-syncing my docs, then restoring from backup.

  • Ashley Aitken Level 1 Level 1 (35 points)

    Hi BKN,

     

    Thanks for your post and sorry to hear you are in the same situation (but it's good not to be alone ;-)

     

    Some notes on your comments (can't seem to easily split quoted messages here):

     

    1. I don't  seem to get the "Unexpected connection closure..." error from iTunes that you get (not sure that is significant though)

     

    2. With regards to the special character(s) in the filename.  I have hex edited the manifest.mbdb and changed my "&" to a "A" in the filename and the problem still existed (with an "A" in the error path), so I hope we can rule that out. 

     

    3. I have not really used Omnigraffle iCloud syncing, just turned on iCloud at the end of the change-over period and haven't used it for file sync-ing (at least not that I know of), so perhaps can rule that out.

     

    4. I have Dropbox running on Mac and client is on iPad (and iPhones).  I don't think my Omnigraffle docs have come anywhere near Dropbox though, again not use Omnigraffle on iPad for a while.  Have used on Mac quite a bit though.

     

    5. I am still running Lion on my MacBook Pro and the machine doing the iTunes syncing is a Mac mini running Snow Leopard Server, so I think we can rule out iCloud issues, again since I haven't really gotten into iCloud yet. 

     

    I have done a lot of investigating and experimenting (with no luck unfortunately).  I have used iBackupRobot (free version that works well, click cancel past the registration dialogs to get full functionality I believe) and Hex Fiend as mentioned above. 

     

    I also tried another one (called iBackupRestore or something like that but it required mono and X, which I had, but ran very slowly and failed - I think it only works for iOS4 or less). So, don't try that.

     

    With iBackupRobot I extracted my problematic document and associated files. It gave me:

     

    Documents_Site Wireframe & Mockup.graffle

    Documents_Site Wireframe & Mockup.graffle_data.plist

    Documents_Site Wireframe & Mockup.graffle_data.plist.info

    Documents_Site Wireframe & Mockup.graffle_QuickLook_Preview.pdf

    Documents_Site Wireframe & Mockup.graffle_QuickLook_Preview.pdf.info

    Documents_Site Wireframe & Mockup.graffle.info

     

    _ is for /

     

    The .info files just contain details of the mapping from real filename to the hex filenames inside the backup (useful to find the files and remove them as I did, see below). 

     

    I noticed that the data.plist file seemed to be empty so I filled it with content from another data.plist file in Omnigraffle's documents.  Interestingly, the error message changed a bit then (IIRC) to this:

     

    20/10/12 10:47:40 PM[0x0-0x37b37b].com.apple.iTunes[4493]2012-10-20 22:47:40.605 AppleMobileBackup[30109:903] ERROR: Restore message response: 102 mkdir error: No such file or directory (2) at path "/var/mobile/Applications/8AF90D98-FB52-4E3E-877F-FD0A0F45C0A1/Documents/Site Wireframe & Mockup.graffle/QuickLook" (MBErrorDomain/102)

     

    Note the path no longer includes SafeHarbor (which I believe is the temporary storage area whilst apps are being loaded etc). So some progress but a very similar error.

     

    I have tried removing the hex-name files from the backup but MobileBackup detects them and says the backup is corrupt and will not proceed.  The problem is I can't see how we can edit the manifest.mbdb (apart from simple hex editing). 

     

    I've tried editing the plist files Manifest.plist and info.plist file (with Property List editor) but again no luck, deleting items (Omnigraffle application entries) is detected as a corrupt backup and MobileBackup will not proceed.

     

    It is interesting how it is the QuickLook folder that is listed in the error.  Mine contains a Preview.pdf file which seems to be fine. 

     

    I'm also not sure what the error message actually means.  I guess it mean that when trying to create the QuickLook directory the path up to there didn't exist (e.g. the "Site Wireframe & Mockup.graffle" directory or one of its parents didn't exist).

     

    I could be wrong though. 

     

    I visited an Apple Store and tried to talk to a Genius but didn't get much help from the iPad Genius (should have registered for a Mac Genius apparently), he admitted he wasn't a Mac or iPad Genius (good on him) and went out back to ask his guru colleague. 

     

    He came back and said his colleague thought the real error was the -1, which he said indicated a hardware fault. 

     

    I don't think they knew what they were talking about, on some Apple support pages it does refer to -1 being something about hardware / comms fault, but I also think it is just a catch-all error code for iTunes when it doesn't know what else to report. 

     

    He suggested trying on another iPad but I don't have one and he wouldn't let me use one of theirs. I guess I could buy one and return it after testing for a refund, but I doubt it is a hardware problem myself. 

     

    I was hoping they may have some secret way to force the restore to continue or to selectively ignore certain applications on restoring (which may come to iTunes one day I hope).  It seems the Apple stores don't specialise in this kind of suppor though. 

     

    He suggested ringing Apple phone support / Applecare but I wasn't too keen on trying to explain this and share details over the phone.  I might give it a go, even though you had no success because I might luck out on someone who knows more etc.

     

    I think I have done a full reset, sync'ed all apps and then tried the restore - fail.

     

    I have tried so many things I am now having trouble remembering what I tried and how each failed. 

     

    My restore seems to go pretty well for quite a while before it fails, so I think it is restoring it's just getting an error when doing this one document for Omnigraffle and can't get past that. 

     

    If we could stop it restoring Omnigraffle I think we would be good to go but, as mentioned above, I can't see how we could do that without some serious editing of the backup, especially the plists and manifest.mbdb, but I am not expert ont hose.

     

    Very sad to hear that Apple had no ways to work around a file or error.  I think it is a fault in their restore software - it is too fragile, not catching the said error and fixing the directory path. But I am not holding my breathe for them to assist (but will try to get help).

     

    Thanks for your notes and please keep me informed of how you go / if I can help in anyway. 

     

    Unfortunately, I am very busy at work these days and can only work on this on the weekends.

     

    Cheers,

    Ashley.

  • brassknucklenerd Level 1 Level 1 (10 points)

    Oh... when I let all my apps sync, the shared documents are restored, but the document in question isn't in the list. Two others are, one of which includes a space in the filename, but neither of which include a "."

     

    Both those docs appear on my iPad in OmniGraffle, but when I click on the icon, it says "a file is missing or has been deleted".

     

    Tried re-adding the broken (zero Kb) files plus the missing "problem" file and re-syncing, then tried restoring from backup. Got this:

     

    23/10/12 1:32:51.921 PM [0x0-0x183183].com.apple.iTunes: 2012-10-23 13:32:51.920 AppleMobileBackup[30665:503] ERROR: Restore message response: 101 lstat error: Not a directory (20) at path "/var/mobile/Applications/05628E6C-76E0-494B-9E37-CD8F902CF7E9/Documents/psccle an.com site architecture v1.graffle/QuickLook" (MBErrorDomain/101)

     

    23/10/12 1:32:51.923 PM [0x0-0x183183].com.apple.iTunes: 2012-10-23 13:32:51.922 AppleMobileBackup[30665:503] WARNING: No MobileSync error code defined for error code: 101

     

    23/10/12 1:32:51.923 PM [0x0-0x183183].com.apple.iTunes: 2012-10-23 13:32:51.922 AppleMobileBackup[30665:503] ERROR: Restore error: -1

     

    23/10/12 1:33:14.710 PM iTunes: _NotificationSocketReadCallbackGCD (thread 0x7fff73995960): Unexpected connection closure...

     

    23/10/12 1:33:14.710 PM iTunes: _NotificationSocketReadCallbackGCD (thread 0x7fff73995960): Unexpected connection closure...

     

    23/10/12 1:33:15.514 PM [0x0-0x183183].com.apple.iTunes: Parent: Error or timeout on select

     

    23/10/12 1:33:15.521 PM [0x0-0x183183].com.apple.iTunes: Child with pid 28497 exited normally

     

    23/10/12 1:33:15.521 PM [0x0-0x183183].com.apple.iTunes: ATHostConnectionDestroy 0x7fd17c2efd40

     

     

    Ugh.

  • Ashley Aitken Level 1 Level 1 (35 points)

    Are you creating the directory on the iPad? Have you jailbreak'ed your iPad.  That is where the problem is occurring I believe ... unless you know more about how iTunes restores?

     

    Spaces and special characters can be a problem with Unix commands if they are not quoted properly, but I would assume millions would be having this problem if that was the cause.

     

    I wonder if we (I will) should contact Omnigroup and ask them if they have anything to do with this or have any experience (seems strange that it is Omnigraffle for both of us).

  • brassknucklenerd Level 1 Level 1 (10 points)

    I'm creating the directory on my Mac, using iTerm (a Terminal app). My iPad isn't jailbroken. In fact it's only been out of the box for a day. And I got the same error whether I tried to restore to a completely wiped iPad, a set-up but empty iPad, or after syncing my apps. So I don't think it's the iPad.

     

    I sent a support request to OmniGroup earlier today, actually, with a link to this thread. They've got a support backlog right now, but hopefully they'll get back sooner rather than later. I'll post any useful response from them here.

     

    I've got another meeting with a Mac Genius tomorrow. I explained the situation over the phone when making the booking, to be sure they understood that not just any old geek will do. We need an iPad restoring supernerd.

     

    Another thing I tried that didn't work: repairing permissions. Same error message in iTunes.

     

    And I agree about the special characters. It was a long shot, and if it's related, it's not the only problem. And you're right - more users would be having this problem, surely. No, there's something about OmniGraffle.

  • Ashley Aitken Level 1 Level 1 (35 points)

    Ok, I am comfortable at the command line but I don't know much about the iTunes iOS restore process.  My iPad is not jailbroken either. 

     

    Do you see these directories/files being created on your Mac during the restore process (and then probably get copied over to the iPad)?  I will have a look and try next time. 

     

    I'm not sure how restore works but I thought the directories were being created on the iPad during the restore process.  Perhaps iTunes (MobileBackup) mounts the iPad's file system or similar.

     

    Good to rule out iPad hardware. As I mentioned, I think it is the restore software being too fragile when confronted with something strange in the Omnigraffle document. 

     

    Good luck with the Mac Genius - I am not confident you will get very far but worth a try.  I was hoping they would have some extra software to analyse a backup or install without iTunes etc.

     

    Unfortunately, as mentioned, can't investigate further until the weekend. 

  • brassknucklenerd Level 1 Level 1 (10 points)

    Hi Ashley,

     

    Well, we can definitely rule out a hardware issue. I went back to the Apple store and tried to restore to another iPad 1, same error.

     

    I knew next to nothing about the restore process as of a couple hours ago, but I'm figuring it out, I think. I'm currently continuing what you started - parsing the backup files and trying to find a way to modify them so that the problem file is gone.

     

    The filenames in the backup folder are all just strings of characters, but they do seem to have filetypes. I'm using "iPhone Backup Viewer" to go through the files in the backup folder, then using Text Wrangler to modify the .plist files and deleting the others. Looks like the problem file is mentioned in the general plist file for the app (in the app's Library/Preferences folder), so hopefully if we can edit that reference out as well, it'll work.

     

    I'll post the results...

  • Ashley Aitken Level 1 Level 1 (35 points)

    Ok, not hardware (thought so).

     

    I can't recall exactly but I think the name of the backup directory (hex filename) may somehow be created based on the contents, i.e. some sort of hash.  I got stumped by that at one stage.

     

    As mentioned, I found iBackupBot to be good for viewing (and editing the backed up files in) the backup. 

     

    There seems to be a mapping from the hex filenames to the real filenames in the manifest.mbdb binary file. iBackupBot will export an info file to tell you the hex name for each real file exported. 

     

    I also submitted support request to Omnigroup and got a quick reply - they haven't heard of this problem.  He suggested deleting the QuickLook folder but as we know this is easier said than done.

     

    I reckon Apple must be working on a way to selectively restore (or not) applications from backups.  It just makes not sense to have to lose all current data to restore one application's data.

     

    Pity Apple don't read these forums.  That said, I might submit a bug / support request to Apple directly, and see what happens.

  • brassknucklenerd Level 1 Level 1 (10 points)

    So close and yet so far...

     

    I'm trying to edit OmniGraffle out of the backup completely. The Info.plist and Manifest.plist files are straightforward to edit, but we need a way to edit Manifest.mbdb itself, or the restore will always be looking for OmniGraffle:

     

    25/10/12 10:44:16.775 AM [0x0-0x3e03e].com.apple.iTunes: 2012-10-25 10:44:16.773 AppleMobileBackup[12882:503] ERROR: Restore message response: 205 App domain com.omnigroup.OmniGraffle without an entry in manifest properties (MBErrorDomain/205)

     

    This gives some information on the content of mbdb files:

     

    http://code.google.com/p/iphonebackupbrowser/wiki/MbdbMbdxFormat

     

    So this breaks down what contents in the mbdb file are expected to be strings or integers (unsigned 8,16,32, or 64 bit). If we can find a way to see the raw file content (pico or another Terminal editor?) we might be able to track down and remove the correct data around the string "OmniGraffle".

  • Ashley Aitken Level 1 Level 1 (35 points)

    Yes, the manifest.mbdb file is the problem and, being binary, any editing of it (beside swapping characters etc.) is very problematic.  I got the same error.

     

    I used "Hex Fiend" (for Macs) to edit the file. 

     

    It is a free hex editor that allows you to easily search and replace hex / strings etc.  But deleting stuff can cause problems.

     

    If I had more time I could write a program to read the manifest.mbdb, make some changes, and then write it out again but that may still not work.