Previous 1 2 3 Next 43 Replies Latest reply: Sep 4, 2013 5:42 AM by Leonardo Gabiati
andrew89 Level 1 (0 points)

Recently updated my iPhone 4 to iOS 6.  A person's birthday showed up twice, then 3x, 4x, now 6x in my calendar.  I can't delete any of them and they keep multiplying.


I enabled Facebook integration when I updated to iOS 6.


I am not using iCloud.  iCloud Contacts and Calendars sync are off.


My calendar syncs to gMail.


If I go to my Google calendar online, the birthday shows up only once.


4x duplicate birthdays:  Calendar - my gmail account.  Accepted: Contacts

2x Calendar - my gmail account


All of the duplicate events have the same note "Today is Jane Doe's birthday!"


The "correct" birthday comes from the iPhone contact.


Capitalization of the events are slightly different.  With the one from the iPhone contact, it reads like "Jane Doe's Birthday". All of the duplicates have a lower-case "b" - "Jane Doe's birthday".


At first I thought it might have something to do with FB integration, but one person's birthday is listed 6x whose info is only in my iPhone contacts - he doesn't have a FB account.  Oddly enough, people who I'm FB friends with, but didn't have an iPhone contact for before iOS6, their birthdays only show up once.

  • EyeMustDecrease Level 1 (0 points)

    I'm having this very issue. It seems to be related to the way local calendars are interacting with the Google Calendars, and I can't figure out how to make it stop. VERY annoying.


    In the meantime:

    -I've turned off CalDav (Exchange doesn't work with it either) and downloaded Calendars by Readle

    -To get rid of the dupes en masse, I've turned on iCloud, merged the calendars, went into iCloud calendars and deleted all but one of the calendars so I can get rid of the dupes. Then, I created a new calendar and deleted the last remaining calendar. Hope that makes sense.


    It's a terrible solution, but it's the best I've got for now.

  • ahazelrigg Level 1 (0 points)

    This started for me today when I added a "subscribed" calendar.  If I deselect the subscribed calendar then the duplicates go away.  I did this on both my wife's and my phone - added the subscription calendar and birthday duplicates.  So strange.

  • wizwilson Level 1 (10 points)

    Same here. So annoying. I'm syncing google calendars via Gmail as well as Facebook events on a 4S running iOS 6.


    I'm now getting two, no wait four, no wait six..................well, duplicate versions of all birthdays, you get the idea.


    Each of these duplicates is added to the main calender account.


    The only workaround that I've found is to dump the standard calendar app and use CalAlarm or similar for calendar.


    My iPad (iOS 5) has no such issues, nor does my wifes 3GS running iOS 6. 

  • Kirsten Johnson Level 1 (20 points)

    Same problem on 3GS. I use iCal to sync my gmail calendars. I have 22 birthday entries for each of my contacts now. :-(  I loaded ios6 a while back, but the problem started yesterday when i said yes to integrating faceBook. I currently have FB uninstalled under settings and no contacts or calendar sync in there.

  • Kirsten Johnson Level 1 (20 points)

    I fixed it on my phone! While in Calendar app, click Calendars. If I only have 4 or less calendars checked, life is good. Select more than that and the dupes are back.

  • Kirsten Johnson Level 1 (20 points)

    Couple more notes. I started seeing dupes again, but was able to get rid of them by saving settings in iphoneselect google web page. E.g. Uncheck and recheck birthday secondary calendar and press save. I was also able to recreate the problem by selecting the birthday calendar with the red package icon under iPhone calendars. Note that when I had the problem earlier this was NOT selected. Seems to be really flaky behavior with the calendar right now.

  • wizwilson Level 1 (10 points)

    Ok, so after tinkering about here's the score:


    Any five calendars selected, no issues


    Any six calendars selected, major duplication of birthdays. These can be any six calendars. You don't even need any of them to be a birthday calendar or even the calendar into which the duplicates are being created!


    Very wierd


    I'll try deselecting and reselecting on the google web page and report back.

  • andrew89 Level 1 (0 points)

    Per someone's suggestion I have only 3 calendars picked and am up to 12 dupes per person. Gmail calendar. Facebook events and iPhone contacts


    One that keeps coming back even though I uncheck it is Gmail Contacts Birthdays and ... calendar

  • wizwilson Level 1 (10 points)

    Ok........sorted it.


    Here's what I did:


    1. Go to and deselect all calendars.


    2. Go to your iPhone calendar, select calendars at the top right and deselect all calendars.


    3. Go to Settings>Mail, Contacts, Calendars>and then either GMail or Exchange (whichever you have enabled your calendar through.


    4. Now turn off your calendar. You'll get a warning that everything will be deleted, but that's ok.


    5. Now go back to the Google web page and select the calendars that you want to sync but don't select either of the ones to do with birthdays listed under Shared Calendars as your iPhone will generate these anyway.


    6. Go back to your calender account settings on iPhone and turn calendar back on again.


    7. Go back to your calendars on iPhone and select which ones you want to sync.


    Et voila..........crazy duplicate birthdays gone :-)

  • wizwilson Level 1 (10 points)

    Sorry, step 2, Calenders is in the top left, not top right :-)

  • EyeMustDecrease Level 1 (0 points)

    Does it continue to work? I've been able to "fix" it a few times, but the dupes return after some time.

  • andrew89 Level 1 (0 points)

    The Google calendar iphone calendar sync settings is well-hidden.  Don't know why this isn't visible in the calendar mobile setup page.


    Following wizwilson's suggestion and unselecting "Contacts' birthdays and events" from the iphone select page seems to have done the trick.


    Note: problem isn't solved.  This is only a work-around.  Either Google or Apple are at fault here and a fix is still required.

  • andrew89 Level 1 (0 points)

    I confirm wizwilson's findings that you don't have to have a birthday calendar active to see the duplicates.


    I added a few read-only shared calendars on the google iphone select screen (US Holidays and 4 sports team schedules).  I started getting the duplicates for the sports teams (duplicates with more than 1 calendar).


    Issue seems to be related to:

    • iOS6
    • GMail calendar
    • Never (?) with the GMail primary calendar ("My Calendar")
    • Happens only (?) with shared calendars AND if more than 4 (5?) calendars are selected in the iPhone calendar setup.


    Have 3 calendars selected (iPhone Contacts Birthdays, GMail "My Calendar", GMail US Holidays") and am not seeing any duplicates.   The "All GMail" calendar is also selected, but I didn't count that one.  In the Google iphoneselect settings, I'm only selecting "My Calendar" and one shared calendar to sync with the iphone.

  • wizwilson Level 1 (10 points)

    Between steps 4 and 5, reopen your calendar, press calendars in the top left. You should now have one calendar active called 'my calendar' or something similar. Click on the blue circle next to it and then click 'delete calendar'. Now continue from step 5 :-)

Previous 1 2 3 Next