1 Reply Latest reply: Oct 20, 2012 7:04 AM by QuickTimeKirk
patrick_patrick Level 1 Level 1 (0 points)

I have 10.7.5 & 10.8.2.  I'm having issues with some 3rd party software CaptureOne.  I spoke with them & they said I need to go back to 10.7.4. Can I go back with this download?