1 2 Previous Next 17 Replies Latest reply: Jun 21, 2013 3:51 PM by YossiHalevi Go to original post
  • 15. Re: AppStore submissions fail after Java Update 2012-006 1.0
    Psychojam123 Level 1 Level 1 (0 points)

    Hi fr8tdog, Thx Thx Thx Thx , you save my life !!!

  • 16. Re: AppStore submissions fail after Java Update 2012-006 1.0
    YossiHalevi Level 1 Level 1 (0 points)

    Hi friends

    I had this problem in the past and i fixed it (I don't remember how)

    Since then i uploaded many times with no problem.

    Today I wanted to upload new version to my app and, !!X$%X!!, it back...

    In my folder "JavaVirtualMachines" it shows only "1.6.0.jdk"

    This is the bug:

    Error:

              /Applications/Xcode 2.app/Contents/Applications/Application Loader.app/Contents/MacOS/itms/bin/iTMSTransporter: line 14: awk: command not found

              /Applications/Xcode 2.app/Contents/Applications/Application Loader.app/Contents/MacOS/itms/bin/iTMSTransporter: line 18: ../share/

    When i try this:

    cd /System/Library/Frameworks/JavaVM.framework/Versions

    sudo ln -s CurrentJDK /System/Library/Frameworks/JavaVM.framework/Versions/1.5

    sudo ln -s CurrentJDK /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0

    It says:

    ln: /System/Library/Frameworks/JavaVM.framework/Versions/1.5/CurrentJDK: File exists

    Same when i try 1.6 instead of 1.5

    I don't know what to do...

    Any help...please..

  • 17. Re: AppStore submissions fail after Java Update 2012-006 1.0
    YossiHalevi Level 1 Level 1 (0 points)

    Viola!!!!  I solved it...

     

    Using:

     

    GNU nano2.0.6 File: ...app/Contents/MacOS/itms/bin/iTMSTransporter          

     

    #!/bin/sh

     

    # if the user has the run script in their PATH

    # then we can get the path to the script from

    # 'which'.  otherwise, we have to get the path

    # from $0

    if [ "$0" = "iTMSTransporter" ] ; then

      SCRIPT_PATH=`which iTMSTransporter`

    else

      SCRIPT_PATH=$0

    fi

     

    # get the script's directory

    SCRIPT_DIR=`echo $SCRIPT_PATH | /usr/bin/awk -F"/" '{print substr($0,1,length($$

     

    # call the transporter relative to the script's directory

    #echo Calling: ${SCRIPT_DIR}../share/iTMSTransporter.woa/iTMSTransporter "$@"

    "${SCRIPT_DIR}../share/iTMSTransporter.woa/iTMSTransporter" "$@"

    #"/Applications/Xcode.app/Contents/Applications/Application Loader.app/Contents$

1 2 Previous Next