2 Replies Latest reply: Oct 21, 2012 6:45 AM by KannaSL
KannaSL Level 1 (0 points)

While updating my iphone 3GS to iOS 6 (from iOS 4.1) this msg popped up. "Only compatible sim cards from a supported carrier may be used to activate iphone......". I have been using this iphone with the existing sim card which wored perfectly. I'm is Sri Lanka and "Dialog" is my carrier network. What can I do to make my iphone work?

iPhone 3GS, iOS 4.1