1 Reply Latest reply: Oct 21, 2012 8:40 AM by Klaus1
Clarerunner Level 1 Level 1 (0 points)

I have an imac (2009) with OS X 10.5.8 and i need to install the new itunes (10.7) in order to sync my new nano (7th generation).  Do I have to upgrade my software to Snow Leopard in order to run itunes 10.7?  How to I go about this?


iMac, Mac OS X (10.5.8)