14 Replies Latest reply: Oct 27, 2012 2:27 PM by Tasman Traveller
Tasman Traveller Level 1 (0 points)

Hi all

When I try opening a number of games on my iMac, I am getting the error message (for example COD) "Call of Duty 4 - Modern Warfare" is damaged and can't be opened.  Delete "Call of Duty 4 - Modern Warfare and download it again from the App Store"

COD4 error.jpg

The last tme I used these apps/games (specifically Call Of Duty 4, Doom 3 and Battlefield 2012) was months ago... apart from COD4 which I definitely fired up and was working 6 weeks ago.  (Don't play games much!)


I have searched for the answer, and most similar problems are associated with Gatekeeper - i.e. setting to allow install from amy location.  But two of these apps are from the AppStore (I bought Battlefield elsewhere).


I have tried;-

* Deleting/Download the app again from AppStore

* Setting Gatekeeper to "Allow Applications Downloaded from anywhere" (Always had this setting)

* Running Disk Utility "Repair Disk Permissions"

* Using AppCleaner to delete all settings as well as the App (**** going to lose my place in the game!)

- Also deleting the trash.  Then re-downloading/Installing.


It's really weird that none of my other Apps apart from these 3 games get the error.

I Installed COD4 on my Macbook Air which is the same OSX/Update level (latest) and it WORKS.  So something is specifically wrong with my iMac


I'm wondering if there are any OSX security/java/whatever updates which could have affected this  But once again it all works on my Macbook Air.

Are there any files/settings that Appcleaner misses that I could reset/delete and try again?





24-inch, Early 2008

Processor  3.06 GHz Intel Core 2 Duo

Memory  6 GB 800 MHz DDR2 SDRAM

Graphics  NVIDIA GeForce 8800 GS 512 MB

Software  OS X 10.8.2 (12C60)

iMac, OS X Mountain Lion (10.8.2), 24-inch, Early 2008, 6GB RAM
  • Linc Davis Level 10 (192,335 points)

    "AppCleaner," like almost all "utilities" for the Mac, is useless, or worse than useless. Get rid of it.


    When you re-downloaded these apps, did you delete them first? If not, try that.

  • Tasman Traveller Level 1 (0 points)

    Yes as my post said I deleted app, and settings, and emptied the trash before re downloading/installing.

    I was recommended Appcleaner by Appstore Apple support.  I quite like it - even for just seeing where an App places stuff.

  • Linc Davis Level 10 (192,335 points)

    Launch the Terminal application in any of the following ways:


    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.


    Triple-click the line below to select it, then drag or copy into the Terminal window — do not type — and press the  space bar:


    codesign -vv


    Now switch to the Finder and drag one of the problem apps into the Terminal window. More text will be added to what you entered.


    Click in the Terminal window to activate it, then press return.


    Post any lines of output that appear below what you entered — the text, please, not a screenshot.

  • Tasman Traveller Level 1 (0 points)

    Here we go...


    Last login: Mon Oct 22 12:15:22 on console

    BigMac:~ george_cook_jnr$ codesign -vv /Applications/Call\ of\ Duty\ 4.app

    /Applications/Call of Duty 4.app: valid on disk

    /Applications/Call of Duty 4.app: satisfies its Designated Requirement

    BigMac:~ george_cook_jnr$

  • Linc Davis Level 10 (192,335 points)

    Please enter this command in the same way as before:


    ls -Oel !$/Contents/MacOS

  • Tasman Traveller Level 1 (0 points)

    Hi - wan't quite sure if you wanted me to drag/append the app into the window again, so I tried both the command you gave and then separately the command with the app appended...


    Last login: Mon Oct 22 14:12:34 on ttys000

    BigMac:~ george_cook_jnr$ ls -Oel !$/Contents/MacOS

    ls -Oel /Applications/Call\ of\ Duty\ 4.app/Contents/MacOS

    total 4704

    -rwxr-xr-x  1 root  wheel  compressed 6120528 21 Oct 12:00 Call of Duty 4

    -rwxr-xr-x  1 root  wheel  compressed  225152 21 Oct 12:00 libBinkMachOx86.dylib

    BigMac:~ george_cook_jnr$

    BigMac:~ george_cook_jnr$

    BigMac:~ george_cook_jnr$ ls -Oel !$/Contents/MacOS /Applications/Call\ of\ Duty\ 4.app

    ls -Oel /Applications/Call\ of\ Duty\ 4.app/Contents/MacOS/Contents/MacOS /Applications/Call\ of\ Duty\ 4.app

    ls: /Applications/Call of Duty 4.app/Contents/MacOS/Contents/MacOS: No such file or directory

    /Applications/Call of Duty 4.app:

    total 0

    drwxr-xr-x  8 root  wheel  - 374 21 Oct 12:00 Contents

    BigMac:~ george_cook_jnr$

  • Linc Davis Level 10 (192,335 points)

    Please read this whole message before doing anything.


    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.


    Step 1


    The purpose of this step is to determine whether the problem is localized to your user account.


    Enable guest logins* and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up guest users” (without the quotes) in the search box. Don't use the Safari-only “Guest User” login created by “Find My Mac.”


    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.


    Test while logged in as Guest. Same problem?


    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.


    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.


    Step 2


    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.


    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:


    1. Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    2. When you see the gray Apple logo, release the shift key.
    3. If you are prompted to log in, type your password, and then hold down the shift key again as you click Log in.


    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.


    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.


    *Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.


    Test while in safe mode. Same problem?


    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • Tasman Traveller Level 1 (0 points)

    Thanks for working with me on this...


    Negative for all results.  i.e. Logging into Guest a/c same problem.  Booting in Safe Mode same problem, and now booted as normal same problem.

    Nothing plugged into the iMac except mouse & k/b.  The only mod to this machine is OWC memory upgrade to 6 gig.  That was 9 months ago and I have played all apps fine since this mod.

  • Linc Davis Level 10 (192,335 points)

    When you deleted the problem apps, did you use the method recommended by Apple?


    How to remove Mac App Store apps that appear in Launchpad


    I've seen various reports of this issue. It seems to have different causes. In some cases, it's caused by a bug in the App Store:


    Corrupt App Store binaries crashing on launch


    Sometimes the app itself is incompatible with the current version of OS X:


    Repeated message "Kaspersky Virus Scanner" is damaged


    Sometimes the user files created by the application are corrupt or out of date, but that's not the case here. Sometimes the system keychain has been tampered with, or the system has otherwise been corrupted:


    Mac App Store - App Damaged and Can't...: Apple Support Communities

    I deleted my Mac App Store certificates...: Apple Support Communities


    I suggest you use the Apple-approved method of deleting the apps, which removes the hidden receipt associated with the app as well as the app itself. If that doesn't work, contact the respective developers.

  • Tasman Traveller Level 1 (0 points)

    Thanks for those suggestions.

    Deleting via Launchpad didn't work.

    I have a feeling that the App Store Certificates may be the issue.  But I am only speculating.

    Is there a way to clean up Keychain?


    I tried to re-install OSX from the AppStore to clean all the system stuff up but it will "not update a newer version".


    So... right now I'm not in the frame of mind to completely re-install my system from scratch (as per the regular Windows re-install days!) just to get these games working.  But seeing as the original install of my apps/OSX was 2008 maybe I should do that sometime in the near future.


    Don't think it's a developer issue... or an AppStore issue...  as it happens with a number of apps... one of which (Battlefied) was bought before Appstore days.  Also they on my Macbook Air.


    So must be some kind of deep security/certificate/corruption on my iMac.


    I will carry on ferreting around to see if there is a solution and I will post back when/if I find it.  Don't hold your breath!

  • Tasman Traveller Level 1 (0 points)

    Oops - Forget my failed OSX installed last post I was trying to install Lion over Mountain Lion


    Anyway, I did deleted COD4 again, emptied the trash, then a complete re-install of Mountain Lion over my current setup (i.e. preserving apps and user files), downloaded COD4 from AppsStore... SAME PROBLEM!


    So back to zero.  I guess a complete CLEAN reinstall is sometime the only answer.  That new iMac looks good...

  • Linc Davis Level 10 (192,335 points)

    Did you try to contact any of the app developers?

  • Tasman Traveller Level 1 (0 points)

    Yes I've logged it with Aspyr... they requested a system report and I'm currently waiting for feedback.


    Meanwhile... I contacted Apple Tech support and we went through some tests...  e.g.

    Set up a new user a/c with admin access... same problem

    Re-installed Mountain Lion booting from recovery disk and choosing Time Machine restore... same problem.


    Finally I decided that seeing as I have not rebuilt this machine from scratch since buying it in 2008 I relented and carried out a full clean fresh rebuild....


    Booted from recovery disk, deleted OSX partition, installed Mountain Lion from new.

    Started the slow painful process of installing apps and copying over data.

    But (just for the **** of it) I started with downloading COD4 from AppStore.

    Guess what.  SAME PROBLEM!!!!!!!!!!!!

    Can't you believe it?  It makes absolutely no sense or logic.


    Well, I will continue rebuilding my new machine.  But feeling miffed and ripped off!  Still waiting on Developer but starting to think there is a conspiracy!  Need a drink...

  • Tasman Traveller Level 1 (0 points)

    The short answer:

    My OSX partition was formatted Mac OS Extended (Case-Sensitive, Journaled), instead of Mac OS Extended (Journaled).


    The Long answer:

    How ths came about is simply a self-inflicted wound... User Error!  At some point in the last couple of months I decided to do a de-frag.  I used SuperDuper to image my drive, and copied it back to the iMac.  This has worked well in the past - carried it out a couple of times over the years.

    BUT.... somehow I formatted a drive... maybe the external SuperDuper drive... wrongly.  This may be because of normally formatting TimeMachine drives to Case-Sensitive... and perhaps I was in autopilot mode and formatted the SuperDuper drive the same way... and it was imaged back to the Mac the same... not sure but I think thats what happened.


    The weird things in all this...

    1) The fact that only my games did not work with the wrong format and everything else did.... maybe because they were originally ported from Windows???

    2) Even though in the last week I booted from my recovery disk and re-installed Mountain Lion (once using Time-Machine, once a clean install) there was no warning in the Lion install to tell me I was installing to the wrong format.  Apple take a 1% blame here


    I finally fixed it by up booting to the SuperDuper drive, formatting the iMac drive to Mac OS Extended, installing Mountain Lion to the iMac drive and finally migrating all files from my Time Machine.

    It's all back 100% and COD4 works a treat


    My thanks to Aspyr for analysing my log files and pointing out the error.  And thanks Linc for the help on the way really appreciated mate.