1 Reply Latest reply: Oct 22, 2012 12:58 PM by BDAqua
quaidbilal Level 1 Level 1 (0 points)

My imac some time boot up with light only or with question mark but doesn't load operating system.  I checked apple wireless mouse and key board both switched on with green light. Please help me to troubleshoot the issue.

 

Thanks in advance

  • BDAqua Level 10 Level 10 (119,400 points)

    Hello,

     

    Could be many things, we should start with this...

     

    "Try Disk Utility

     

    1. Insert the Mac OS X Install disc, then restart the computer while holding the C key.

    2. When your computer finishes starting up from the disc, choose Disk Utility from the Installer menu at top of the screen. (In Mac OS X 10.4 or later, you must select your language first.)

    *Important: Do not click Continue in the first screen of the Installer. If you do, you must restart from the disc again to access Disk Utility.*

    3. Click the First Aid tab.

    4. Select your Mac OS X volume.

    5. Click Repair Disk, (not Repair Permissions). Disk Utility checks and repairs the disk."

     

    http://docs.info.apple.com/article.html?artnum=106214

     

    Then try a Safe Boot, (holding Shift key down at bootup), run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions, reboot when it completes.

     

    (Safe boot may stay on the gray radian for a long time, let it go, it's trying to repair the Hard Drive.)

     

    If perchance you can't find your install Disc, at least try it from the Safe Boot part onward.

     

     

    If 10.7.0 or later...

     

    Bootup holding CMD+r, or the Option/alt key to boot from the Restore partition & use Disk Utility from there to Repair the Disk, then Repair Permissions.