Previous 1 2 Next 18 Replies Latest reply: Apr 12, 2014 6:03 AM by JimJohnMarks
Wilbur Pan Level 1 (20 points)

Because of the security issues with Java, I uninstalled Java 6 (using various terminal commands) and installed Java 7 from Oracle's website. Looking at /Library/Internet Plug-Ins, I can see that JavaAppletPlugin.plugin is there, and Get Info tells me that it is part of Java 7 Update 09.


However, when I use Safari to try out a Java test page, or use one of the Java-based programs that I need to run for work, I get a message that says, "To open “PluginProcess,” you need a Java SE 6 runtime. Would you like to install one now?"  (PluginProcess is replaced by the program name if I am running a Java program.) If I click "Install", the Apple version of Java 6 gets installed.


This doesn't make sense to me. Why would Java 7 need the Apple Java 6 environment? And why doesn't Safari or other Java based programs recognize that the Java 7 JavaAppletPlugin.plugin is on my computer already?


Although I'm not really an IT person, I am pretty handy with the Terminal and command line operations, so if fixing this means using the command line, I'm good with that.



  • Wilbur Pan Level 1 (20 points)

    Bumping just in case someone can help me this morning.

  • vkehayas Level 1 (60 points)
  • Wilbur Pan Level 1 (20 points)

    Thanks. I saw that article. It's not exactly what I want. The article shows how to move from Java 7 back to Java 6. I want to move to Java 7, but OS X keeps asking me to install a Java 6 component.

  • Wilbur Pan Level 1 (20 points)

    Just in case, I followed the directions at the bottom of the page under To disable Java SE 6 Web Start opening and reinstalled Java 7 from Oracle's site.


    This is what I see in terminal:


    $ java -version

    java version "1.7.0_09"

    Java(TM) SE Runtime Environment (build 1.7.0_09-b05)

    Java HotSpot(TM) 64-Bit Server VM (build 23.5-b02, mixed mode)


    So I do have Java 7 installed.


    But when I go to a Java test page, I get this:


    Screen Shot 2012-10-24 at 5.14.23 PM.png



  • Wilbur Pan Level 1 (20 points)

    Bumping just in case anyone riding out hurricane Sandy is looking for something to do.

  • kallekilponen Level 1 (0 points)

    I'm having the same exact problem. Doesn't anyone have a solution?

  • Adam Polgar Level 1 (100 points)

    Wilbur, Kallekilponen:  I have experienced the exact same issue. I started with a brand-new Mac mini, fresh out of the box. It did not have Java of any sort installed. I installed Oracle's Java 7.9, but could not run any of our work Java applets, or anything Java-related at all, and it prompted me to install Apple's Java SE 6, apparently ignoring my Oracle Java 7 install.  After poking and prodding around, I have come to the conclusion that our problem doesn't actually exist, per se. I believe the dialog that is scaring us with the prospect of re-infecting our systems with the insecure Java 6 is actually misleading in the way it is phrased, as it does not install Java 6 if only Java 7 is present. It merely "completes" the initial Java 7 install by adding some system-level Java prerequisites that were missing.  The behavior seems to be as follows:  On systems with no Java:  • install Apple's Java SE 6, and prerequisite system files that enable Java to run  On systems with Java 7 (and nothing else):  •  install only prerequisite system files that enable Java to run  In fact, the installer seems to be smart enough to know that I only want to use Java 7, and performs a clean-up to remove Java 6-related files that I will not use! For example, my fresh install had the Java Preferences app in Applications/Utilities. This Java app is used to manage Apple's Java 6. It is part of a default OS X install, but as a Java app itself, does not run without Java, and brings up the familiar "Install Java SE 6" prompt. However, after following through with the prompt's install, this app is removed, because the installer knows you will not be using it, as Oracle's Java 7 is managed from System Preferences instead.  Long story short, it looks like there's nothing to worry about! On a system with just Oracle's Java 7 installed, it should actually say "You need to configure Java by downloading some support files". It does not (re-)install Apple's Java 6.  I hope this information is helpful! :)

  • Rémy Schumm Level 1 (5 points)

    for me, this update did re-installt JDK 6 under /System/Library/Java/JavaVirtualMachines/1.6.0.jdk even though JDK 7 is installed under /Library/Java/JavaVirtualMachines/jdk1.7.0_09.jdk


    Applets run under jdk 7 now, but Java Applications under JDK 6.

    Removing jdk 6 brings up the mentionend "Need JDK 6 update-Panel" again. So: no JDK 7 without JDK 6 for me.

  • steven.D Level 1 (0 points)

    I think I've found a solution to the problem that Java Applications doesn't use Java 7. This seems to work for me. Try it and please confirm if it works for you.



    Install Java SE Development Kit 7u9 from Oracle .html



    Execute something that triggers the prompt to install Java SE 6. for example i web site using java applet. And follow through with the installation. (after this you will have three java versions: Java6 32-bit, Java6 64-bit, Java7 64-bit)



    Open a new terminal window and execute the following commands.


    $ cd /System/Library/Frameworks/JavaVM.framework/Versions

    $ sudo rm CurrentJDK

    Password: ********

    $ sudo ln -s /Library/Java/JavaVirtualMachines/jdk1.7.0_09.jdk/Contents/ CurrentJDK

    $ sudo ln -s CurrentJDK 1.7

    $ sudo ln -s CurrentJDK 1.7.0



    Note: I don't know if the last two lines are necessary, but I just tried to follow the existing pattern.

  • Rey Bango Level 1 (0 points)

    Adam, this is not what I've experienced. On a brand new mahcine, I installed Oracle's latest version of Java (7u10) and was still prompted. I then read I needed the JDK so I installed that which gave me the Java 7 preference pane and going to Terminal showed Java as 1.7. Even with that, when I tried to run a desktop app, I was prompted for Apple's 1.6 JRE.


    Only after installing Apple's JRE did the app work. And yes, I verified that the 1.6 files were in the System folder. So I don't think it's simply wrapping up a 1.7 install. It's actually installing 1.6 which, IMO, makes no sense.



  • VicT77 Level 1 (0 points)

    Rey is correct. I experienced the same exact problem with Jdownloader.  Even with the 1.7 JDK installed from Java, it keeps prompting you to install Apple's 1.6 (and this also with the terminal showing 1.7 as the current version as Rey had mentioned).


    Now I have both versions installed in the system and it is near impossible to remove Apple's version because after you install it, not only does it create the 1.6 JDK (which you can simply move to the trash), it creates a gazillion symlinks to files with this JDK all over your directory. You would think that by installing the latest Java version, all previous versions would be removed and all the applications which use Java will now use this latest version.  It seems absolutely ridiculous that Apple and Java can't get their act together and solve this simple versioning issue that is non existent on the most basic PC.


    If anyone has figured out how to completely remove Apple's 1.6 Java including all the symlinks linking to it, please let know?

  • kelhak1 Level 2 (215 points)

    I did'nt have any alert to install java6 after installing 7u11 which they say fixes the security issues.


    7u11 still doesn't work on pogo for me. ****, I wanted to practice gambling.



  • martinfrompoole Level 1 (140 points)

    Apple are blocking the Java Browser plug-in due to continuing security issues: pread-security-threat/


    7u11 only fixes the issue that was actively be exploited, there are a number of others still not fixed; as this isn't the first (or second) major security allert over Java, I can't see Apple unblocking it until Oracle has demonstrated Java has been properly fixed.

  • VicT77 Level 1 (0 points)



    Safari allows you to run Java with or ironically if you are using Apple's outdated 1.6 version.  It only blocks you if you are using a Java version previous to (from Oracle only).


    Kelhak- The alerts only come up if you are running a Java program on your Mac like Jdownloader. Even if you have the JDK (vs the lighter JRE) installed, it will still b**tch about installing 1.6.  I have since gotten rid of Jdownloader and am using Folx.  So now, I'd like to get rid of Apple's 1.6, but it looks like its going to be an impossible task since it creates dozens of symlinks all across the system.

Previous 1 2 Next