9 Replies Latest reply: Oct 23, 2012 3:10 PM by storme
storme Level 1 Level 1 (0 points)

I am trying to drag files off my GoPro onto mac desktop. It is allowing me to do some, but one one file i keep getting an error saying i have ejected the device, then iphoto pops up and i cannot move the file. (file is not locked btw).

 

I've tried going to PREFERENCES to select iphoto to NOT open when i connect a device, but every time i click PREFERENCES it crashes.

 

I read on the forums that i should reinstall lion. So i have done that and it is STILL crashing upon opening, so i cannot deslect it to open every time i connect a device. I don't even use iphoto and it is driving me crazy. It always pops up when i connect my iphone as well and i want it to stop.

 

Anyone have any other suggestions? Surely a second Lion Install is not going to change things?

 

If anyone has any other advice about dragging a 3gb file off my GoPro that is 100% not locked (all the other files on it drag over easily), i'd appreciate it. To confirm i am NOT knocking the usb connection/definitely NOT accidentally ejecting the GoPro.

 

This all seems somehow related to iphoto given i get the "did not eject properly" error followed by error -31 and -42 when transfering this file and then iphoto opens immediately...

 

HELP!

 

THANK YOU!

 

p.s - i have the most up to date iphoto.


MacBook Pro, Mac OS X (10.7.2)
  • storme Level 1 Level 1 (0 points)

    I have also now reboot in SAFE MODE, tried setting up a new user account and iphoto works just fine in that, I have also tried moving the library and rebooting from automatic backup... all as per other threads on forums...

     

    nothing works. As soon as you open iphoto and go to PREFERENCES it crashes. It is impossible for me to use iphoto (not that i really use it) or set it to NOT open when attaching an external HD.

     

    Any ideas anyone?

  • Old Toad Level 10 Level 10 (124,125 points)

    Try this:  launch iPhoto with the Option key held down and create a new, test library.  Try to import photos from your camera and check to see if the same problem persists.

     

    OT

  • storme Level 1 Level 1 (0 points)

    Hey Toad

     

    I did that before... I saved the new library to my EX Harddrive but then when i reopened it it didn't offer me an option to choose which library to choose? It just opened as usual, i assume using the original library.

     

    From what i can tell from forums, it is a problem with the library.

     

    Am i meant to copy the current library to a new location (which i have done), then delete the original library that's in PICTURES? And then reopen? Will that offer me the option to select the new library?

     

    Many thanks!

  • Old Toad Level 10 Level 10 (124,125 points)

    To change libraries you need to hold down the Option(Alt) key while launching iPhoto.  Then you'll be given the chace of selecting which library to open:

    iP11optionopen.PNG

     

    Let's get on the same page.  You can't import photos from your camera into your current library, right?  Specifically you have a 3GB file on your camera that you can't get off the camera, right?  Does your camera have a memory card that you can use with a card reader? That would be the best solution.  It may not be iPhoto at all but the fact that the one file is so large.

     

     

     

    OT

  • storme Level 1 Level 1 (0 points)

    Hey Toad,

     

    thanks for that. It is still crashing as soon as i hit PREFERENCES!

     

    Argh! i've tried everything it seems?

     

    New Account Log in

    Recovered Library from automatic Back Up

    Reinstalled Lion

    Rebooted in Safe Mode

    Opened with alt and selected a second copy of the same library....

     

    Really not sure what else to do?!

  • Old Toad Level 10 Level 10 (124,125 points)

    Give this a go:  make a temporary, backup copy (if you don't already have a backup copy) of the library and try the following:

     

    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home()/Library/ Preferences folder.

     

    2 - delete iPhoto's cache file, Cache.db, that is located in your

         User/Home()/Library/Caches/com.apple.iPhoto folder. 

     

    Click to view full size

     

    3 - launch iPhoto and try again.

     

    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.

     

    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.

  • storme Level 1 Level 1 (0 points)

    Thank you toad. I will try this! But can you tell me how to get the TERMINAL up??

     

    Thank you!

  • storme Level 1 Level 1 (0 points)

    Oh i've found it... trying out the rest now.

  • storme Level 1 Level 1 (0 points)

    Hi Toad,

     

    So the same problem is happening. I followed your instructions, then reopened with ALT and new iphoto library. As soon as i click on preferences it crashes and i get iphoto not responding.

     

    So frustrating. All i want to do is select it so it doesn't try and open whenever i attached my iphone/hard drive because it crashes everything!

     

    I imagine there is nothing left for me to do as it seems i've tried everything, but if you can think of anything else, i'd glad take the suggestion.