Previous 1 2 Next 20 Replies Latest reply: Nov 6, 2015 10:36 AM by bondingfortoday Go to original post
  • LAFfer Level 1 (10 points)

    I've deleted my Google account from my iPhone, iPad, iMac and MacBook.  I've turned off Birthday calendar on everything.


    Now I go to iCloud Calendar, on the web and I still have multiple birthday entries. 


    It looks like a bug in iCloud itself to me.  ios 6 and Mountain Lion are just reflecting it.


    I've just given up on using Birthdays until they fix it.  Just part of a growing list of Apple doesn't work right anymore.

  • Vaiofan Level 1 (5 points)

    I don't think it's related to iCloud. I don't use iCloud for calendar, and I still have this issue. Most people in the other threads on the issue don't use iCloud either.

    What I imagine could be in your case is that your iCloud calendar on the phone picks up all the "stray" calendar entries and syncs them into the cloud.

    As you have noticed, deleting any or even all calendars doesn't help. These duplicate entries are stray, they don't belong to any calendar and thus can't be deleted by deleting / removing calendars. In one of the threads here there was a solution posted which was supposed to delete these stray entries too, but it didn't work for me. Only thing that does it is resetting the device to factory defaults and NOT restore from backup (the backup includes all stray events).

  • crw83001 Level 1 (0 points)

    Fixed my issue too, and it was driving me nuts! Thanks for the solution.

  • Ronson1909 Level 1 (0 points)

    I had all the same problems and tried all suggestions but was not able to delete the recurring events until I found this post



    and the hint to iCloud (although I don't use it). So what I did - apart from all the other hints in this thread - was to remove all accounts (or at least all calendar syncs), and then sync to iCloud (actually first I removed the account, readded it and then turned on calendar sync). Then the multiple entries disappeared and I could reconnect all other accounts.


    Hope this helps.

  • jlehrer Level 1 (0 points)

    I have tried everything and have been unable to remove the duplicate birthday entries from my iPhone 5.  If the native iPhone birthday calendar is enabled then I see multiple entries for every birthday.  What's worse, each time the calendars refresh, another entry is created for the same birthday.


    The only solution is to turn off the native iPhone birthday calendar and turn on the GMAIL calendar named "Contacts' birthdays and events (Read Only)".


    I had this problem when I first got my iPhone and had to completely wipe it and start from scratch.  Now, 6 months later, the problem is back.  I also believe I know what causes the problem.


    Old, working setup (calendars controled on each device):


    Each calendar I want to sync is added as an account on my iPhone, or as a subscribed calendar.  E.g. tripit, Holidays, sports calendars, google calendar, etc...  Running the calendar app, going to "calendars" then checking each one on, including the "Birthdays" calendar, works fine.


    This was a headache because I effectively did the same thing in google calendars on my laptop, subscribing to each calendar.  I had the identical setup in two places.  So, I decided to do it the "right" way.



    Broken setup (calendars controlled by google):


    I removed all calendars from my iPhone by turning off google calendars in settings/accounts.  I confirmed that all of my calendars were properly configured in  Then I went to this URL:



    and enabled all of the calendars, including "Contacts' birthdays and events (Read Only)"


    I then re-enable google calendars on the iPhone.  Now, all of the calendars are listed in the calendars app under the account "google".


    This is when all of the birthdays in the iPhone native birthday calendar (the one with the birthday cake) started multiplying.


    At this point I found no way to remove these multiple entries, even though I have tried everything everyone has posted here.  The only fix is to turn off the iPhone native birthday calendar.  The google one is better anyway. 



    Even if I remove the google account completely and use only the native iPhone calendar, the duplicate birthday entries still exist.



  • bondingfortoday Level 1 (5 points)

    I was able to finally get rid of the duplicate Birthday calendars the following way.


    1. Turn off all calendars on your iOS device in Settings > Mail, Contacts, Calendars

    2. Create a complete backup of your iOS device on your computer with iTunes.

    3. Make a copy of the backup folder

    4. Download and install iBackupbot on your computer

    5. Delete the Calendar folder and all Calendar items out of the backup as shown in the screenshots.


    6. Reset your iOS device and use the edited backup to restore it.

Previous 1 2 Next