3 Replies Latest reply: Nov 29, 2012 1:59 PM by TRA2010
TRA2010 Level 1 Level 1 (0 points)

I have a Lion Server (10.7.4) that has several users and has been working for almost a year. All of a sudden 1 user is unable to edit his calendar, but other users are working fine. All his other services are working fine (mail, contacts).

If he adds entries via PC or iPad they do not appear on the web interface and are not synced between iPad and PC, so they remain only local to the device it is created on.

If I open his calendar via the web interface then I can see his entries up until this problem started but cannot edit or add new entries. The ones created after this problem on the iPad or PC do not appear.

If I send an invitation from another user then it appears in the web interface of the calendar.

I have looked at the Caldav log and can see no error message. No error comes up on the PC or iPad either.


I have connected from another iPad but the same problem.


There have been no recent software changes on the server.

He has 1 PC and 2 iPads connecting with his UID to this calendar. He has a secretary with Read/Write access. All this was working perfectly.

The only recent change has been adding several additional delegation users to his calendar with Read access.


To me it looks like his UID only has READ access to his calendar.


I have tried rebooting the server but no difference. I have also tried removing his access to the iCal service and adding it back.


I'm stuck on how to get this working, short of deleting/recreating his UID but then concerned with loosing his data.

I've been searching the forums but find no assistance yet.

MacBook Pro, Mac OS X (10.7.3), Server
  • TRA2010 Level 1 Level 1 (0 points)

    All the access till now has been with a windows client, iPad or server web interface. The users home PC was recently upgraded to 10.8. I have not had a chance to see if this is getting the same error. The server is running 10.7.4, however I think the problem started just before this.


    On further testing with a Mac iCal Client I now get the following error message:

    The server responded: “403”. to operation CalDAVWriteEntityQueueableOperation


    I see a couple of threads discussing this error but have not found one with a solution yet on how to re-instate the ACL on the calendar. It seems that it got a lot more complex since 10.7 moved iCal to a database.


    Looks like the only way around this is going to be delete the user and recreate the account. Not the most elegant way of fixing this.

  • TRA2010 Level 1 Level 1 (0 points)

    After scouring the web for days I was unable to find a solution to this problem. I was about to delete the users account on the server and recreate but that is a huge effort considering email etc that must be backed up and restored.

    Then I discovered a simple solution. I was unable to fix the existing calender access but what I did was create a 2nd calendar (Calendar2) in iCal for the user. The user had full access to the new calendar. So essentially had 2 calendars and was able to edit his existing appointments in the original (now read only) calendar and move them to his new calendar.

    I still don't know why this happened but at least this is a simple and workable solution.

  • TRA2010 Level 1 Level 1 (0 points)

    Turns out that the above solution was fine for the users own calendar entries but when others sent invites they defaulted to the old calendar and it was not possible to change this or move the events.


    I eventually had to backup all the users email, calendar and contacts. Then DELETE the user account on the server and create a NEW one. Connect to his new mail account and upload all his data.


    After that everything was working as normal.


    Not the most elegant solution but it did work.