Previous 1 2 3 Next 39 Replies Latest reply: Oct 25, 2012 7:15 PM by zvandiver
Morac Level 1 Level 1

I updated to iBooks 3.0 on my iPhone 4S and iPad 2, both running iOS 6.0.  Everything is fine on my iPhone, but on my iPad the "Purchased Books" collection is empty.  The books I had downloaded were in my Books collection and the all books show up in the purchased area of the store, but nothing shows up in the library purchased area. In addition, some books I had downloaded showed as not being installed in the purchased area of the store.

 

I tried deleting all books off my iPad, but that didn't help.   I noticed the books I deleted off my iPad showed up in the books area on my iPhone (but not downloaded).  When I delete books of my iPhone it asks me if I want to delete them off all devices, but I don't get that option when deleting books on my iPad.  Despite that, collections do appear to sync, though not instantly, and deletions on the iPad do eventually show up on the iPhone.

 

I tried removing iBooks on my iPad, restarting the iPad and reinstalling, but that didn't fix the problem. It also didn't remove any of the PDFs I had on my iPad.   It also seemed to cause the books I deleted on my iPad to show up on my iPhone.

 

It seems like my iPad's book area is corrupt somehow.  How can I fix this?


iPad 2, iOS 6, AT&T 64 GB
Solved by Morac on Oct 24, 2012 5:08 AM Solved

The iCloud restore finished and I update to iBooks 3.0 and now everything works, so it looks like a restore will fix this.  I did initially set up as a new iPad first and test iBooks.  I don't know if that was required or not, but since it doesn't take much more time it might be a good idea to try.

 

Here's what I did:

1. Set iPad into DFU mode (because it wouldn't boot, dunno if this is needed)

2. Restore iOS 6

3. Set up as new and install iBooks and test (works)

4. Go to Reset -> all media and settings

5. After reboot restore from latest iCloud Backup and wait a long time.

6. Upgrade to iBook 3.0 (works)

 

I haven't synced with iTunes yet so hopefully that doesn't break it.   I'm still convinced it broke do to a bug when upgrading from iOS 5.1.1 to iOS 6 OTA, but this will fix it.

Reply by Morac on Oct 23, 2012 9:49 PM Helpful

Since I did a restore I decided to set up my iPad as a new device and try iBooks.  The "Purchased Books" collection populated correctly so  it appears that is a "fix", albeit not the best one.

Reply by EricOtown on Oct 24, 2012 10:02 AM Helpful

I have a solution that doesn't involve a full wipe and restore of you device. After a frustrating phone call to Apple tech support, I finally found the solution. After I fully explained this issue in detail, the first tech support person that I spoke with told me that they can't support every app because their are over 250,000 apps in the App Store. She asked me who makes iBooks. I'm not kidding. This was a big surprise as I have always received excellent support from Apple from very knowledgable support people. This worried me that Apple has not been able to keep up with their explosive growth within their tech support department.

 

Anyway after explaining to her that iBooks is actually an Apple app, she still was no help as I was having to explain to her the basic functions and features of ibooks. She surely could not understand the new features if she didn't even know ibooks existed. So finally she transferred me to her supervisor and I told him that a full wipe and restore was not an option and that I would rather live without this feature as otherwise ibooks seemed to be functioning. At first he just recommend that I download purchased books from the ibooks store, "Purchased" tab, "Not on this iPad" tab. I explained to him that if Apple rolls out a new feature, my expectation is that I should be able to use that feature.

 

So after of continued to push back on the full wipe and restore solution, he finally recommended that I try to just "Reset All Settings" in iPad "Settings" app, "General", "Reset, "Reset All Settings". This was more palatable to me as it only takes about 20 minutes for me to get all more settings back to they way they were before the Reset. Things like wifi, background pic, lock screen pic, and other general settings. My email, contacts, calendar accounts all stayed on the iPad as well as all my data, documents, and Apps as well as folders and app positioning on my iPad all stayed as is before the reset. Long story short, after I did this reset settings, reentered my wifi settings, and Apple ID for ibooks, this problem was solved and all my Purchased Books not on my iPad, now appear in both the regular book shelf and the new bookshelf called "Purchased books". They have a little iCloud icon in the upper right hand corner of the book cover. Just make sure that you set this feature to "On" in your Settings app in the ibooks settings. It's called "Show All Purchases". I hope this works for everyone else.

All replies

  • ericupton Level 1 Level 1

    Mine just crashes over and over and over...

     

    Reinstalled. Rebooted. No clue how to make it work. It appears to have started after failing to download the books...

     

    Definitely disappointed.

  • WalrusC Level 1 Level 1

    Experiencing this exact same issue on my iPad 2; no problems with my iPhone 5. Have tried reinstalling, rebooting, etc. No luck.

  • Morac Level 1 Level 1

    I'm convinced the app is broken on the iPad 2.  I tried using iExplorer to wipe out the Books folder and iOS recreated it and it still didn't work.  I even tried copying the folder from my iPhone to my iPad and it still didn't work.

     

    Collections and bookmarks are syncing (i.e. download a book on my iPad and it shows up on my iPhone with a download icon) and my purchases show up in the purchased area in the Store so iCloud is working, but the app simply refuses to show me purchased books in the library.

  • Scott Stein1 Level 1 Level 1

    I am having similar problem on ipad 3 and also one of my iPhone 5's but not the other one I have. Very strange if anyone has solution please advise

  • EricOtown Level 1 Level 1

    Morac, I have an iPhone and iPad and I am having the identical issues that you described. Exactly. I'm glad I read your post because I was getting ready to delete iBooks from my iPad and reinstall. You saved me the time. I was also concerned that my hundreds of personal PDFs would be deleted as well. I don't use iTunes sync/backup anymore and as far as I know I can't do a selective restore from icloud of just my I iBooks PDFs without wiping and restoring my entire iPad from icloud.

     

    I am not convinced, as you said, that iBooks 3.0 for iPad has a huge bug and they will be issuing 3.1 within a week or so hopefully. My iPhone seems to be working fine as far as I can tell. This is disappointing that this bug didn't get weeded out in testing before they announce this at a huge apple event and it goes live in the App Store. I am also still having the same issue with iBooks 3.0 that I did with the prior versions where I have problems downloading PDFs into ibooks using "open in". About 50% of the time after selecting iBooks in "open in" for a PDF from mail, Internet, or another app, iBooks will open but the PDF never appears. This only happens on my iPad not iPhone. I typically have to close iBooks in the App Switcher and try again and again until usually after multiple tries it works. I have found that it happens mostly of iBooks is open in the background.

  • WalrusC Level 1 Level 1

    From what I am starting to gather, it appears the issue MAY be a multiple devices issue. My iPhone 5 was my first to be updated, and it works fine. My iPad 2 was next, and it is having all the trouble. Hearing similar stories with different devices, common theme being first device updated being fine, thereafter not so much.

  • Morac Level 1 Level 1

    Just a FYI.  When I deleted and reinstalled iBooks, all my PDFs were still there.  They aren't stored in the iBooks app which is why I thought maybe my iBooks data was corrupted.  So basically if you uninstall and reinstall iBook, you shouldn't lose the pdfs.  I didn't, but I can't guarantee that you won't.

     

    iBooks is a universal app so there's a separate executables for the iPhone and iPad in the same app.  Apparently the app is just buggy and Apple never bothered to test it with an iPad. 

     

    Has anyone had it work on an iPad and if so what model?

  • Morac Level 1 Level 1

    I updated in that order as well, but I don't think the order has anything to do with it.  The app should be able to show purchased apps regardless if syncing with iCloud is enabled or not.  Personally my iCloud account and my iTunes account use different Apple ID's.

  • EricOtown Level 1 Level 1

    I updated my iPad first and the purchased books bookshelf was empty. Then in updated my iPhone and it worked fine. I have also tripled checked that the "Sync Purchased Books" button was set to "On" in my iPad Settings. It is. I even tried to turn it off and back on a few times. Closed iBooks running in the background. Rebooted my iPad. Deleted and reinstalled some books. Nothing works. Maybe they just forgot to turn on the icloud sync server for iPads purchased books. Who knows. 

  • EricOtown Level 1 Level 1

    Ok now I have another issue that wasn't there before. Now I see a number 2 in ibooks on the button for "Store". I believe this is supposed to indicate that publishers have an update available for a books, but when I click the Store button with the number 2 it takes me to the ibooks store but I don't see any where to go for  "Updates" to books. I scanned all of my books in the "Purchased" section and none have an "update" indicator. Any suggestions? This number 2 definitely wasn't there for the first couple hours after I updated to ibooks 3.0. It sounds like Apple may still be pushing out changes to ibooks thru their servers. Perhaps this issue with Purchased Books not showing up on the bookshelf on iPads will be fixed by morning. This may not require an updated version of ibooks. It's likely something that can be pushed out over Apples icloud servers that are pushing the "Purchased Books" in the first place. Just like minor changes to the App Store sometimes happen without an iOS update.

  • Morac Level 1 Level 1

    Well I decided to do a "restore from backup" on my iPad 2 in case I messed something up and that was a bad idea since now my iPad won't even turn on.  I'm trying to do a DFU restore now.  I'm really annoyed since I just made a backup on my PC three days ago. 

     

    I have an iCloud backup, which I think I'll try to restore from first.  Hopefully that works.  Really annoying though.

  • Morac Level 1 Level 1

    Since I did a restore I decided to set up my iPad as a new device and try iBooks.  The "Purchased Books" collection populated correctly so  it appears that is a "fix", albeit not the best one.

  • Michael Fata Level 1 Level 1

    It looks like I'm the opposite. The Purchased Books section populated just fine on my iPad 3, but on my iPhone 5 it's empty. I tried deleting and re-installing the app on the iPhone but it still won't populate. To add insult to injury, I grabbed my wife's iPhone 4S and installed iBooks 3.0 and hers populated perfectly. We share the same Apple ID on all our iOS devices. If I go into the Store on my iPhone all the books show up on the Purchased tab like they always have. Very frustrating!

  • EricOtown Level 1 Level 1

    I have to check my other iPad and iPhones. I only check my main iPad and iPhone that I use. I also have another iPad and two other iPhones that my wife and kids use but share my Apple ID. I'm curious if they are working. So far my main iPad is not and my main iPhone is.

Previous 1 2 3 Next