Previous 1 3 4 5 6 7 8 Next 108 Replies Latest reply: Jan 31, 2016 5:38 PM by Bella0406 Go to original post
  • mightymilk Level 1 (20 points)

    I'm weary to do that, since I'd be opening up my browser to malicious websites, but it's getting to the point that I'm avoiding websites that have any built-in Facebook functionality, which now a days is most sites.  Still looking into it though, it's actually not affecting me right now... seems to come and go.

  • canucksgirl01 Level 1 (55 points)

    I can understand your hesitation, however the FB certificate only applies to Facebook (and FB functionality on a website), so you can safely accept that certificate (and it will apply to all instances).

     

    Regarding malicious websites, if you visit a website that's using a fake certificate (regardless of whether they use Facebook functionality or not), you would get a unique alert from Safari about the problem, and it wouldn't be affected by your acceptance of the Facebook Certificate (because a website requires their own certificate). They are independent of eachother.

     

    I hope that helps.

  • mightymilk Level 1 (20 points)

    I was under the impression I had to make an exception for all Certificates, hence my hesitation.  If there's a way to select which Certificates are marked as always allow... Then I have no issue doing that.

     

    Cheers

  • canucksgirl01 Level 1 (55 points)

    When you select "always allow" or "never allow" under the "Trust" section of a certificate, it ONLY applies to that certificate, which is why it says "When using this certificate"...

     

    It will not create an exception for every certificate Safari checks.

  • MsVanessa Level 1 (0 points)

    Hi, what do I do when my iPad 2 has "invalid URL" (similar problem with my Mac which you helped fix with going into Terminal and paste that empty cache message). I can't find Terminal on my iPad 2.

     

    Thanks.

  • MadMacs0 Level 5 (4,722 points)

    MsVanessa wrote:

     

    Hi, what do I do when my iPad 2 has "invalid URL" (similar problem with my Mac which you helped fix with going into Terminal and paste that empty cache message). I can't find Terminal on my iPad 2.

    You should really post this to a different forum as this one only covers Mac OS, but a quick answer is that there is no way to enter command lines on an iOS device that I'm aware of. I doubt Apple would allow a third party app that could do this.

     

    You may be having issues with your router or whatever DNS server your ISP uses. Try changing your DNS settings.

  • canucksgirl01 Level 1 (55 points)

    Terminal isn't included on iPad, so I'm not sure what else you could do to get it working. Like MadMacs0 suggested, you may want to post this as a new question in the iPad section. Chances are someone has a solution for you over there.

  • LouOpps Level 1 (0 points)

    I found a solution that fixed the error for me. I had changed the date and time on my Ipad which seemed to mess everything up. Go into settings, general, date and time, and turn set automatically to on. Once i switched this back on the error message went away.

  • resmith Level 1 (0 points)

    I see no menu choice for KeyChain Access. OS 10.8.3. Safari 6.0.4. I can't even connect to the App Store because it says I have no Internet connection (but I do!).

  • MadMacs0 Level 5 (4,722 points)

    resmith wrote:

     

    I see no menu choice for KeyChain Access.

    I don't see where anybody said there was a menu choice.

     

    KeyChain Access is an app located in /Applications/Utilities/. You have to open it to take the steps outlined by canucksgirl01.

  • resmith Level 1 (0 points)

    I seem to have resolved this irritating problem simply by clicking on "Set date and time automatically" in Date & Time of System Preferences. How and why this has resolved the problem makes no sense to me, but I'm certainly glad it has.

  • canucksgirl01 Level 1 (55 points)

    @resmith - The reason it fixed the problem is because website certificates are dated (with a start date and expiry date). If your computer has the wrong date, it will think the certificate is invalid and will alert you to that fact.

  • resmith Level 1 (0 points)

    Thanks for the explanation. Fixing the problem wasn't intuitive when I was struggling to figure it out, but your explanation makes sense and clears up a big mystery for me.

  • canucksgirl01 Level 1 (55 points)

    You're welcome. Glad I could help.

  • Ruliyah Level 1 (0 points)

    Dear MadMacs0,

     

    I have the problem since four weeks with my yahoo email: no access possible. Certificate warning shows up etc. The solutions of Keychain access, time and date don't work because Key Chain Access doesn't detect a problem and Time and Date is already automatically set: changing this and back did not help. It is ridiculous to have it and I don't understand that Apple doesn't fix it! My IMac 27 inch is three months old.

     

    Facebook, I don't have.

     

    Would you please so kind to tell how to get my yahoo email again without interfering with my hotmail which is working fine. I am now 3 months on IMac/Apple so brand new.

     

    Thanks and kind regards

Previous 1 3 4 5 6 7 8 Next