3 Replies Latest reply: Mar 4, 2013 5:29 PM by monick
monick Level 1 (0 points)

I would like to buy Imovie, and I need to know if it will work with my current OS.

On the app store in requirements it says 1.7.4 or later? Is that true???

I'm not looking to upgrade my OS as my iMac is too old, probably not eligible.

Mac OS X (10.6.8), Imac 23' Core 2 Duo