6 Replies Latest reply: Oct 25, 2012 5:29 AM by LeftyInNC
LeftyInNC Level 1 (0 points)

I'm trying to install the printer driver for my OfficeJet Pro L7580 and keep getting the above message.

I'm going into System Prefs, Print & Scan, Add a printer...  it discovers my printer as a Bonjour printer, and says that Apple has the software for this printer, but two increments into the progress bar, it fails with the above message.

 

How do I install support for my printer?


MacBook Pro, OS X Mountain Lion (10.8.2)
  • PAHU Level 6 (16,105 points)

    You could download the HP Driver v2.12 package from Apple. This download has drivers for a large number of HP devices including your L7580, so the download is 439MB in total.

     

    If you don't want to use a large chunk of your monthly limit and just get the driver for your model of HP then try to add the printer  later. Maybe there is just network congestion in your region and this is causing the install to fail.

  • minny-mo Level 1 (0 points)

    I'm getting the same message in relation to attempting to load drivers for a Brother MFC. I manually found and loaded the drivers then attempted to add the printer however Preferences automatically attempts to download them again and comes up with the same error message. I can't find the location of the drivers on my computer so that I can manually direct the printer manager to use the loaded drivers.

  • LeftyInNC Level 1 (0 points)

    Forgive a novice Mac user -- to what "monthly limit" do you refer?  I hadn't heard about any limit on downloads.

  • minny-mo Level 1 (0 points)

    I believe Pahu is referring to his/her monthly data allowance for his/her broadband plan. For eg. for those subscribing to Bigpond 5gb, almost 500 Mg is a chunk. For those of us on higher allowances (allowances jump to at least 50gb after that) it's not even worth considering.

  • LeftyInNC Level 1 (0 points)

    Thanks -- I know Apple does a lot of stuff differently than most in the industry -- i don't get too surprised when they surprise me any more.

  • LeftyInNC Level 1 (0 points)

    After not working yesterday and the day before, today it worked.  Perhaps it was network congestion.  <shrug>

    Thanks for the prompt responses!