12 Replies Latest reply: Oct 30, 2012 7:50 PM by macjack
eklektostoworship Level 1 Level 1

Every time I reboot TextEdit opens automatically.  I do NOT select reopen windows when logging back in.   I also do NOT have it in my startup programs under my login name.

 

Does anyone have a clue how to fix this?

 

V 10.7.5

 

Thanks


MacBook Pro, Mac OS X (10.7.5)
  • macjack Level 9 Level 9

    Luanch Terminal in your Utilities folder.

    At the prompt copy & paste

    defaults write com.apple.TextEdit.savedState NSQuitAlwaysKeepsWindows -bool false

    Press retun and test.


  • eklektostoworship Level 1 Level 1

    MacJack.. I did as you asked and now TextEdit and Safari are opening opening automatically.  TextEdit is now opening with the last file info that was placed in it as to before it was just opening a blank edit page.

     

    Any thoughts?

  • macjack Level 9 Level 9

    OK. Let's try this...copy & paste this command at the prompt and press return.

    defaults write -app 'TextEdit' ApplePersistence -bool no

    Now restart.

     

    If for some reason this doesn't work (but I bet it will) In System Preferences > General there is a hard-to-find checkbox under "Number of recent items" you can turn off. (Also, you can hold the shift key when logging in to disable resume on a one time basis.)

     

    Another way to accomplish this is through Finder by going to ~/Library/Saved Application State/TextEdit and delete that file…or any other app, like Safari.

    (note that the User Library is hidden - so go to your Finder "Go" menu hold the option key to choose "Library") The go to "Saved Application State" folder and delete the files for TextEdit and Safari.

     

    Or to turn off Resume globally...

    chflags uchg ~/Library/"Saved Application State"

    Press return.

     

    The reverse should you need it is

    chflags nouchg ~/Library/"Saved Application State"

    Let us know.

  • eklektostoworship Level 1 Level 1

    I tried...

     

    1. defaults write -app 'TextEdit' ApplePersistence -bool no

     

    2. System Preferences > General there is a hard-to-find checkbox under "Number of recent items" you can turn off.

     

    3. Another way to accomplish this is through Finder by going to ~/Library/Saved Application State/TextEdit and delete that file…or any other app, like Safari.

    (note that the User Library is hidden - so go to your Finder "Go" menu hold the option keyto choose "Library") The go to "Saved Application State" folder and delete the files for TextEdit and Safari.

     

    and

     

    4. chflags uchg ~/Library/"Saved Application State"

     

    This is the weirdest issue.  Any other thoughts?


     

     

     


  • macjack Level 9 Level 9

    What happens in another user, if you log into Guest or create a fresh user account and test?

  • eklektostoworship Level 1 Level 1

    I created a test user account.  Those apps did NOT automatically start.

  • macjack Level 9 Level 9

    Well, at least we know it's limited to your User account. That's a start.

    Let's try a startup in Safe Mode and see if the problem still occurs?

    Restart holding the "shift" key.

    (Expect it to take longer to start this way because it runs a directory check first.)

     

    If this works look in System Preferences > Users & Groups > Login items and delete any third party login items (-), you can always add them back with the (+). Also look in /Library/Startup Items. Nothing is put in that folder by default, so anything in there is yours.

     

    I know you don't have them in Startup Items but there may be something there causing it.

  • eklektostoworship Level 1 Level 1

    I really appreciate you taking the time to respond.   Unfortunatally the last reply options did not resolve either.   In Safe mode both did NOT start up.   I took everything out of the login items and did not add anything back in.  Nothing was in startup items..

     

    This is truely a mystery.

  • macjack Level 9 Level 9

    I think you should make an appointment at The Genius Bar and let them have a look at it.

    Please let us know, what they have to say.

  • eklektostoworship Level 1 Level 1

    Sure will.  Again... thanks for your help.

  • eklektostoworship Level 1 Level 1

    Took it to the Genius Bar.  They could not fix it.  They tried a bunch of different stuff.   Their take on it was to reinstall the operating system.   I am gonna keep lookin..

  • macjack Level 9 Level 9

    Thanks for letting us know... that's too bad