Previous 1 2 3 Next 41 Replies Latest reply: Apr 12, 2014 11:49 AM by JBuck713
Geofeni Level 1 Level 1 (0 points)

I had never use IMessage before, ever. Only a few days ago did I turn on iMessage which then it said "waiting for activation". I then texted a friend and it was an iMessage BUT she said it was coming from my email. This is really annoying my friends and myself, and it's using up my data on my phone which I have to pay for. I've read related discussions, and have tried everything possible. I've restarted my phone. Signed out and back into Apple. It still uses my email and it does not show my number nor does it let me add my number. All it shows is my email as my address, then underneath says "add another email address".


iPhone 4S, iOS 6
  • Allan Sampson Level 10 Level 10 (123,370 points)

    http://support.apple.com/kb/TS4268?viewlocale=en_US&locale=en_US

     

    iPhone automatically registers your phone number for use with FaceTime and iMessage during activation.

     

    This is really annoying my friends and myself, and it's using up my data on my phone which I have to pay for.

     

    Sending an iMessage when connected to your carrier's cellular network uses data regardless if the iMessage is sent with an email address or with your iPhone's phone number. Exchanging iMessages is the same as exchanging email when connected to your carrier's cellular network - it uses data.

     

    Settings > Messages > Send & Receive.

     

    Below you can be reached at, your cell phone number is not available there and grayed out, and below Start new conversations from, your cell phone number is not available there either?

  • Geofeni Level 1 Level 1 (0 points)

    My text messaging is free though.

    Also, I went to send & receive. It shows only my email address & underneath It says "add another email address". My number is not shown at all.

  • Allan Sampson Level 10 Level 10 (123,370 points)

    If your text message is free, why are you wanting to send an iMessage?

     

    Sending an iMessage when connected to your carrier's cellular network uses data regardless if the iMessage is sent with your iPhone's cell phone number or an email address. Exchanging iMessages is the same as exchanging email when connected to your carrier's cellular network - it uses data.

     

    As provided, iPhone automatically registers your phone number for use with FaceTime and iMessage during activation.

     

    If this did not occur and you want to continue using data when exchanging iMessages when connected to your carrier's cellular network when your text message is free, contact AppleCare.

  • Geofeni Level 1 Level 1 (0 points)

    Because iMessage is more quick and efficient.

    Sometimes I send friends/family photos and they don't get it till a few days later, same occurs with texts.

  • Allan Sampson Level 10 Level 10 (123,370 points)

    Sending and receiving iMessages with a registered email address changes nothing in regards to using data with iMessage when connected to your carrier's cellular network when e changing iMessages.

  • Geofeni Level 1 Level 1 (0 points)

    Okay,

    Why isn't my number visible though? All it shows is my email and the option to add another email. My number is not there at all, there's no option to add it and it isn't there grayed out.

  • Allan Sampson Level 10 Level 10 (123,370 points)

    I don't know why with the following copied from the link provided.

     

    iPhone automatically registers your phone number for use with FaceTime and iMessage during activation.

     

    Since this didn't occur, there is a problem that wasn't resolved by the steps you have already tried which is why I suggested contacting AppleCare.

  • ChuckG32 Level 1 Level 1 (0 points)

    Thanks Allan.  I had the same issue, and I was able to resolve it by going to the link you provided and doing the following:

     

    -- Go to Settings>Messages>Send&Receive.  Enable "Use Apple ID for iMessage" 

     

    Once you do this, it will bring up a list with your phone number AND all of the email accounts that are associated with your AppleID.  From that list, you should be able to specify your phone number as account that you will be using iMessage from.

     

    After you do this, log into iMessage on your Mac and it should prompt you to add your phone number.

     

    Another thing that you might want to consider -- go to the AppleID website https://appleid.apple.com/cgi-bin/WebObjects/MyAppleId.woa/  and make sure you have a mobile number specified in your AppleID settings.

     

    Hope that helps!

  • Chris CA Level 9 Level 9 (77,485 points)

    Just an FYI: to The app on the iPhone is Messages.

    An iMessage is a specific type of text using the Messages app.

    If you do not enable Settings > Messages > iMessage, you will send a regular text/SMS message. It will not be an iMessage.

    iMessages can only be sent to recipients with an AppleID and Mac OS or iOS device.

    In the Messages app, iMessages are blue and regular text/SMS is green.
    The Mac can only send iMessages.

  • kayleighg2310 Level 1 Level 1 (0 points)

    how was the problem fixed? i have the same problem

  • sledgbrainerd Level 1 Level 1 (0 points)

    I have the same problem.  It matters because when I iMessage someone, all they get is my email address, even if they have added the email to their contact info for me.  When I send regular texts, they get my contact name. 

     

    There is no option in

     

    SETTING>MESSAGES

     

    to change where the iMessages are sent from.  It gives me the choice to change what a caller ID sees, but my number is already selected so obviously that doesn't have anything to do with the problem.

     

    Any advice would be great.

  • droopmcc Level 1 Level 1 (0 points)

    I found the resolution! To recap, My iPad was unable to send/receive iMessages using my iPhone number. It was only showing my email address as an option. It all has to do with your iPhone, not your iPad.

     

    Go to your iPhone and navigate to Settings>Messages>Send&Receive. At the top, you should notice that it is asking you to sign in using your AppleID. You must sign in on your iPhone or it will not know to sync it up with your iPad. Once you login, you will notice that your phone now shows your phone number and email address. Go back to your iPad and navigate to Settings>Messages>Send&Receive. You need to sign out of your AppleID from here. Simply sign back in and voila! You will get a pop up message telling you what you've done. Go to your iPhone and it will give you similar messages saying that the iPad was set up with that phone number. Enjoy!

  • Negishi Level 1 Level 1 (0 points)

    droopmcc wrote:

     

    I found the resolution! To recap, My iPad was unable to send/receive iMessages using my iPhone number. It was only showing my email address as an option. It all has to do with your iPhone, not your iPad.

     

    Go to your iPhone and navigate to Settings>Messages>Send&Receive. At the top, you should notice that it is asking you to sign in using your AppleID. You must sign in on your iPhone or it will not know to sync it up with your iPad. Once you login, you will notice that your phone now shows your phone number and email address. Go back to your iPad and navigate to Settings>Messages>Send&Receive. You need to sign out of your AppleID from here. Simply sign back in and voila! You will get a pop up message telling you what you've done. Go to your iPhone and it will give you similar messages saying that the iPad was set up with that phone number. Enjoy!

     

    This may have worked for you, but for a growing number of people, it's not working for us.

    -We have no option to select between our phone number or email

    -We have no caller id selection option

    -Recieve & Send only has the email listed (phone # is greyed out and can't be ticked)

    -Signing in and out does nothing

    -Resetting network settings doesn't work

     

    I'm thinking some of you were just lucky and it started working on it's own again after you did reset the power and what not. For the vast majority and the 290,000 plus views from this topic alone, it isn't working.

  • Emmmmzy53 Level 1 Level 1 (0 points)

    Mine isn't working either. AppleCare said it could be an AT&T issue but AT&T said no. I've done a hard reset on my phone multiple times and no luck

Previous 1 2 3 Next