2 Replies Latest reply: Oct 26, 2012 1:44 PM by tonefox
Moonpidgeon07 Level 1 (0 points)

Some apps are not loading because it says it needs an iOS4.3 update, yet when I follow the instructions from Apple.com there is no update option under settings then general.  What do you suggest.


iOS 4
  • Niel Level 10 (298,302 points)

    That iPhone model can't be updated past 4.2.1. If it's running an iOS version older than 4.2.1, update it from iTunes on a computer.

     

    (71127)

  • tonefox Level 6 (9,155 points)

    The option under Settings does not appear until you are running iOS 5. As you cannot get past 4.2.1 you are stuck with the connecting to a computer running iTunes method of upgrading the OS. If you already at 4.2.1 you have reached the end of the line for your hardware.  Any app wanting an iOS beyond 4.2.1 is not available to you.  Time marches on.