5 Replies Latest reply: Nov 14, 2012 1:07 PM by Niros771
Niros771 Level 1 Level 1 (0 points)


Last week I bought a brand new AirPort Extreme base station in order to improve my wireless network in my apartment.

I have D-link ADSL modem (model 2760u) that connected to the AirPort Extreme..

So the problem is very often I see that the modem is sync and the Internet is connected but in the airport network I see that I'm connected to the wireless but for some reason the AirPort Extreme report that the Internet is disconnected (again the flashlight is green in the modem)

Restarting the airport resolve the problem for few hours but its very annoying to do this over and over again.


The airport is now working in bridge mode because I get airport massage for double NAT)


Can I get any help please?


Thank you!

OS X Mountain Lion (10.8.2)
  • Tesserax Level 8 Level 8 (49,860 points)

    A "double NAT" condition is indicative of having two routers with NAT enabled in series. It appears that your D-Link modem is actually a combination ADSL modem & router. Typically, in this configuration, you would want the downstream router (in this case the Extreme) in bridge mode.


    Once in bridge mode, the Extreme should NOT lose Internet connectivity periodically. If this still continues to be the case, I would suggest a complete power recycle of your networking equipment, and then, reconfiguring your Extreme as a bridge.


    Please post back after doing so to let us know your results.

  • Bob Timmons Level 10 Level 10 (92,235 points)

    In addition to the expert advice from Tesserax, in order to configure the AirPort Extreme in Bridge Mode to work correctly with your D-Link modem/router.....


    Open Macintosh HD > Applications > Utilitiies > AirPort Utility

    Click on the AirPort Extreme icon, then click Edit

    Click the Network tab at the top of the window


    Make sure that the setting for Router Mode is set to Off (Bridge Mode)

    Click Update to save the changes and allow 30 seconds for the AirPort to restart


    Then, power cycle the entire network by powering all devices off

    Wait a few minutes, then start the modem/router first and let it run a minute

    Start the Airport Extreme next the same way

    Continue starting devices one at a time until the network is completely powered back up



    Screen Shot 2012-10-28 at 1.32.55 PM.png

  • Niros771 Level 1 Level 1 (0 points)

    Thank you for tips guys.

    I'll perform all the steps above and update you soon about the results.

  • Niros771 Level 1 Level 1 (0 points)

    its seems like we done here...

    problem is solved


    thank you again guy's.

  • Niros771 Level 1 Level 1 (0 points)

    Ok it seems like the problem is back :\


    its seem like the air port extreme drops the internet connection very often...

    i tried all the option i know..

    working with bridge mode, working with DHCP and NAT and nothing helped


    the problem is solved only with rebooting the device every hour.


    what can I do?