Previous 1 2 Next 16 Replies Latest reply: Mar 20, 2016 11:18 AM by Becky3775
pielimekey Level 1 Level 1

Every time I use the remote to my apple tv it interferes with my macbook and starts the Front Row application or change the volume or make iTunes start playing.  Even if I am standing away from the laptop with my body between the lap top and the apple tv using the remote this happens.  It drives me insane and makes me want to throw my laptop out the window.  Truly, this is making me crazy.


MacBook, Mac OS X (10.5.8)
Solved by Alley_Cat on Oct 29, 2012 2:45 AM Solved

Disable the IR receiver on the Macbook via System Preferences under Security, General tab.

 

AC

Reply by Alley_Cat on Oct 29, 2012 5:43 AM Helpful

Joe Gramm wrote:

 

... I just went into Apple TV/Settings/General/Pair Remote and noticed I had not paired my Remote with Apple TV. Would pairing the remote with Apple TV eliminate the need to disable the IR on the Mac...

No - the remotes don't know they're paired, only the devices.

 

My theory on this is that each remote has an identifier code transmitted with the IR instruction.

 

When a device is paired it only responds to a remote with that identifier and ignores others - so unless the iMac was paired with another remote it would still respond to the one AppleTV was paired to.

All replies

  • Joe Gramm Level 5 Level 5
    expertise.iphone
    iPhone

    Do you have seperate remotes for the Macbook and Apple TV

  • Alley_Cat Level 6 Level 6

    Disable the IR receiver on the Macbook via System Preferences under Security, General tab.

     

    AC

  • Joe Gramm Level 5 Level 5
    expertise.iphone
    iPhone

    Alley_Cat - That's what I did on my iMac a while back because I was having the same issues as pielimekey and that did solve it for me.

     

    But I just went into Apple TV/Settings/General/Pair Remote and noticed I had not paired my Remote with Apple TV. Would pairing the remote with Apple TV eliminate the need to disable the IR on the Mac. That's why I asked if pielimekey had more than one remote as you would not want to disable the ability to use a second remote on the Macbook.

     

    I guess I could test it out by enabling the IR on my iMac and seeing if pairing my remote with Apple TV prevented it from controling the iMac.

  • Joe Gramm Level 5 Level 5
    expertise.iphone
    iPhone

    Update:

    I paired my remote with Apple TV, but the remote was still able to start iTunes on the Mac. I don't have a second remote for the iMac, but I assume if the Mac had it's own remote and was paired to the Mac, the Apple TV remote would not be able to control the Mac.

     

    But in the case of one remote, disabling the IR on the Mac seems to be the only solution.

  • Alley_Cat Level 6 Level 6

    Joe Gramm wrote:

     

    ... I just went into Apple TV/Settings/General/Pair Remote and noticed I had not paired my Remote with Apple TV. Would pairing the remote with Apple TV eliminate the need to disable the IR on the Mac...

    No - the remotes don't know they're paired, only the devices.

     

    My theory on this is that each remote has an identifier code transmitted with the IR instruction.

     

    When a device is paired it only responds to a remote with that identifier and ignores others - so unless the iMac was paired with another remote it would still respond to the one AppleTV was paired to.

  • storme Level 1 Level 1

    Hi All,

     

    I have a problem... my SETTINGS / SECURITY/ GENERAL tab does not have an option for IR?

     

    I'm on a macbook pro 10.7.5

    My options are:

    A login password has been set for this user

    Require password for sleep & Screensaver

    Show a messsage when screen saver is locked

    Disable Automatic Login (this is checked)

     

    Allow application downloads from:

    Mac App Store

    mac App store & identified developers

    Anywhere ( this is checked)

     

    HELP! My remote just keeps playing itunes on my macbook pro when i'm trying to change the channels on Apple TV. Argh!

     

    Any ideas?

     

    Thank you!

  • Joe Gramm Level 5 Level 5
    expertise.iphone
    iPhone

    In the /General tab, click the lock and enter your password then select Advanced. That's where the IR setting is.

  • nicoleca27 Level 1 Level 1

    Thanks! This was incredibly helpful

  • Sharon-Ann Arbor MI Level 1 Level 1

    thank you!! that worked for me.

  • MacManTaylor Level 1 Level 1

    Make sure you pair your iMac/Macbook remote with your iMac/Macbook via system preferances > security & privicy > advanced (click padlock in faded out) > pair > follow on screen instructions.

     

    Then pair your AppleTV remote with the TV via Settings > General > Remotes > pair.

     

    problem solved.

  • Gunnar I Level 1 Level 1

    Thanks! Not easy to find!

  • Emdee44 Level 1 Level 1

    Extremeley helpful!!! Having iTunes come on every time may have been the most annoying thing EVER! Thanks again.

  • Bgig Level 1 Level 1

    Yep, Worked for me!

     

    Thanks,

     

    BG

  • AMartini Level 1 Level 1

    This worked for me too! I apple upgrades the remote a little so we can control the devices we want (i.e. perhaps add a "source" switch to the remote to make it more universal?

Previous 1 2 Next