6 Replies Latest reply: Oct 29, 2012 11:51 AM by Bob Timmons
davedams Level 1 Level 1

I'm told I need an earier version of airport utility to manage the ariport express, but when i go to download the earlier version I'm told its not compatible with my current (latest) OS. Do I now have to throw out that Airport express and buy a new one? What's the deal?

 

Cheers,

David

Solved by Bob Timmons on Oct 28, 2012 3:03 PM Solved

This is an older version of the Express that was sold long before Apple started naming generations.

 

Download and install AirPort Utility 5.6 for Mac OS X Lion

 

You can keep both AirPort Utility 5.6 and 6.1 on your Mac and use the one that you need.  AirPort Utility 5.6 will also work with your newer AirPort devices as well.