Skip navigation

Photo Stream causing Aperture to hang

631 Views 6 Replies Latest reply: Feb 13, 2013 12:36 AM by iplayful RSS
Whatzup Calculating status...
Currently Being Moderated
Oct 29, 2012 2:56 AM

Since yesterday I am having problem between Photo Stream and Aperture. I had Photo Stream turned on ever since it was available. Whenever I open Aperture now, I get the spinning beachball and Aperture isn't responding. I have tried leaving it running for an hour and it didn't recover. When I look at the CPU utilitization, 3 processes are taking up all CPU time - (1) Aperture, (2) distnoted agent, (3) ApplePhotoStreamDownloader. Since the latter 2 are related to iCloud and PhotoStream, I disabled Photo Stream in my iCloud Perference. Afterwards, Aperture worked perfectly. When I turned on Photo Stream again, the same problem reappears. I have tried resetting the Photo Stream and remove all pictures via icloud.com. It didn't solve the problem. I have also tried signing in and out of the iCloud on my Mac, and it was the same. I have also tried reparing and rebuilding the Aperture library.

 

In additino, I can repeat the same problem on iPhoto. That leads me to believe this is an iCloud/Photo Stream problem rather than an Aperture problem.

 

Has any of you experienced similar issue? Any fixes or troubleshooting tips can you recommend?

MacBook Pro, OS X Mountain Lion (10.8.2)
  • léonie Level 8 Level 8 (46,355 points)
    Currently Being Moderated
    Oct 29, 2012 5:21 AM (in response to Whatzup)

    In some cases it helped to disable PhotoStream in your account, then to create a new user account on ypur mac and enable Photostream for this account.  Import some photos to Aperture, then turn off the PhotoStream again for this account. Now enable the PhotoStream again in your account. Does it work now?

     

    Regards

    Léonie

  • léonie Level 8 Level 8 (46,355 points)
    Currently Being Moderated
    Oct 29, 2012 6:37 AM (in response to Whatzup)

    I tried. Photo Stream worked perfectly fine on the new account.

    So it does not seem to be a network problem, or are you using any helpers, e.g. Little Snitch, that may interfere with your network? Check carefully your login/startup items  and the custom preference panes, if there is anything present in your regular account, that is not used in a new user account.

     

    Aloso you may want to check the permissions in your user library;  the PhotoStream is stored in the folder ~/Library/Application Support/iLifeAssetManagement/assets/

     

        your user library > Application Support > iLifeAssetManagement > assets

     

    These folders should be writable to you and readable to everyone. Inside the subfolder assets > sub you should find all PhotoStream image files, if they have been downloaded. What are the permissions on these folders?

     

    Just in case, you have not had to access your user library before: In Mt. Lion it is hidden. You can reveal it from the Finder's "Go" menu. Select "Go" in them Finder's main menu bar and hold down the "alt/Options" key, until "Library" appears in the drop-down menu.

     

    Regards

    Léonie

  • léonie Level 8 Level 8 (46,355 points)
    Currently Being Moderated
    Oct 29, 2012 8:18 AM (in response to Whatzup)

    You are welcome.

    I am glad it works for you now.

     

    Léonie

  • iplayful Calculating status...
    Currently Being Moderated
    Feb 13, 2013 12:36 AM (in response to Whatzup)

    Thank you very much to Whatzup and Léonie! I had the same problem. I noticed repeating messages in Console referring com.apple.photostream-agent. I tried to delete it and nothing changed. But after removing ~/Library/Application Support/iLifeAssetManagement the Aperture launches almost instantly!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.