1 Reply Latest reply: Oct 29, 2012 7:24 AM by b j t
LiuDong Level 1 Level 1 (0 points)

the iBooks3.0 is unable tu use!

Too many people can't use it!

It's a bad updata!


iPad, iOS 5, 3G