Previous 1 2 Next 16 Replies Latest reply: Oct 9, 2014 12:41 PM by Rick Dykstra Go to original post
  • RPTB1 Level 1 Level 1 (0 points)

    I found that copying the entire /Library/Frameworks/PluginManager.framework from another Mac with up-to-date Moutain Lion fixed the problem, with both Final Cut Express and Aperture working afterwards.

  • Rick Dykstra Level 1 Level 1 (0 points)

    I solved exactly this problem, very easily. All I did was restore one file from my Time Machine backup, being:

    Macintosh HD/Library/Frameworks/PluginManager.framework/Versions/B/PluginManager

     

    Background. With my Early 2008 Mac Pro I was having trouble with flakey RAM cards. When attempting to restart with a particular combination of RAM installed, OS X Lion became corrupted. I'm guessing this happened when RAM that I had solder-reflowed in an oven failed after working temporarily. Anyway, my Macintosh HD became unreadable; the computer would not get past the grey screen on startup. I used Disk Utility from the passport drive that contained my copy of Lion to erase the disk and reinstall Lion. I then restored my applications and files and ran software updates, to find that Final Cut Express would not start, with the same message I recently received when trying to open Aperture. I reinstalled Final Cut Express from disks. This appears to have created the problem with Aperture not opening.

     

    I found this thread and was tossing up between downloading Aperture 3.4.4 from the Apple Support page (not from the App Store - I don't have the latest OS X due to incompatibility with various peripherals) or reinstalling Lion from the passport. I saw Leonie's post above, about the possibility of the PluginManager file being missing. Mine was not missing but I decided to overwrite from Time Machine the version that was present before the hard disk lockup. The path to this file is shown above. This simple step worked - I now have Aperture 3.4.4 and Final Cut Express 4.0.1 working at the same time on OS X Lion 10.7.5.

     

    If this hadn't worked my next step would have been to overwrite from Time Machine the folder containing this Plugin Manager file, which worked for RPTB1 above. After that I would have tried a reinstall of OS X from passport drive, and then a reinstall of Aperture 3.4.4 downloaded from the Apple Support pages. Luckily I haven't had to do any of these.

     

    I hope this helps someone. The earlier posts in this thread, when read together, sure helped me.  :-)

Previous 1 2 Next