1 Reply Latest reply: Oct 31, 2012 2:19 PM by Dale Weisshaar
tequilab0b Level 1 (0 points)

I have an '07 Macbook with newest OS. My WD MyPassport external (1TB) that I have had for a little over a year. My computer froze and I did a hard reboot with the drive (and 2 others) connected. The other two drives still work fine but the one I am refering to here is not recognized by my macbook (or several other computers I have tried it in). I have tried various things (shutdown with it plugged in, different cable from other WD MP, etc.). Tried to look in disk utility and not recognized there nor in System Information lists for USB devices (all my other drives are still recognized and I have tried all USB ports). The drive itself shows a light and you can tell it is spinning but just not being recognized by the computer in any way. I would like to save the drive if able (I have a LOT of movies and TV shows on there and am currently deployed) but if I have to I can reformat and restart my collection with others.