5 Replies Latest reply: Jul 28, 2013 7:14 PM by cdn-tallguy
lindsay201 Level 1 Level 1

I'm wondering if anyone knows how to fix a problem I'm having with homesharing and my apple tv. It connects fine, and will play exactly one song or movie/tv show, and then stops because it is no longer connected to homesharing. My cousin and I live in the same building and use the same internet provider, but she doesn't have the same problems with her ATV. We do have different routers, in case that makes a difference (although I'm still able to connect to the internet and turn on homesharing again, so I don't think that my internet is the problem). Can anyone help?

  • LifeboatParty Level 1 Level 1

    I have what appears to be the same problem. Streaming from iTunes works fine for one song, regardless of length, but stops 0:02 into the next song. I can see all the album art and go through the menus, but at that point, nothing will play. I have done all the usual stuff: reset Apple TV, unplugged and replugged Apple TV, reset router, etc. I have a 3G Apple TV, AirPort Extreme, and the latest iTunes version on Windows. I tried streaming from the Mac Mini, as well, but it would not connect at all there. When I read troubleshooting tips, and I see things like opening ports and stuff, I think it is ridiculous. I have an AirPort Extreme and an Apple TV--they can't talk to one another without me waving a dead chicken over them? I do not understand why Apple products are so difficult to work with.

  • Brian Cook4 Level 4 Level 4

    >use the same internet provider, but she doesn't have the same problems

    Home Sharing has nothing to do with your ISP.


    Is your computer going into sleep mode by chance?

  • LifeboatParty Level 1 Level 1

    I thought at first that was what was happening (computer going to sleep), although it didn't make any sense because that would typically be at a set duration (e.g., 15 minutes). In any case, I have checked, and the computer is not going to sleep. The iTunes just stops streaming. As mentioned, I can still see everything on iTunes--all album art and information--and even move to select a different song. However, it will not start streaming again after it stops (unless I turn off home sharing and start it again, but that's a lot of work to play one song!).

  • cdn-tallguy Level 1 Level 1

    I had exactly the same issue when accessing my iTunes library saved on my remote computer from Apple TV.
    My remote computer connects to a dual band ASUS router via Wi-Fi. Apple TV is connected to my router via Ethernet cable.

    Another computer directly connected to the same router via Ethernet cable plays just fine without disconnecting home sharing after one song (then iTunes on the remote computer needs to be closed and re-opened in order for homesharing to work again).

    After troubleshooting for a long time I've noticed that the AirPlay icon is also not showing on remote computer beside the volume slider


    > it's not an Apple TV issue, must be a router/Wi-Fi issue.

    > In order to check if iTunes is OK on the remote computer I've connected it directly to the router via Ethernet cable and that solved it. Airplay icon showing and no song interuptions.

    At the same time I shut down Windows Defender, Router and Windows firewall and assigned a static IP address to my computer and also forwarding ports in my router that iTunes needs.


    I now forward port 3689 and 5353.

    Ultimately not 100% what made it work but after half a day playing with it connecting to my router via Ethernet seem to have done the trick.


    Later on I've restarted Defender and also both Router and Windows firewall.

    All working fine ever since via Wi-Fi and Airplay icon showing as well.

  • cdn-tallguy Level 1 Level 1

    I've now assigned a dynamic IP address to my router and also removed port forwarding in my router.

    I'm thinking simply plugging in the Ethernet cable directly in the router once resolved airplay icon not showing in iTunes and also the homeshare interruption after one song, weird but true!

    Everything working fine now via Wi-Fi.