Previous 1 2 3 Next 30 Replies Latest reply: Jun 10, 2015 7:06 AM by casianeduard Go to original post
  • baltwo Level 9 Level 9 (62,205 points)

    The OP claimed that Java wasn't installed. The request to ascertain if those items were on the machine was to verify that condition. Reinstalling the JRE components has nothing to do with those components, since they're installed by the OS and not any Java update, whether from Apple or Oracle. As before, just mucks things up.

  • nikkormac Level 1 Level 1 (75 points)

    it doesn't muck things up; it simply requests clarification and speeds things along. you suggested an approach to take if the OP discovered those components were not in the expected location, but you said nothing about what she should do if she found they were there (as i did, while continuing to experience the exact problem the OP described in her original post). i simply asked you for a solution to the other possibility, the one you hadn't addressed, since it was the situation i'd found on my own machine while still experiencing the OP's problem.


    having both of those situations addressd - that is, what to do in the case of the presence and the absence of those components - instead of just one would allow the OP, and others with the same problem, to take action regardless of whether they found those components present, instead of finding those components present and having to come back here and ask the very question i asked before they could proceed.

  • Helene L Level 1 Level 1 (0 points)



    Again thanks for your help! I just did as you suggested and the three components

    JavaFrameEmbedding.framework etc. are there


    Thus we are in the case of presence of components




    I have already tried the download link from Mac, and no improvement, actually this is what prompted me to open this thread as when I tried installling it the answer I get is impossible to install, Java already there... and when I check with terminal or try to run the software Gephi (the one I use that needs Java 6) then I get the answer that Java is not installed.

  • baltwo Level 9 Level 9 (62,205 points)

    Then, boot into recovery mode, restore the OS, restart, and try installing Java 6 again. BTW, don't install Java 7 until you resolve the Java 6 issue.

  • nikkormac Level 1 Level 1 (75 points)

    i see - thanks for the explanation (and sorry it wasn't as simple for you as it was for me). hopefully with baltwo's guidance you'll have the issue resolved in not much more time.


    best of luck.

  • annmclpc Level 1 Level 1 (0 points)

    Shortly before Thanksgiving, I spent 5 hours on the phone with 'support'.  I did all of these steps and nothing works.  The blip is down in the corner of my screen and I just continue to ignore it.  I have the exact issue that Helene L has!!!  All this happened after I loaded OS X lion

  • Helene L Level 1 Level 1 (0 points)

    Thanks Baltwo for this, I am speaking at a conference on Monday and have an important video conf on tuesday and I need my Mac for both, thus for fear that something really bad happens, I'll try the recovery on Wednesday... Sorry for the slow speed of my following up on your very kind help and advice, but my fear is to lose everything!

  • baltwo Level 9 Level 9 (62,205 points)

    Let us know how things turn out.

  • Helene L Level 1 Level 1 (0 points)

    Hello Baltwo,


    This is getting worst...

    I tried to reinstall Lion from the recovery, and guess what, it did not work!!! Everything went fine until after the login and then I had the screen saying downloading... and the time was 120h +!!! I cancelled and tried redo it and this time got 121h 4mn with nothing happening for more than 5 mn.

    Thus I cancelled, restarted thinking that maybe it was becaue the recover wanted to do it through wifi (although my wifi works very well if I trust my ipad) and started looking for the way to ask fro recovery through ethernet and not wifi.

    and there I could not find it but discovered a java in the preferences and when I go to the Java control panel it says "Your current version is Java 7 update 9. It is recommended that you update now to keep your system secure." which I did and everything went well.

    But in terminal I always get the same "No Java runtime present, requesting install."


    So now I have 2 problems, one with java 7 but no java runtime and one because I cannot reinstall lion...!!! Sigh....


    Thank you so much for any idea you could have. In the meantime I'll try to see on the internet if I can do something about the way to reinstall lion, and if ever I manage, I'll write a post immediately.


    I also wonder if the best way would not be to upgrade to Mountain Lion.... but yet, this is aggravating!


  • baltwo Level 9 Level 9 (62,205 points)

    DLing anything via WiFi is the slowest method, Although describes the process, it's scant on details using an ethernet connection, but apparently, you first connect via WiFi, then switch to ethernet. All I can suggest is that you contact Apple's Express Lane and let them sort out this nonsense for you. My machine isn't capable of using it.

  • Helene L Level 1 Level 1 (0 points)

    Thank you Baltwo for your time and advice, this was truly very supportive :)

    I wish you a merry Christmas and shall drop a line here when problems are solved!

    Mercy Christmas again


  • Helene L Level 1 Level 1 (0 points)

    Hello Baltwo, Hello everyone,


    I found a solution: I updated to Monutain Lion, ran java pref, it uploaded perfectly everything and my software works now as previously... I am just SO happy . True enough, it cost the price of the Montain Lion update, but anyway I would have needed to do it one day or another.


    Thanks to everyone for their help and contribution,


    Merry Christmas / Season's Greeting


  • baltwo Level 9 Level 9 (62,205 points)


  • alexalexalex155 Level 1 Level 1 (0 points)

    nikkormac worked a treat, cheers

  • leeosenton Level 1 Level 1 (0 points)

    nikkormac     Thanks for this link and simple answer. Fixed me up without issue and got my android tools environment straight. A++ Thanks for sharing.