4 Replies Latest reply: Nov 10, 2012 4:40 AM by Michael Facelle
DrewM Level 1 (35 points)

My install of OS 10.7.5 allowed me to download and install Safari 6.0.2, which I found out afterward (via error box) cannot be run under Lion.  How can I downgrade?  The OS will not allow me to delete the new installation of Safari, nor could I restore the previous version via Time Capsule.

Mac Pro, Mac OS X (10.7.5)
  • nikonvscanon Level 1 (0 points)

    I have EXACTLY the same problem, and no obvious solution.

    I did manage to force a delete of Safari 6.0.2.

    I used "Get info" on the rogue Safari application and then in Sharing and Permissions changed everthing to read & write.

    I then tried installing 6.0.1, but the program is still broken.

    I then used timemachine to restore an old version of Safari 6.0.1, but the program is still broken.

    I deleted 6.0.1 and then installed the 1st Safari for Lion 6.0.0, but the old program is also broken.

    My 5 year old Black Macbook cannot be upgraded to Mountain Lion.

    I'm now stuck using Google Chrome browser as a temporary workround.


    Upgrading a browser from 6.0.1 to 6.0.2 shouldn't destroy the browser.

    Reverting back to 6.0.1 should be an option!

  • Michael Facelle Level 1 (70 points)

    Open the applications folder

    Right click on Safari

    Select "Show Package Contents"

    Delete the folder "Contents" in the window that opens (you will need to enter your password)

    Open Terminal

    Type (without quotes) "sudo rm -d /Applications/Safari.app"

    Enter your password again.


    Safari should now be deleted, and you can then restore from Time Machine

  • nikonvscanon Level 1 (0 points)



    I selected and opened Safari and deleted Contents.

    I then deleted Safari using Terminal.

    I then restored Safari 6.0.1 (Created Mon 1st August) from my Timemachine backup.


    The restored Backup still doesn't work and crashes on launch.

    The crash report gives the following technical info about the problem:


    ******************************************************************************** ******************

    Process:         Safari [1552]

    Path:            /Applications/Safari.app/Contents/MacOS/Safari

    Identifier:      com.apple.Safari

    Version:         6.0.1 (7536.26.14)

    Build Info:      WebBrowser-7536026014000000~1

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [153]



    Date/Time:       2012-11-09 22:47:40.218 +0000

    OS Version:      Mac OS X 10.7.5 (11G63)

    Report Version:  9



    Interval Since Last Report:          66863 sec

    Crashes Since Last Report:           1985

    Per-App Interval Since Last Report:  195712 sec

    Per-App Crashes Since Last Report:   6

    Anonymous UUID:                      CFE007BA-9AFD-4129-8165-83843D28414B



    Crashed Thread:  0



    Exception Type:  EXC_BREAKPOINT (SIGTRAP)

    Exception Codes: 0x0000000000000002, 0x0000000000000000



    Application Specific Information:

    dyld: launch, loading dependent libraries



    Dyld Error Message:

      Library not loaded: /System/Library/Frameworks/Accounts.framework/Versions/A/Accounts

      Referenced from: /System/Library/StagedFrameworks/Safari/Safari.framework/Safari

      Reason: image not found



    Binary Images:

           0x100d60000 -        0x100d60fff  com.apple.Safari (6.0.1 - 7536.26.14) <72FC923C-4E54-310F-B79C-D14AE194E6AE> /Applications/Safari.app/Contents/MacOS/Safari

           0x100d6b000 -        0x101260fff  com.apple.Safari.framework (8536 - 8536.26.17) <A28655B2-8394-32D4-82C2-725FAD855E48> /System/Library/StagedFrameworks/Safari/Safari.framework/Safari

        0x7fff60960000 -     0x7fff60994baf  dyld (195.6 - ???) <0CD1B35B-A28F-32DA-B72E-452EAD609613> /usr/lib/dyld

        0x7fff917e6000 -     0x7fff91813fe7  libSystem.B.dylib (159.1.0 - compatibility 1.0.0) <095FDD3C-3961-3865-A59B-A5B0A4B8B923> /usr/lib/libSystem.B.dylib



    Model: MacBook3,1, BootROM MB31.008E.B02, 2 processors, Intel Core 2 Duo, 2.2 GHz, 4 GB, SMC 1.24f3

    Graphics: Intel GMA X3100, GMA X3100, Built-In, 144 MB

    Memory Module: BANK 0/DIMM0, 2 GB, DDR2 SDRAM, 667 MHz, 0x2C00000000000000, 0x3136485446323536363448592D3636374531

    Memory Module: BANK 1/DIMM1, 2 GB, DDR2 SDRAM, 667 MHz, 0x2C00000000000000, 0x3136485446323536363448592D3636374531

    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x88), Broadcom BCM43xx 1.0 (

    Bluetooth: Version 4.0.8f17, 2 service, 11 devices, 1 incoming serial ports

    Network Service: AirPort, AirPort, en1

    Serial ATA Device: ST9500420AS, 500.11 GB

    Parallel ATA Device: MATSHITADVD-R   UJ-857E

    USB Device: Built-in iSight, apple_vendor_id, 0x8501, 0xfd400000 / 2

    USB Device: Elements 1042, 0x1058  (Western Digital Technologies, Inc.), 0x1042, 0xfa200000 / 2

    USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x022a, 0x5d200000 / 3

    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x5d100000 / 2

    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8205, 0x1a100000 / 2"

  • Michael Facelle Level 1 (70 points)

    My issue with 6.0.2 was that websites were acting "strange" whenever I would try to put something in a shopping cart. It seemed a bit buggy, so I downgraded and all is fine. I didn't have crashing issues, so unfortuately, I can't help you. Did you try trashing the .plist file? Many times that helps.