1 Reply Latest reply: Nov 4, 2012 11:46 AM by rstartree
rstartree Level 1 Level 1 (0 points)

I use a NAS for my Mac OS X Server system. I've dedicated one of the iSCSI LUNs to store all my user home directories. Today, for some inexplicable reason, the iSCSI drive got renamed from Foobar to 00

 

Screen shot 2012-11-02 at 3.05.23 PM.png

 

The mount point also got renamed to from /Volumes/Foobar to /Volumes/00.

 

I manually renamed /Volumes/00 back to /Volumes/Foobar by opening a Terminal window and typing 'mv 00 Foobar', but I would like to restore the old name for the iSCSI drive.

 

Can someone show me how to do this?


Mac Pro, Mac OS X (10.6.8)
  • rstartree Level 1 Level 1 (0 points)

    Note: 

    I tried to rename it in the Finder by right-clicking the drive and selecting 'Get Info'. I then tried to change back to the earlier name by typing 'Foobar' in Name & Extension. When I try to save it (by enterring the carriage return), I get the message:
    The name "Foobar" can't be used.

     

    Try using a name with fewer characters, or with no punctuation marks.
    I gather that some part of the file system got corrupted, so that I cannot rename the iSCSI drive Volume using the Finder. Perhaps I can circumvent this problem by trying to rename the drive in the command line instead of the Finder. Is there a way to do this in the command line?