1 Reply Latest reply: Nov 3, 2012 6:53 AM by Klaus1
Pasakhala Level 1 Level 1 (0 points)

I can't chat using this version in Facebook.Similarly,I can't install the available updates though my mac book meets the general requirements for it.I can't choose the location to be installed.


MacBook Pro, Mac OS X (10.5)