Previous 1 2 Next 24 Replies Latest reply: May 24, 2015 12:53 AM by TwanCMB
CapM1 Level 1 (0 points)

My external hard drive was working this morning.  Its only a few months old (Seagate GoFlex Desk).  Now, says "the disk you inserted in not readable by this computer."  I saw a thread that has not been solved yet, but it asked the OP to post some info.  Here's what I am getting:

 

/dev/disk0

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      GUID_partition_scheme                        *320.1 GB   disk0

   1:                        EFI                         209.7 MB   disk0s1

   2:                  Apple_HFS Macintosh HD            319.2 GB   disk0s2

   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

/dev/disk1

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      GUID_partition_scheme                        *2.0 TB     disk1

   1:                        EFI                         209.7 MB   disk1s1

   2:                  Apple_HFS                         2.0 TB     disk1s2

 

 

Any help would be GREATLY appreciated! 


MacBook Pro (13-inch Early 2011)
  • baltwo Level 9 (62,215 points)

    Power down and disconnect the ext HD, Zap the PRAM, and Reset the SMC, then connect and power up the ext HD.

  • Frank Caggiano Level 7 (25,715 points)

    Have you tried runnning repair disk from Disk Utility?

  • CapM1 Level 1 (0 points)

    Thanks for responding guys.  Zap, reset, & repair did not work.  Repair comes up 

    Error: Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.

     

    And these types of messages:

     

    File record has hard link chain flag (id = 734865)

    Incorrect number of thread records

    Incorrect number of file hard links

    (It should be 1 instead of 4)

    I have to believe this is  software error.  I think it happened when I moved a file.  I saved a file to the drive, but then realized it was in the wrong place.  When I loved it to its proper folder, that's when this happened.  Frustrating.  I have to believe that the files are there and in good working order, but what do I know.


  • baltwo Level 9 (62,215 points)

    Then, try something stronger, such as DiskWarrior or TechToolsPro.

  • CapM1 Level 1 (0 points)

    Which one would you recommend between DiskWarrior or TechToolsPro?  Looks like they are both $99.  I'm not too psyched about paying $99 if it doesn't work, but I guess I have no choice.

  • baltwo Level 9 (62,215 points)

    DiskWarrior is the best for fixing directory issues. TTPro does other things.

  • CapM1 Level 1 (0 points)

    DiskWarrior recovered my external hard drive!  Great product.  All my files are back.  Thanks so much!

  • baltwo Level 9 (62,215 points)

    thumbsup.gif

  • steveht02 Level 1 (0 points)

    I had this problem and was able to solve it via another forum by following the directions here: http://perrohunter.com/index.php/blog/2011/06/repair-a-mac-os-x-hfs-partition-ta ble

     

    Free and worked great!!

  • Pensrud Level 1 (0 points)

    Used Disk warrior. Headache gone...heart rate returned to where it should be. Thanks DW 4.3.

     

    Installed, ran, fixed in about a minute or so.  STOKED!!!

     

    Using Mountain Lion 10.8.2 on both MBP i7 Retina summer 2012, and Imac 27" i5 mid-2010

  • baltwo Level 9 (62,215 points)

    You should be using DW 4.4.

  • Phalgun27 Level 1 (0 points)

    Hi CapM1,

     

    I am having the same problem. My external harddrive is 1Tb (Seagate FreeAgent GoFlex). I don't know what happened but I am getting this error "The disk you inserted is not readable by this computer"

     

    My harddisk is 80% full. From the above messages I see you have recovered all your files with the help of DiskWarrior. I would like to know if you used DiskWarrior 4.3 or 4.4? I have downloaded DiskWarrior 4.3. Do I need to write it on a DVD and then boot my Mac? Can you please tell me how you have fixed? Also How long it took for you to recover all your files. Can you use your external harddisk again?

     

    Thank you,

    Phal

  • CapM1 Level 1 (0 points)

    4.4 is what I used.  I downloaded it so I could use it immediately, so I didn't wait on any DVD's.  It took a few hours (actually, I think I started it before I went to bed and woke up the next morning and everything was fixed).  Yes, hard drive was returned to perfect working order, and has been ever since!

  • Phalgun27 Level 1 (0 points)

    Thanks for the quick reply. I have 4.3 version and I have put it in Utilities Folder. When I run it, I don't see the option for my external hard disk. I just see Mac. Do we need to plug our external harddisk while DiskWarrior is working?

Previous 1 2 Next