8 Replies Latest reply: Nov 23, 2014 3:22 PM by ScottLA10
mr4js Level 1 Level 1 (0 points)

Safari slow


MacBook Pro 5.1 Late 2008, Mac OS X (10.5.5), Intel Core 2 Duo 2.8 GHz
  • dominic23 Level 7 Level 7 (33,825 points)

    Try to empty caches once in a while.

     

    Click Safari in the menu bar and select "Empty Caches".

     

    Best.

  • mr4js Level 1 Level 1 (0 points)

    Thanks, seems to be better for now.

  • Dan_kernel Level 1 Level 1 (0 points)

    I had the same problem. Safari was freezing in several pages.

     

    Disable iCloud for safari. Go to System Preferences > iCloud >uncheck Safari... Done! Restart safari and see if safari is loading pages faster.

     

    I'm sure that apple will release a fix for this soon, in the mean time, use iCloud in safari only when you really need it.

  • ptorab Level 1 Level 1 (0 points)

    Same problem -- started a few days ago - I have an iMac 2011. Page loads take forever (minute may be). Completely frustrating. Switched to Chrome to get some job done.

     

    Disabling Java and Javascript fixes the speed, but some web pages don't work correctly.

  • mr4js Level 1 Level 1 (0 points)

    My issue was with the Contacts application using up almost 100% of my resources. This is a common problem for some who have upgraded the OS. If your computer gets slow, open Activity Monitor and look at the %CPU. If one activity is very high, this is the problem. Search the boards, you will find the files to delete to fix the problem. After i did this, it was like having a new computer.

  • mr4js Level 1 Level 1 (0 points)

    This was the fix for me. When your computer gets slow, look at Activity Monitor for high %CPU usage. The prblem was AddressBookSourceSync using almont all %CPU. The fix is:

     

    Re: What is AddressBookSourceSync?

    Oct 19, 2011 12:47 PM (in response to rsfromhome)

    Had the same problem of Address Book / AddressBookSync run wild after upgrading to 10.7.2 and icloud, and this is what I did which seems to have fixed it.

     

    1. Made sure that mobileme was not syncing anymore (system preferences)by logging out of MobileMe.

    2. As a precaution, backed up my address book (1700 contacts) locally,  and quit address book.

    3. Checked to see if icloud had all of my contacts. www.icloud.com

    4. Made sure that AddressBookSync was not running in Activity monitor.  If it is, kill it.

    5. Went into my users library (~/Library/Application Support/Address Book/) trashed everything EXCEPT Confguration.plist.

    6. Went back into System preferences/icloud and made sure that Contacts was checked off. Once checked the sync started.

  • Paperlady1513 Level 1 Level 1 (0 points)

    Hi

    When I click on Safari in the menu bar it doesn't give me the option to clear cache?

  • ScottLA10 Level 1 Level 1 (0 points)

    Same problem.  Simple fix if like me you just want Safari to operate essentially as it did before.

     

    I've never commented before.  Consider my computer skills inferior to an 8 year-old, and was shocked to find my hunch actually worked.

     

    The problem seems to lie in the operating system trying to integrate every aspect of its functionality and content with every type of search conducted in either Safari or Spotlight which is now a jumble at best (I'm back to searching in the finder) and seems to snack on email content.

     

    So, in Safari, open preferences.

     

    Select the Search Icon

     

    From the pulldown I have selected google as my search engine.

     

    I have selected Include Search Engine Suggestions which are often useful and occasionally comical.

     

    Do not select any of the smart search settings.

     

    It seems to send Safari on a wide ranging search of the African Savannah to load a simple webpage because it looks everywhere else first before it loads.  If after all that hunting about it thinks it might have the page or a piece of it somewhere local then it gets a headache instead of just looking for it on the web in the first place.

     

    I have no idea what smart search is or why I would want to search spotlight on my browser or the web from spotlight but apparently it's so smart it's "too smart for its own good."  Huh, maybe artificial intelligence is already here.  Yosemite has a sense of irony.