Previous 1 2 Next 20 Replies Latest reply: Dec 22, 2012 3:35 AM by SrgBrazil
SrgBrazil Level 1 (0 points)

I am having problems with iPhoto 9.4.2.  Every time after I download it my  iPhoto does not open, and I have to restore my library from my Time Capsule.  Any one is having problems with 9.4.2 actualization?

iPhoto '11, OS X Mountain Lion (10.8.2)
  • LarryHN Level 9 (77,104 points)

    Back up your iPhoto library, Depress the option (alt) and command keys and launch iPhoto - rebuild your iPhoto library



  • SrgBrazil Level 1 (0 points)

    I decided to try what you directed.  I updated to iPhoto 9.4.2, tryed to launch and nothing happened.  It is not even possible to rebuild the library.  I them restored version 9.4.1, and everything is OK.  I believe it is a problem with 9.4.2 version.  Are we having problems with iPhoto 9.4.2?

  • Terence Devlin Level 10 (137,945 points)

    No we are not.


    I would guess you have a faulty intall of 9.4.2. Try again.

  • Old Toad Level 10 (135,517 points)

    Download and try this updater: iPhoto 9.4.2.



  • ransims Level 1 (0 points)

    I am having the same problem with iphoto 9.4.2! When I open it, it crashes after a short period of time. It's been going on for a month now since the update and nothing seems to work to fix it. I was hoping Apple would fix the problem with an update due to the large amount of people complaining about the problems, but they have not. 

  • Terence Devlin Level 10 (137,945 points)

    Why is it crashing? A Crash is not a problem, it's a symptom of a problem, and there can be many problems that cause crashes.


    and nothing seems to work to fix it.


    What have you tried?

  • ransims Level 1 (0 points)

    Thanks for the quick response Terence!


    I have tried:

    1. Uninstalling and reinstalling the program and getting rid of any reciepts that are labeled iphoto.

    2. Holding alt+command while opening iphoto and have tried the various fix options

    3. Reverting to the older verion of iphoto (9.4.1)

    4. Reinstalling iphoto using the 9.4.2 update on this blog


    Any advise would be helpful.



  • Terence Devlin Level 10 (137,945 points)

    As a Test:



    Hold down the option (or alt) key and launch iPhoto. From the resulting menu select 'Create Library'



    Import a few pics into this new, blank library. Is the Problem repeated there?

  • Old Toad Level 10 (135,517 points)

    You're not running a new Mac Mini by any chance are you?

  • ransims Level 1 (0 points)

    Terence, that seemed to fix the problem. Thanks a lot for teaching me something new about this great device.

  • ransims Level 1 (0 points)

    Old Toad, I'm using a MacBook Pro. Holding down the option (or alt) key and launch iPhoto and creating a new library fixed the problem.

  • Old Toad Level 10 (135,517 points)

    Holding down the option (or alt) key and launch iPhoto and creating a new library fixed the problem.

    Did that fix your original library?

  • ransims Level 1 (0 points)

    Honestly, I didn't check to see if it fixed the orignal library. I was so enthused that iPhoto stopped crashing I delted the old library without a second thought. The pics from the old library were backed-up on a hard drive. Backing the photos up was a task though. In order to copy the pics before iPhoto crashed, I used command+a to select them all at once, command+c to copy them all at once, and pasted them to a new folder I created on the desktop. It took a couple of attempts because I had to get my fingering right before iPhoto crashed, but I got them all. It also collected all the video I had on iPhoto. 

  • Old Toad Level 10 (135,517 points)

    Actually creating a new library was a test to determine if the problem was limited to your library or if it was system wide.  Since the new library worked it appears that your original library was the culprit. 


    In that case make a temporary, backup copy of your library if you don't already have one (Control-click on the library and select Duplicate from the contextual menu) and  apply the two fixes below in order as needed:


    Fix #1


    Launch iPhoto with the Command+Option keys held down and rebuild the library.




    Since only one option can be run at a time start with Option #3, followed by #4 and then #1 as needed.


    Fix #2


    Using iPhoto Library Manager  to Rebuild Your iPhoto Library


    1 - download iPhoto Library Manager and launch.


    2 - click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.


    3 - Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option.


    4 - In the next  window name the new library and select the location you want it to be placed.


    5 - Click on the Create button.


    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments.  However, books, calendars, cards and slideshows will be lost. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.

Previous 1 2 Next