Skip navigation

MBP + SSD + FileVault2 = Kernel Panic

5522 Views 68 Replies Latest reply: Apr 6, 2013 12:58 PM by OBDave RSS
1 2 3 ... 5 Previous Next
OBDave Calculating status...
Currently Being Moderated
Nov 3, 2012 10:59 PM

Hello - I'm hoping someone here might be able to offer some insight into something I'm seeing. I've Googled and not found the specific set of weirdnesses I'm seeing.

I have a 13-inch Mid 2009 MBP. About six months ago I installed a 256 GB Intel SSD, and love the performance. It's hard to go back to a spinning platter after you've lived with an SSD for awhile. At the time I installed the SSD I was running Snow Leopard and I used Trim Enabler to enable TRIM support. Zero issues.

After 10.8.1 was released I upgraded to Mountain Lion, and downloaded the latest Trim Enabler to re-enable TRIM. A week later 10.8.2 became available and I installed the update and again re-enabled TRIM. Apart from battery life issues the machine runs very reliably.

Everything worked great until about two weeks ago when I enabled FileVault2. Ever since then, the machine kernel panics at login about 20% of the time. If it gets past the KP it seems to run fine, but in 5 years of owning 3 Macs, I had never seen a kernel panic ever up until this point. Here are some additional clues:

1) I used Carbon Copy Cloner to clone the SSD to a 7200 RPM WD Scorpio Black HDD, and swapped the drives. I never see Kernel Panics when running the HDD.

2) I thought that maybe Trim Enabler had corrupted the Kernel (even though that issue with earlier versions of Trim Enabler has since been resolved). Today's experiment: I put the SSD back in the MBP and made a bootable 10.8.2 installer on a USB stick. I did a complete re-install of the OS. Interestingly enough, the install kept the encrypted disk image. It asked me for a password to unlock the disk, and then proceeded to re-install 10.8.2 on the encrypted disk. When it finished, the first time it rebooted I got a kernel panic. I went into About The Mac and determined that Trim was not enabled, which is what I expected. (i.e. I think I have successfully restored to a pre-Trim Enabler state, which would eliminate Trim Enabler as a cause).

3) I went into System Prefs and turned off FileVault2. When the machine finished decrypting the disk, I rebooted. No Kernel Panic. And I see that I'm back to the regular login (not the FileVaulted login). I've rebooted the machine about 20 times and no kernel panics.


4) I booted off the USB stick, ran Disk Utility and erased the SSD. Then did a completely clean install of 10.8.2. Did not run the migration assistant thing, so I have a totally squeaky-clean install. Turned on FileVault. When the machine rebooted to begin the encryption, it immediately had a kernel panic. Gah.

FileVault hates my SSD.



Here's a sample KP:



Interval Since Last Panic Report: 499670 sec
Panics Since Last Report: 1
Anonymous UUID:

Tue Oct 23 18:27:08 2012
panic(cpu 0 caller 0xffffff800ceb7bd5): Kernel trap at 0xffffff7f8de93578, type 13=general protection, registers:
CR0: 0x000000008001003b, CR2: 0xffffff80ee8ce000, CR3: 0x000000000fb03000, CR4: 0x0000000000000660
RAX: 0x0000000012cfb21f, RBX: 0x01ffff801efcd000, RCX: 0x00000000658f72f3, RDX: 0x0000000000000000
RSP: 0xffffff80f40c3e50, RBP: 0xffffff80f40c3e60, RSI: 0x0000000000000002, RDI: 0xffffff800d401ef0
R8: 0x0000000000000001, R9: 0x00000000000003ff, R10: 0xffffffffffffffff, R11: 0x00000000ffffffff
R12: 0xffffff801efcd000, R13: 0xffffff801ebd1900, R14: 0xffffff801ef70100, R15: 0x0000000000000001
RFL: 0x0000000000010246, RIP: 0xffffff7f8de93578, CS: 0x0000000000000008, SS: 0x0000000000000000
Fault CR2: 0xffffff80ee8ce000, Error code: 0x0000000000000000, Fault CPU: 0x0

Backtrace (CPU 0), Frame : Return Address
0xffffff80f40c3af0 : 0xffffff800ce1d626
0xffffff80f40c3b60 : 0xffffff800ceb7bd5
0xffffff80f40c3d30 : 0xffffff800cece4ed
0xffffff80f40c3d50 : 0xffffff7f8de93578
0xffffff80f40c3e60 : 0xffffff800d23181b
0xffffff80f40c3ea0 : 0xffffff800d23133e
0xffffff80f40c3f30 : 0xffffff800d22d2d0
0xffffff80f40c3f70 : 0xffffff800d231e99
0xffffff80f40c3fb0 : 0xffffff800ceb26b7
Kernel Extensions in backtrace:[1C94C4BC-B05C-36D4-B1A2-B0BE04A5C620]@0xfff fff7f8de92000->0xffffff7f8dea4fff
dependency:[C3094550-7F58-3933-A4F7-CD33AE83F8B9]@0xffff ff7f8dbab000
dependency:[B1B77B26-7984-302F-BA8E-544DD3D75E73]@0xffff ff7f8d472000

BSD process name corresponding to current thread: kernel_task

Mac OS version:
Not yet set

Kernel version:
Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64
Kernel UUID:
Kernel slide: 0x000000000cc00000
Kernel text base: 0xffffff800ce00000
System model name: MacBookPro5,5 (Mac-F2268AC8)

System uptime in nanoseconds: 941471620
last loaded kext at 282686089:     2.5.0 (addr 0xffffff7f8e298000, size 53248)
loaded kexts:     2.2.2     602.15.22     196.0.0     5.2.5     4.9.6     2.4.1     2.0.19     5.4.0     5.2.5     1.5     1.6.1     161.0.0     1.7     1.6     1.9     1.6     1.6     4.0.39     2     196.0.0     2.5.0     3.5.1     500.15     5.2.5     4.5.5     2.2.1     3.0     5.4.0     2.2.9     1.6.1     1.8.0     1.1     220     1.0.0d1     7     344     1.8     28.21     1.6     2.7.2     1.4     1.0
Model: MacBookPro5,5, BootROM MBP55.00AC.B03, 2 processors, Intel Core 2 Duo, 2.53 GHz, 8 GB, SMC 1.47f2
Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MB
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz, 0x859B, 0x435435313236344243313036372E4D313646
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1067 MHz, 0x859B, 0x435435313236344243313036372E4D313646
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (
Bluetooth: Version 4.0.9f33 10885, 2 service, 18 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: INTEL SSDSC2CW240A3, 240.06 GB
Serial ATA Device: HL-DT-ST DVDRW GS23N
USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0x24400000 / 2
USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0x26500000 / 2
USB Device: MobilePre, 0x0763 (M-Audio), 0x200f, 0x04100000 / 4
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0236, 0x04600000 / 3
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x04500000 / 2
USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x06100000 / 2
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8213, 0x06110000 / 4

  • Kappy Level 10 Level 10 (220,980 points)
    Currently Being Moderated
    Nov 5, 2012 1:16 PM (in response to OBDave)

    Here's my opinion: MBP + SSD and no FileVault2. Why do you need FileVault at all? Is your M-audio device compatible with Mountain Lion?

  • Kappy Level 10 Level 10 (220,980 points)
    Currently Being Moderated
    Nov 5, 2012 2:13 PM (in response to OBDave)

    Here's my thoughts. Take them for what they are worth.


    Unless you work with that machine in an environment where security is a requirement, like a government office, then you don't need FileVault. Much easier to put any sensitive data you have into an encrypted disc image stored on a flash drive (or get an encrypted flash drive) you carry with you. That way your data are safe because they aren't kept on the computer.


    My other suggestion is don't let the computer get lost or stolen.

  • wjosten Level 10 Level 10 (91,280 points)
    Currently Being Moderated
    Nov 5, 2012 2:27 PM (in response to OBDave)

    Kappy's advice is dead on, & unless you store nuclear launch codes or hundreds of Swiss account numbers, you really don't need FileVault2. Huge performance hit for what could be done following Kapp's advice.

  • JShimazaki Level 2 Level 2 (355 points)
    Currently Being Moderated
    Nov 5, 2012 4:23 PM (in response to OBDave)

    0BDave, have you tried reseting the SMC and PRAM? Also check if the SSD firmware is current. Good luck!!

  • JShimazaki Level 2 Level 2 (355 points)
    Currently Being Moderated
    Nov 5, 2012 5:27 PM (in response to OBDave)

    OBDave, thanks for the update. The only thing I could think of is updating your Mac's EFI. Based on your model It's obviously a compatibility issue and updating the EFI may solve it.  Here the link to update your EFI.

  • JShimazaki Level 2 Level 2 (355 points)
    Currently Being Moderated
    Nov 5, 2012 6:02 PM (in response to OBDave)

    LOL.....It kinda helps to include all the troubleshooting you performed in order to eliminate the possiblities.....

  • Linc Davis Level 10 Level 10 (107,470 points)
    Currently Being Moderated
    Nov 5, 2012 6:24 PM (in response to OBDave)

    I disagree with the advice you're being given about FileVault. There's no reason not to use it. However, you wrote in your original message that you installed "TRIM Enabler." If you hack your system, you're on your own. You should expect problems with that configuration, and you should be prepared to solve those problems yourself.

1 2 3 ... 5 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (3)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.