Previous 1 2 3 4 5 Next 68 Replies Latest reply: Apr 6, 2013 12:58 PM by OBDave Go to original post
  • OBDave Level 1 Level 1 (5 points)

    Hi Nathandim,


    Thanks. This is very interesting. I think you're right, this drive appears to be strictly SATA-2, which kind shoots down my SATA speed negotiation theory.


    I googled MK2555GSXF kernel panic and found this guy, who seems to be having the exact same issue as you:


    I guess I need to modify my theory. It seems this problem is not limited to SSDs or SATA-3 devices.

  • JoMek Level 1 Level 1 (0 points)

    OBDave wrote:


    Are you using an afterermarket hard drive, or the original drive that came in your MBP?


    Hi O.P.,


    I am still using the original drive, Hitachi HTS545050B9SA02. I did Apple's hardware test, which came up OK.


    I also did some extended testing using a Linux live-CD; my drive seems to be completely flawless.


    I have been using FileVault since I bought the MBP, there never were any problems. They only started with Mountain Lion.

  • OBDave Level 1 Level 1 (5 points)

    Since my Applecare support for Mountain Lion is expiring soon I decided to call in and see what they have to say. My call was escalated to a second level support person (or whatever the Apple lingo is for that), and he seemed to understand my issue, and while FV2 should work with an aftermarket drive, because it's an aftermarket drive there's not much that they could do. He said that if I could reproduce the issue on the original drive I might be able to send the MBP in to have them analyze it. I'm pretty strapped for time these days so this isn't going to be feasible for me. And I kinda suspect that chasing down kernel bugs on 3+ year old hardware won't be bubbling to the top of the priority list anytime soon.

  • Saguinus Level 1 Level 1 (10 points)

    I have exactly the same problem on similar hardware.


    We have a MacBook Air, late 2010, 256GB Apple SSD with FileVault 2 enabled on Mountain Lion 10.8.2.


    The kernel panics occur immediately after logging in, and the frequency is probably similar to yours at about 20% of the time. These kernel panics started occuring only after moving from Lion to Mountain Lion. The FileVault 2 volume worked fine under Lion.


    I ran Apple hardware test, which came back ok. I reinstalled the OS, with no change. I used Onyx to do some cleaning of cache files, and ran disk utility to repair permissions and repair disk when booted from the recovery drive. No issues were found and the problem continued.


    Eventually, I took it in to my local Apple Store. They agreed to look at the problem (the Mac has 3 years' Applecare). They suggested it could be a corrupted FileVault, or a potential hardware issue. So they turned off the FileVault, then left it on a reboot cycle overnight. The computer never missed a restart...


    So they replaced the logic board, re-enabled FileVault, and returned the MacBook Air to me.


    When I got it home, we booted it up and a kernel panic occurred. This was on a fresh Apple SSD volume... I rebooted some more times and got a few more kernel panics. Then I turned off the FileVault again, restored the original account and files from a TM backup. We have not had a kernel panic since.


    There is clearly a problem with the combination of FileVault 2 and Mountain Lion, on the Apple SSD in the MBA.


    My next step will be to contact Apple again and see how they want to progress this. FileVault is a mooted feature, and Apple need to make sure it works on all supported hardware.

  • OBDave Level 1 Level 1 (5 points)

    Thank you so much for posting this, and please keep us informed of any progress. I guess I'm on my third or fourth theory now, but now that a few people are reporting this issue on totally stock hardware, I now suspect the root cause is a ML kernel bug that only manifests itself at login when using FileVault2.


    I'm hoping if enough people report the issue that Apple will debug it and provide a kernel fix in a forthcoming release.

  • Saguinus Level 1 Level 1 (10 points)

    Regarding my MacBook Air (Late 2010)...


    Today I talked with an AppleCare Senior Advisor in the UK about the case. I also referred him to these forum threads on the subject.


    He has asked me to replicate the kernel panic and use an Apple data capture program to capture additional information about the crash. The data will be forwarded to engineers. I have just turned FV back on and will do this as soon as I can.


    The advisor acknowledged that a number of users appear to be affected with this problem, and was keen to resolve the problem for us.


    I will update you guys when I hear back from Apple.

  • Saguinus Level 1 Level 1 (10 points)

    Another update for you.


    The AppleCare UK senior advisor that I spoke to a few days ago got back to me today.


    He said that the data capture file I submitted has been looked at by an Apple engineer.


    The word is that they have a small number of similar reports from other users. I wasn't informed how many there were.


    Apparently they are working on the problem, but they haven't yet isolated the issue. They recognise that some hardware platforms are affected while others are not. For example, our 2011 MacBook Air with Mac OS X 10.8.2 and FileVault 2 does not have the problem, but our 2010 MBA does...


    The engineers have also seen these threads on the subject, but they can't post directly. The advisor said that they hope to be able to release a fix in a forthcoming software update, and/or a bulletin page in the support area, but that affected users should disable FileVault for the moment. There will also likely be an internal message to Apple Stores to make staff aware of the symptoms.


    I think we are all hoping that they don't need to do a hardware recall...


    One further thing he said was that if users get a FileVault related kernel panic, they can call AppleCare and explain that this is a recognised problem. You should be able to do this even if your machine is out of warranty. An advisor may then send you the data capture program, depending on your hardware.

  • OBDave Level 1 Level 1 (5 points)



    Thank you very much for posting this update. This is good news. When I get a chance I will call US Applecare and see how far I get. The last time I spoke with them, they were not very forthcoming and claimed to have never heard of this issue before. If you happen to have a Case ID or trouble ticket number we could reference, that would be helpful as well. I hope if we get enough squeaky wheels to complain about this problem, it will get fixed.





  • Nathandim Level 1 Level 1 (0 points)

    Thank you for the info. Now I'll just wait for a fix.

  • JoMek Level 1 Level 1 (0 points)

    Here's another observation I've made regarding this bug:


    So far, the kernel panic never happened when I use an administrator account to boot up the FileVault2-encrypted machine.


    It's only when I use a user (non-administrator) account that I get kernel panics about 20% of the time.


    As I said, this is just an observation. Maybe if I boot with an admin-account 1,000 times I might get a kernel panic as well ...

  • OBDave Level 1 Level 1 (5 points)

    Hmm, it's an interesting theory. My data doesn't really conform to it, I just have one user account with admin privileges, and that's what generated all the kernel panics. I currently do not have FV enabled as I'm not sure whether the KPs corrupt the file system or not. I've got all my work and personal files in an encrypted disk image that I mount at login.


    My mid 2009 iMac (totally bone stock) has FileVault2 enabled, and it's generated one kernel panic at login. I do embedded software development for a living and I wish they could give me some tools and turn me loose on the problem. At this point I'd bet a pint that it's some sort of a weird timing issue at boot, like the kernel attempts to read from the SATA hardware but doesn't wait long enough for it to initialize, or something like that. Or maybe it's something dumb like an uninitialized variable. It does seem to be hardware dependent - folks who have the issue see it frequently, and those who don't rarely if ever see it.

  • kagero_mski Level 1 Level 1 (0 points)

    Glad to know that I am not alone in this problem. 


    @ Saguinus I have the exact same problem with my MacBook Air (2010).  Pretty much did the same thing you did.

    When I took it to the AppleStore, I ended up going back 4 times, ending up with 3 separate logic board replacements (roughly 3 months in a row) which the Apple Store had recommended that I do.

    Each time the problem came back.  I narrowed it down last month with filevault.  The problem only started after I installed mountain lion and enabling filevault.  Since I turned off filevault, I haven't gotten the kernel panic again but I am still having problems with corruption on my screen when my system recovers from sleep (likely a different issue). 


    @SaguinusJoMek I do get the kernel panic on my administrator account often when I had Filevault enabled.

  • tom3f Level 1 Level 1 (0 points)

    Hi, It's not only problem with MBP + SSD + FileValut2, I have old Macbook White Late 2009 (A1342). My macbook is with original HDD. I have only diferent RAM because orginal 2GB was to low. When I use my macbook I don't have any problem but with filevalut 2 I had in 20% of boot ups kernel panic. So it's not only SSD related. It apears with HDD too.


    This is post I made before on this forum becouse I didn't found this post.


    I don't have warranty and in my country we don't have official apple store so I didn't try go there but I run apple hardware test and everithing is ok. And in this my thread on forum one user try tu convince me that my HDD is failing but I didn't believe it because I never had problem without filevalut.

  • SpyderZ Level 1 Level 1 (0 points)

    I also have this problem on my 2009 13" MacBook Pro with 128GB Samsung drive and Mountain Lion. Looks like you guys have nailed it down to the root cause.


    I just did a clean install of everything, then turned on File Vault2 and all panic **** went lose. Turning it off for now until the fix comes.

  • UshakovAA Level 1 Level 1 (0 points)

    Have same  problem on  MBA 11' 2010  with 64gb ssd (