Previous 1 2 3 Next 68 Replies Latest reply: Apr 6, 2013 12:58 PM by OBDave
OBDave Level 1 (5 points)

Hello - I'm hoping someone here might be able to offer some insight into something I'm seeing. I've Googled and not found the specific set of weirdnesses I'm seeing.

I have a 13-inch Mid 2009 MBP. About six months ago I installed a 256 GB Intel SSD, and love the performance. It's hard to go back to a spinning platter after you've lived with an SSD for awhile. At the time I installed the SSD I was running Snow Leopard and I used Trim Enabler to enable TRIM support. Zero issues.

After 10.8.1 was released I upgraded to Mountain Lion, and downloaded the latest Trim Enabler to re-enable TRIM. A week later 10.8.2 became available and I installed the update and again re-enabled TRIM. Apart from battery life issues the machine runs very reliably.

Everything worked great until about two weeks ago when I enabled FileVault2. Ever since then, the machine kernel panics at login about 20% of the time. If it gets past the KP it seems to run fine, but in 5 years of owning 3 Macs, I had never seen a kernel panic ever up until this point. Here are some additional clues:

1) I used Carbon Copy Cloner to clone the SSD to a 7200 RPM WD Scorpio Black HDD, and swapped the drives. I never see Kernel Panics when running the HDD.

2) I thought that maybe Trim Enabler had corrupted the Kernel (even though that issue with earlier versions of Trim Enabler has since been resolved). Today's experiment: I put the SSD back in the MBP and made a bootable 10.8.2 installer on a USB stick. I did a complete re-install of the OS. Interestingly enough, the install kept the encrypted disk image. It asked me for a password to unlock the disk, and then proceeded to re-install 10.8.2 on the encrypted disk. When it finished, the first time it rebooted I got a kernel panic. I went into About The Mac and determined that Trim was not enabled, which is what I expected. (i.e. I think I have successfully restored to a pre-Trim Enabler state, which would eliminate Trim Enabler as a cause).

3) I went into System Prefs and turned off FileVault2. When the machine finished decrypting the disk, I rebooted. No Kernel Panic. And I see that I'm back to the regular login (not the FileVaulted login). I've rebooted the machine about 20 times and no kernel panics.


4) I booted off the USB stick, ran Disk Utility and erased the SSD. Then did a completely clean install of 10.8.2. Did not run the migration assistant thing, so I have a totally squeaky-clean install. Turned on FileVault. When the machine rebooted to begin the encryption, it immediately had a kernel panic. Gah.

FileVault hates my SSD.



Here's a sample KP:



Interval Since Last Panic Report: 499670 sec
Panics Since Last Report: 1
Anonymous UUID:

Tue Oct 23 18:27:08 2012
panic(cpu 0 caller 0xffffff800ceb7bd5): Kernel trap at 0xffffff7f8de93578, type 13=general protection, registers:
CR0: 0x000000008001003b, CR2: 0xffffff80ee8ce000, CR3: 0x000000000fb03000, CR4: 0x0000000000000660
RAX: 0x0000000012cfb21f, RBX: 0x01ffff801efcd000, RCX: 0x00000000658f72f3, RDX: 0x0000000000000000
RSP: 0xffffff80f40c3e50, RBP: 0xffffff80f40c3e60, RSI: 0x0000000000000002, RDI: 0xffffff800d401ef0
R8: 0x0000000000000001, R9: 0x00000000000003ff, R10: 0xffffffffffffffff, R11: 0x00000000ffffffff
R12: 0xffffff801efcd000, R13: 0xffffff801ebd1900, R14: 0xffffff801ef70100, R15: 0x0000000000000001
RFL: 0x0000000000010246, RIP: 0xffffff7f8de93578, CS: 0x0000000000000008, SS: 0x0000000000000000
Fault CR2: 0xffffff80ee8ce000, Error code: 0x0000000000000000, Fault CPU: 0x0

Backtrace (CPU 0), Frame : Return Address
0xffffff80f40c3af0 : 0xffffff800ce1d626
0xffffff80f40c3b60 : 0xffffff800ceb7bd5
0xffffff80f40c3d30 : 0xffffff800cece4ed
0xffffff80f40c3d50 : 0xffffff7f8de93578
0xffffff80f40c3e60 : 0xffffff800d23181b
0xffffff80f40c3ea0 : 0xffffff800d23133e
0xffffff80f40c3f30 : 0xffffff800d22d2d0
0xffffff80f40c3f70 : 0xffffff800d231e99
0xffffff80f40c3fb0 : 0xffffff800ceb26b7
Kernel Extensions in backtrace:[1C94C4BC-B05C-36D4-B1A2-B0BE04A5C620]@0xfff fff7f8de92000->0xffffff7f8dea4fff
dependency:[C3094550-7F58-3933-A4F7-CD33AE83F8B9]@0xffff ff7f8dbab000
dependency:[B1B77B26-7984-302F-BA8E-544DD3D75E73]@0xffff ff7f8d472000

BSD process name corresponding to current thread: kernel_task

Mac OS version:
Not yet set

Kernel version:
Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64
Kernel UUID:
Kernel slide: 0x000000000cc00000
Kernel text base: 0xffffff800ce00000
System model name: MacBookPro5,5 (Mac-F2268AC8)

System uptime in nanoseconds: 941471620
last loaded kext at 282686089:     2.5.0 (addr 0xffffff7f8e298000, size 53248)
loaded kexts:     2.2.2     602.15.22     196.0.0     5.2.5     4.9.6     2.4.1     2.0.19     5.4.0     5.2.5     1.5     1.6.1     161.0.0     1.7     1.6     1.9     1.6     1.6     4.0.39     2     196.0.0     2.5.0     3.5.1     500.15     5.2.5     4.5.5     2.2.1     3.0     5.4.0     2.2.9     1.6.1     1.8.0     1.1     220     1.0.0d1     7     344     1.8     28.21     1.6     2.7.2     1.4     1.0
Model: MacBookPro5,5, BootROM MBP55.00AC.B03, 2 processors, Intel Core 2 Duo, 2.53 GHz, 8 GB, SMC 1.47f2
Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MB
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz, 0x859B, 0x435435313236344243313036372E4D313646
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1067 MHz, 0x859B, 0x435435313236344243313036372E4D313646
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (
Bluetooth: Version 4.0.9f33 10885, 2 service, 18 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: INTEL SSDSC2CW240A3, 240.06 GB
Serial ATA Device: HL-DT-ST DVDRW GS23N
USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0x24400000 / 2
USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0x26500000 / 2
USB Device: MobilePre, 0x0763 (M-Audio), 0x200f, 0x04100000 / 4
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0236, 0x04600000 / 3
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x04500000 / 2
USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x06100000 / 2
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8213, 0x06110000 / 4

  • OBDave Level 1 (5 points)

    OK, so I ran the extended Apple Hardware Test for a few hours with no errors reported.

    I booted off the 10.8.2 thumbdrive, ran Disk Utility and deleted the Mac partition on the SSD, then created a new one from Scratch. Installed OSX. Checked for updates. So fresh partition, fresh OS. Rebooted a coupe times, no problems.

    Turned on FileVault. When it finished, rebooted and immediately got a kernel panic at login.


    After doing some googling last night, I'm reading a lot about problems with the NVidia SATA chipset, in particular some serious incompatibilities with the Sandforce controllers used in many SSDs, including my Intel SSD. Try Googling "mac nvidia sandforce" and "mac nvidia ssd"


    These incompatibilities seem to have more to do with the SATA speed negotiation, but clearly something bad is happening at boot, but only when Filevault enabled. I think I'm screwed. I suspect my only option with this MBP is to either go back to the HDD or forego FileVault.


    Mon Nov  5 12:34:35 2012

    panic(cpu 0 caller 0xffffff8019ab7bd5): Kernel trap at 0xffffff8019a2da10, type 13=general protection, registers:

    CR0: 0x000000008001003b, CR2: 0xffffff80fb3f5000, CR3: 0x000000001c6a1000, CR4: 0x0000000000000660

    RAX: 0x0000000000000001, RBX: 0xffffff802be52aa0, RCX: 0x0000000009000000, RDX: 0xffffff80f5396078

    RSP: 0xffffff8100bfbe50, RBP: 0xffffff8100bfbe80, RSI: 0xffffff80f5396068, RDI: 0x0000000000000000

    R8:  0xffffff801a0bec60, R9:  0xffffffffffffffff, R10: 0x00000000ffffffff, R11: 0x00000000ffffff80

    R12: 0xffffff801a0bebe8, R13: 0xffffff802be4cad0, R14: 0x01ffff802be4caa0, R15: 0x0000000000000000

    RFL: 0x0000000000010002, RIP: 0xffffff8019a2da10, CS:  0x0000000000000008, SS:  0x0000000000000000

    Fault CR2: 0xffffff80fb3f5000, Error code: 0x0000000000000000, Fault CPU: 0x0



    Backtrace (CPU 0), Frame : Return Address

    0xffffff8100bfbaf0 : 0xffffff8019a1d626

    0xffffff8100bfbb60 : 0xffffff8019ab7bd5

    0xffffff8100bfbd30 : 0xffffff8019ace4ed

    0xffffff8100bfbd50 : 0xffffff8019a2da10

    0xffffff8100bfbe80 : 0xffffff8019e2e1e9

    0xffffff8100bfbec0 : 0xffffff8019e2ca47

    0xffffff8100bfbf30 : 0xffffff8019e2d3a2

    0xffffff8100bfbf70 : 0xffffff8019e31e99

    0xffffff8100bfbfb0 : 0xffffff8019ab26b7



    BSD process name corresponding to current thread: kernel_task



    Mac OS version:

    Not yet set



    Kernel version:

    Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64

    Kernel UUID: 69A5853F-375A-3EF4-9247-478FD0247333

    Kernel slide:     0x0000000019800000

    Kernel text base: 0xffffff8019a00000

    System model name: MacBookPro5,5 (Mac-F2268AC8)



    System uptime in nanoseconds: 1231252501

    last loaded kext at 921958359:          602.15.22 (addr 0xffffff7f9aeae000, size 2265088)

    loaded kexts:          602.15.22          4.9.6          2.0.19          2.4.1          1.6.1          196.0.0          5.4.0          5.2.5          161.0.0          1.5          1.7          1.6          1.9          1.6          1.6          4.0.39          2          196.0.0          500.15          4.5.5          3.0          2.2.1          2.2.9          5.4.0          1.6.1          1.8.0          1.1          220          1.0.0d1          7          344          1.8          28.21          1.6          2.7.2          1.4          1.0

  • Kappy Level 10 (265,726 points)

    Here's my opinion: MBP + SSD and no FileVault2. Why do you need FileVault at all? Is your M-audio device compatible with Mountain Lion?

  • OBDave Level 1 (5 points)

    I love the performance of the SSD. But I'd ike to enable FileVault in case my MBP ever gets lost or stolen.


    The M-Audio device is compatibile with ML, but if you look at the second KP you'll see it's no longer part of the equation. The machine KPs with a fresh OS install on a fresh partition, just by enabling FileVault.

  • Kappy Level 10 (265,726 points)

    Here's my thoughts. Take them for what they are worth.


    Unless you work with that machine in an environment where security is a requirement, like a government office, then you don't need FileVault. Much easier to put any sensitive data you have into an encrypted disc image stored on a flash drive (or get an encrypted flash drive) you carry with you. That way your data are safe because they aren't kept on the computer.


    My other suggestion is don't let the computer get lost or stolen.

  • wjosten Level 10 (94,210 points)

    Kappy's advice is dead on, & unless you store nuclear launch codes or hundreds of Swiss account numbers, you really don't need FileVault2. Huge performance hit for what could be done following Kapp's advice.

  • OBDave Level 1 (5 points)

    There are lots of reasons one might want whole-disk encryption. There are so many reasons, in fact, that Apple went out of their way to implement it as a feature. Perhaps I do have one or two nuclear launch codes I'd like to keep secret. Perhaps I exchange emails with my accountant, my lawyer, and my doctor. Perhaps I do contract work under NDA, and would like to keep my client emails and files as secure as I can. That doesn't seem like too much to ask, especially when the OS actually has a feature for doing exactly that.


    I did consider making an encrypted disk image, and I could make that work with regular data files, but what about stuff that gets stored in Libraries? Email, contacts, calendar, etc. My understanding is that it's not possible to encapsulate that stuff inside an encrypted disk image. For similar reasons the encrypted flash drive is a non-starter.

    Don't let the computer get lost or stolen? Thanks, I'll file that one next to "never get sick" and "never be in a plane crash."


    I was hoping for more insight into the underlying cause of the kernel panics, but I thank you for taking the time to reply.

  • JShimazaki Level 2 (355 points)

    0BDave, have you tried reseting the SMC and PRAM? Also check if the SSD firmware is current. Good luck!!

  • OBDave Level 1 (5 points)

    Thanks JShimazaki, I neglected to mention those things. I did zap the PRAM and reset the SMC yesterday. I also downloaded the latest firmware from Intel and determined that the SSD was already running the latest FW.

  • JShimazaki Level 2 (355 points)

    OBDave, thanks for the update. The only thing I could think of is updating your Mac's EFI. Based on your model It's obviously a compatibility issue and updating the EFI may solve it.  Here the link to update your EFI.

  • OBDave Level 1 (5 points)

    Ha, sorry, I forgot to mention that too. Mine's a MacBookPro5,5, and I did verify that I had the latest EFI and SMC version.

  • JShimazaki Level 2 (355 points)

    LOL.....It kinda helps to include all the troubleshooting you performed in order to eliminate the possiblities.....

  • OBDave Level 1 (5 points)

    Hahahaha, I know. I do appreciate your taking the time to make suggestions and I apologize for the omissions. I've tried so many things so many different times, and I neglected to keep good notes. I also have a thread open on the often-helpful macrumors forums, and I've been updating that thread when you've reminded me of things I'd checked for but forgotten to mention.


    It really does seem like I covered all the bases, which makes the reports of NVidia SATA controller bugs all the more troubling.

  • Linc Davis Level 10 (192,265 points)

    I disagree with the advice you're being given about FileVault. There's no reason not to use it. However, you wrote in your original message that you installed "TRIM Enabler." If you hack your system, you're on your own. You should expect problems with that configuration, and you should be prepared to solve those problems yourself.

  • OBDave Level 1 (5 points)

    Just to clarify: I did run for about six months with Trim Enabler under Snow Leopard with no issues whatsoever. The system worked great. I then ran for several more weeks under ML with Trim Enabler, also with no issues. It wasn't until I enabled FileVault that I started getting Kernel Panics. When I first encountered this issue, Trim Enabler was the first thing I suspected and removed it. I do not have Trim enabled now. The system is now entirely bone-stock apart from the aftermarket SSD. And yet it still KPs.


    Should I expect there to be problems when using an Intel SSD? Do you consider installing a non-OEM SSD "hacking my system?"

Previous 1 2 3 Next