Previous 1 2 3 Next 35 Replies Latest reply: Nov 14, 2012 1:40 PM by leonard1212
leonard1212 Level 1 (0 points)

After some update ?  I can´t import pics from my internal HD as I did för yrs.... Sometimes not even from an USB stick. Directly from camera is ok. No files show up when I indicate in the import ehere th new pics are..??? Have updateted and even reinstalled Aperture, checked harddrive , controlled and repaired etc etc...

What happened???

MacBook Pro, Mac OS X (10.7.5)
  • léonie Level 10 (90,550 points)

    Just to be sure - have you checked your import settings, if some file types are excluded? Sometimes an upgrade resets some preferences setting.


    I'd check the Import panel settings for file types, raw&jpeg pairs, duplicates.





    import sett.png

  • leonard1212 Level 1 (0 points)

    Thanks Léonie! But I did try that and even reinstalled Aperture since I can´t find any "" file they suggest I should remowe. That file does not exist on any user of my mac -only 2 users.

    Aperture 2sees" some librarys with photos on harddrive but not some others?? It is very frustrating...

    I have ticked and unticked all the boxes , restarted, checked harddrive repaired databases some times etc...

    Had Aperture for 3 yrs and this problems started some 4 months ago...???Spent days trying....

  • léonie Level 10 (90,550 points)

    Probably you could not find the preferences file because the user library is hidden by default in Mac OS X 10.75 Lion; but the file must exist - other wise your system really would be broken.

    Reveal the Library from the Finder's "Go" menu:


    • Quit Aperture, if it is running:
    • Open the user library by using the Finder's "Go " menu and hold down the options-key, until "Library" appears in the drop down menu. Select it.
    • In the widow that will open, scroll down to "Preferences"
    • From the "Preferences" folder  remove "" to the Desktop.
    • Then try to launch Aperture again.
    • If this does not help, move the Preferences back.


    You might also wish to try to remove the Image Capture preferences:


    see this post by fof:


    Re: Aperture 3.4 will not open after 10.8.2 installed



      • Quit Aperture, if it is running:
      • Open the user library by using the Finder's "Go > Go to Folder" menu,
      • enter    ~/Library/Preferences/ByHost   into the textfield.
      • In the widow that will open, remove all files from the "ByHost" folder, that have "" in its name.
      • From the "Preferences" folder  remove "".
      • Then try to launch Aperture again.



    Post back, if that does not solve the problem.




  • leonard1212 Level 1 (0 points)

    Thanks again!

    I do not have the file "" in my system!??

    Tried to remove all 6 files from ByHost with imageCapture in them. Started up and

    first it looked good since the option "store files in current location" was not greyed out which also is an additional problem occuring parallell to the "no see my files" business...

    But when I go to some location were i store my pics on HDrive it´s greyed out again and agaIN DO NOT SHOW??

    Regardless if I untick do not import duplicates 10 times!! Spooky???? or what??? The mac works allright otherwise....any ideas????

  • léonie Level 10 (90,550 points)

    Thanks again!

    I do not have the file "" in my system!??

    Aperture will write that file when it quits:


    Did you quit Aperture before checking? With the new process system in Mac OS X Lion you even should log off and on again, to be sure that Aperture really quits.


    If Aperture cannot write the file because of permission problems, it might write the file to the temporary directory instead.

    Have you tried to repair the permissions on your system drive? You can check and repair the permissions with Disk Utility.

    You can inspect the temporary directory from the Terminal window; launch the "" and enter

         open $TMPDIR

    Then browse the nested folders for a folder called

    Quit Aperture, and remove any temporary items in > TemporaryItems.

  • leonard1212 Level 1 (0 points)

    In the TMPDIR is and under TemporaryItems is nothing!

    Still no "" even after logout and in????


    The phenomenon with the greyed out save...- current ..location is also annoying because I have a system where I have used this optiion for 2 yrs but now it doesn´t work??? If I try to import from some library on my HD

    were I store my originals it automatically shifts from current location to something else...


    Lightroom or what alternatives are there???


    Regards again /

  • leonard1212 Level 1 (0 points)

    And ....additionally - for some reason I can not "save in current location" just occasionally this option is greyed out. I do not see any logical pattern as to whan that happens??? Pls Help!! Someone....

  • léonie Level 10 (90,550 points)


    I am totally puzzled like you.

    Have you really looked in the user library for the preferences file and not accidentally in the system library?

    Please check again - you can go directly to the "Preferences" folder from the Terminal window by pasting

         open ~/Library/Preferences

    into the window, or - in the Finder - by using the keyboard shortcut ⇧⌘G and pasting


    into the "Go to the Folder" textfield.


    The must be somewhere. The settings in this file determine which options will be available by default and which not.

  • leonard1212 Level 1 (0 points)

    Thanks a whole lot for Your patiense leonie!!

    There You were absoulutely right and I removed the file

    ""! This did not change much!?

    I took 14 test pics put them on my desktop and tried to import in a testproject.

    In the lower right corner is : Do youu want to import 14 files to...BUT there are no files/pics to see and

    if I click yes nothing happens? And...when I start Aperture the option:save in current location "  is there, BUT if I choose a library to import from on HD this option is greyed out?? I have done this with APERTURE FOR 2 YRS AND AFTER  some of the later updates this does happen. I have done all repairs on permissions for Macintosh HD and all three alternatives repairing aperture library, even reinstalled Aperture....Lightroom or.....

    What shall I do more??? Moutain Lion??? I have Lion latest update and Aperture latest update...


    My best Regards //// hoping for a last clue or hint...

  • léonie Level 10 (90,550 points)

    At last - you found the preferences!


    A section from the screen shot you sent me: yes, this looks weird - Aperture knows the number of images, but cannot show them in the file chooser or as thumb nails.


    Aperture view copy.png


    Can other applications - Preview, Photoshop access and open the images on your desktop?


    Have you activated a file vault, that Aperture has no access to your files?


    If it is not a file vault restricting the access, have you checked the file system on your system drive?

    I'd recommend to boot into recovery mode and to check and repair the file system on your system drive:  OS X: About OS X Recovery





  • leonard1212 Level 1 (0 points)

    Other applications can open the files without hesitation....


    I have a Vault on an not connected external drive but this is only containing the versions and I have all the referenced files on my HDrive (back those up separtely manually) I had that long before these problems occured...

    Should I still connect it now????


    I have checked and repaired my file system many times, 2 times today and it finds and repairs 50-100 items every time....also strange if it repair it should be less to repair but it doesn´t seem so???


    Hope I do not have to reinstall everything???? Still hav not tried  the recovery thing...


    Should I??


    Regards again...

  • léonie Level 10 (90,550 points)

    You did not answer my previous question, if file vault is turned on. File vault is the Mac OS encryption for security.  It is activated in the System Preferences "Security and Privacy" panel. If it should be turned on, turn it off. I did not mean Aperture's vaults used for backup.


    Have you tried everything in the

    Aperture 3: Troubleshooting Basics ?



    BTW: can you import by dragging from the Desktop into Aperture's window?


    To be sure if reinstalling can help, try to launch Aperture from a different user account. Start with a new, empty library and import some images.

    If it even from a new user account does not work, run a hardware check, repair the file system, , reinstall Aperture, reinstall your Mac OS.


    But if Aperture works from a different user account, you need to check all con figurations in your account that might be different, remove Apertures presets (not only the preferences), disable login items, remove older plug-ins.


    Post back, when you know, if Aperture works from a different user account.

  • leonard1212 Level 1 (0 points)

    Thank You for not giving up!

    1. No vault turned on  and never has been.

    2. Everything tried on Aperture 3: Troubleshooting Basics

    3. No problem to import by dragging files into Aperture.

    4. Works the same way from other user: From some folders on Internal and extern SD cards Harddrives

    it works- that is I can see the files and import them, from some folders I can´t see the pictures but the nuber of files (like iin the screenshot I sent) and finally from some folders that I have imported from before I can see nothing= no numbers of files and no pics.This happens regardless if I do not tick No duplicates- then I should see the pics!? And importing from some or even looking at pics in Import mode the option "save in current location "  is not working (greyed out) . From some folders this doesn´t happen so I can save in current....???


    Have done multiple repair sessions permissions both from command +R boot for Macintosh HD (still after 2-3 repair sessions there are lots of remarks when doing a disk control of permissions, makes you wonder if the repair thing really works??) and Aperture´s 3 options..

    Everything else on the mac Macbook Pro 7i 15" 750 Gb 8 GB  Early 2011 works just fine!!

    What now??

    Regards again!!

  • leonard1212 Level 1 (0 points)

    Just checked quickly to import from a folder which Aperture doesn´t "see"  at all into iPhoto (which I never use).

    That works just perfect!! The problem seems to be isolated to Aperture!


Previous 1 2 3 Next