Skip navigation

Parental controls will not open

302 Views 4 Replies Latest reply: Dec 18, 2012 5:57 PM by sanjampet RSS
rationalisst1 Calculating status...
Currently Being Moderated
Nov 5, 2012 10:35 AM

I have an iMac with multiple users set up. One of the users has Parental Controls turned on. I went to edit the Parental Controls the other day, and found that the preference pane will not open. It simply says "loading parental controls" and never actually loads. If I click the Open Parental Controls button again the System Preferences crashes.

 

 

iMac 11,2

Snow Leopard 10.6.8

 

I tried creating a new admin user, but that does the same thing. I've rebooted many times, and also deleted the "~/Library/Preferences/com.apple.systempreferences.plist" file, but that didn't work either. I've even tried backing up and deleting the "/Library/Preferences/.GlobalPreferences.plist" file, to no avail. Any suggestions will be appreciated.

iMac, Mac OS X (10.6.8)
  • CMCSK Level 6 Level 6 (10,250 points)
    Currently Being Moderated
    Nov 5, 2012 2:52 PM (in response to rationalisst1)

    rationalisst1 wrote:

     

    deleted the "~/Library/Preferences/com.apple.systempreferences.plist" file, but that didn't work either.

     

    Try it again but this time afterwards,

    Disconnect all peripherals from your computer.

     

    Boot from your install disc & run Repair Disk from the utility menu. To use the Install Mac OS X disc, insert the disc, and restart your computer while holding down the C key as it starts up.

    Select your language.

    Once on the desktop, select Utility in the menu bar.

    Select Disk Utility.

     

    Select the disk or volume in the list of disks and volumes, and then click First Aid.

    Click Repair Disk.

    Restart your computer when done.

     

    Repair permissions after you reach the desktop-http://support.apple.com/kb/HT2963 and restart your computer.  After you reach the desktop, empty the trash and try the parental controls again.

     

     

     

     

     

     

     

     

     

     

     

    dancingsmilie.gif

  • ds store Level 7 Level 7 (30,305 points)
    Currently Being Moderated
    Nov 5, 2012 4:15 PM (in response to rationalisst1)

    Run through this list of fixes

     

    ..Step by Step to fix your Mac

  • sanjampet Level 5 Level 5 (6,890 points)
    Currently Being Moderated
    Dec 18, 2012 5:57 PM (in response to rationalisst1)

    You have to login as an administrator, Then go to system preferences and click parental controls (it will prompt you re-enter your administrator PWSD again, then select the acct you wish to change. Then allow you to access the parental controlled acct. Make sure to re-lock the pane or it will not be secure.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.