10 Replies Latest reply: Nov 14, 2012 4:41 PM by Old Toad
jthrnbt Level 1 (0 points)

When I launch Iphoto it crashes my Imac and causes it to reboot. I have tried deleting Iphoto and reinstalling it and that doesn't help. I tried Iphoto manager to rebuild the library and it aborts.

I tried this command I found in one of the other responses

(run sudo update_dyld_shared_cache -force) and it returns with run command not found. I have deleted all the photos and tried to create a new library and still crashes and reboots my Mac. I am running 10.8.2. Any help would be appreciated. I don't know what else to try. I took laptop to Apple store last week and they deleted everything and reinstalled OS.

MacBook Pro, OS X Mountain Lion (10.8.2)
  • Terence Devlin Level 10 (137,945 points)

    Create a new account (systempreferences -> accounts or Users & Groups on 10.7 and 10.8), make a new Library in that account, import some shots  and see if the problem is repeated there. If it is, then a re-install of the app might be indicated. If it's not, then it's likely the app is okay and the problem is something in the main account.

  • jthrnbt Level 1 (0 points)

    I added new user and tried to launch Iphoto. I still can't launch it whithout it rebooting my Imac.


    Here are the steps I have tried:

    - Created nrew user and triued to aunh Iphoto.

    - Used old admin account an tried to launch Iphoto.

    - Extracted photos to new folder and deleted photos from library.

    - Unistalled Iphoto and and reinstalled from App Market.

    - Tried launching Iphotot with Command & Option key down.


    None of these steps seems to work for me. I am at a loss. I have noticed a side issue also where I get the same results when trying to "Enter Time Machine"

  • Old Toad Level 10 (135,512 points)

    Boot into Safe Mode,  Mac OS X: Starting up in Safe Mode, and see if iPhoto causes a crash a reboot of your iMac.  If it does you may have to reinstall the system. 


    However, before you do try downloading and applying the OS X Mountain Lion Update v10.8.2 (Combo)

    updater followed by a repair of disk permissions with Disk Utility.



  • jthrnbt Level 1 (0 points)

    Ok. I launched in safe mode. Launched Iphoto and it opens fine with new library that it created.

    I am already running 10.8.2. Is 10.8./2 (combo) a different build? I run Disk Utilty earlier this morning.

  • Old Toad Level 10 (135,512 points)

    The combo contains all of the files in the previous 10.8 updaters and will reinstall them. So if you went from 10.8 to 10.8.2 using the incremental updater you might not have a component that was added in an earlier 10.8 updater.  The combo updater, IMO, is the more reliable updater to use and is the one most recommended by the system gurus in the Apple forums.

  • jthrnbt Level 1 (0 points)

    Man I thought I had it....

    1) I copied my Iphoto Library from a backup.

    2} I rebooted using safe mode.

    3) I was able to rebuild the library using Iphoto Manager while in safe mode.

    4) I was able to launch Iphoto from Iphoto Manager

    5) I installed 10.8.2 (combo) while in safe mode.

    6) I rebooted laptop in normal mode. I then with Disk Utility verfied and repaired disk permissions.

    7) I rebooted again in normal mode and tried to launch Iphoto and it crased again and rebooted my laptop.


    Any other ideas? I am certainly out of them.

  • Terence Devlin Level 10 (137,945 points)

    If you can launch iPhoto in Safe Mode then the issue is caused by something that Safe Mode disables - and that's usually a 3rd party app or plug-in.


    Any messages in the Console?

  • jthrnbt Level 1 (0 points)

    Here is the info from the last iphoto log:

    Tue Nov  6 17:29:47 2012

    panic(cpu 2 caller 0xffffff7f873a6b25): NVRM[0/1:0:0]: Read Error 0x00000100: CFG 0xffffffff 0xffffffff 0xffffffff, BAR0 0xd2000000 0xffffff80a5e2c000 0x0a5480a2, D0, P3/4

    Backtrace (CPU 2), Frame : Return Address

    0xffffff8082d9a8c0 : 0xffffff8006c1d626

    0xffffff8082d9a930 : 0xffffff7f873a6b25

    0xffffff8082d9a9c0 : 0xffffff7f874a04b3

    0xffffff8082d9aa20 : 0xffffff7f874a0527

    0xffffff8082d9aa90 : 0xffffff7f877b5853

    0xffffff8082d9abd0 : 0xffffff7f874c6659

    0xffffff8082d9ac00 : 0xffffff7f873b08da

    0xffffff8082d9acb0 : 0xffffff7f873abfac

    0xffffff8082d9aea0 : 0xffffff7f873ad1d8

    0xffffff8082d9af70 : 0xffffff7f8844245e

    0xffffff8082d9b030 : 0xffffff7f8843fcb3

    0xffffff8082d9b050 : 0xffffff7f8844121b

    0xffffff8082d9b180 : 0xffffff7f8843fb58

    0xffffff8082d9b1e0 : 0xffffff7f8843f6e6

    0xffffff8082d9b290 : 0xffffff7f8845f348

    0xffffff8082d9b500 : 0xffffff7f884718d9

    0xffffff8082d9b670 : 0xffffff7f88471243

    0xffffff8082d9b6a0 : 0xffffff7f884737bc

    0xffffff8082d9b6f0 : 0xffffff7f884730a3

    0xffffff8082d9b770 : 0xffffff7f88457b4a

    0xffffff8082d9b7d0 : 0xffffff7f88458415

    0xffffff8082d9b820 : 0xffffff7f8845880f

    0xffffff8082d9b8c0 : 0xffffff7f88459239

    0xffffff8082d9b900 : 0xffffff7f88414e81

    0xffffff8082d9ba80 : 0xffffff7f884557fe

    0xffffff8082d9bb40 : 0xffffff7f8841398a

    0xffffff8082d9bba0 : 0xffffff8007065bc9

    0xffffff8082d9bbc0 : 0xffffff8007067170

    0xffffff8082d9bc20 : 0xffffff8007064b8f

    0xffffff8082d9bd70 : 0xffffff8006c981e1

    0xffffff8082d9be80 : 0xffffff8006c20aed

    0xffffff8082d9beb0 : 0xffffff8006c10448

    0xffffff8082d9bf00 : 0xffffff8006c1961b

    0xffffff8082d9bf70 : 0xffffff8006ca5b16

    0xffffff8082d9bfb0 : 0xffffff8006cced53

          Kernel Extensions in backtrace:

             com.apple.NVDAResman(8.0)[A4C53A36-22B6-3075-82B9-9DE612A9C015]@0xffffff7f8733f 000->0xffffff7f87641fff

                dependency: com.apple.iokit.IOPCIFamily(2.7.2)[B1B77B26-7984-302F-BA8E-544DD3D75E73]@0xffff ff7f87272000

                dependency: com.apple.iokit.IONDRVSupport(2.3.5)[86DDB71C-A73A-3EBE-AC44-0BC9A38B9A44]@0xff ffff7f8732b000

                dependency: com.apple.iokit.IOGraphicsFamily(2.3.5)[803496D0-ADAD-3ADB-B071-8A0A197DA53D]@0 xffffff7f872e8000

             com.apple.nvidia.nv50hal(8.0)[9F3D09B5-3158-3D9E-BDA3-E71576AAD3B7]@0xffffff7f8 764f000->0xffffff7f87971fff

                dependency: com.apple.NVDAResman(8.0.0)[A4C53A36-22B6-3075-82B9-9DE612A9C015]@0xffffff7f873 3f000

                dependency: com.apple.iokit.IOPCIFamily(2.7.2)[B1B77B26-7984-302F-BA8E-544DD3D75E73]@0xffff ff7f87272000

             com.apple.GeForce(8.0)[2E56ED9A-D848-3795-9E52-56BABDC9000C]@0xffffff7f88407000 ->0xffffff7f884c9fff

                dependency: com.apple.NVDAResman(8.0.0)[A4C53A36-22B6-3075-82B9-9DE612A9C015]@0xffffff7f873 3f000

                dependency: com.apple.iokit.IONDRVSupport(2.3.5)[86DDB71C-A73A-3EBE-AC44-0BC9A38B9A44]@0xff ffff7f8732b000

                dependency: com.apple.iokit.IOPCIFamily(2.7.2)[B1B77B26-7984-302F-BA8E-544DD3D75E73]@0xffff ff7f87272000

                dependency: com.apple.iokit.IOGraphicsFamily(2.3.5)[803496D0-ADAD-3ADB-B071-8A0A197DA53D]@0 xffffff7f872e8000


    BSD process name corresponding to current thread: WindowServer


    Mac OS version:



    Kernel version:

    Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64

    Kernel UUID: 69A5853F-375A-3EF4-9247-478FD0247333

    Kernel slide:     0x0000000006a00000

    Kernel text base: 0xffffff8006c00000

    System model name: MacBookPro6,2 (Mac-F22586C8)


    System uptime in nanoseconds: 227567784471

    last loaded kext at 44911408440: com.apple.driver.AudioAUUC    1.60 (addr 0xffffff7f88f60000, size 28672)

    last unloaded kext at 190871062834: com.apple.driver.AppleUSBUHCI    5.2.5 (addr 0xffffff7f87c66000, size 65536)

    loaded kexts:

    com.jft.driver.PdaNetDrv    1.0.64

    com.Logitech.Control Center.HID Driver    3.3.0

    com.apple.driver.AudioAUUC    1.60

    com.apple.driver.AppleHWSensor    1.9.5d0

    com.apple.driver.AppleMikeyHIDDriver    122

    com.apple.driver.AppleHDA    2.3.1f2

    com.apple.driver.AppleMikeyDriver    2.3.1f2

    com.apple.driver.AGPM    100.12.69

    com.apple.filesystems.autofs    3.0

    com.apple.driver.AppleUpstreamUserClient    3.5.10

    com.apple.GeForce    8.0.0

    com.apple.driver.AppleSMCPDRC    1.0.0

    com.apple.driver.AppleLPC    1.6.0

    com.apple.iokit.BroadcomBluetoothHCIControllerUSBTransport    4.0.9f33

    com.apple.driver.AppleIntelHDGraphics    8.0.0

    com.apple.driver.AppleIntelHDGraphicsFB    8.0.0

    com.apple.driver.AppleSMCLMU    2.0.2d0

    com.apple.driver.AppleMuxControl    3.2.11

    com.apple.driver.AppleMCCSControl    1.0.33

    com.apple.driver.SMCMotionSensor    3.0.2d6

    com.apple.driver.ACPI_SMC_PlatformPlugin    1.0.0

    com.apple.iokit.IOUserEthernet    1.0.0d1

    com.apple.iokit.IOBluetoothSerialManager    4.0.9f33

    com.apple.Dont_Steal_Mac_OS_X    7.0.0

    com.apple.driver.ApplePolicyControl    3.2.11

    com.apple.driver.AppleUSBTCButtons    235.4

    com.apple.driver.AppleUSBCardReader    3.1.0

    com.apple.driver.AppleIRController    320.15

    com.apple.driver.AppleUSBTCKeyboard    235.4

    com.apple.AppleFSCompression.AppleFSCompressionTypeDataless    1.0.0d1

    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib    1.0.0d1

    com.apple.BootCache    34

    com.apple.iokit.SCSITaskUserClient    3.5.1

    com.apple.driver.XsanFilter    404

    com.apple.iokit.IOAHCIBlockStorage    2.2.2

    com.apple.driver.AppleFWOHCI    4.9.6

    com.apple.driver.AppleUSBHub    5.2.5

    com.apple.driver.AppleAHCIPort    2.4.1

    com.apple.driver.AirPort.Brcm4331    602.15.22

    com.apple.iokit.AppleBCM5701Ethernet    3.2.5b3

    com.apple.driver.AppleUSBEHCI    5.4.0

    com.apple.driver.AppleEFINVRAM    1.6.1

    com.apple.driver.AppleSmartBatteryManager    161.0.0

    com.apple.driver.AppleACPIButtons    1.6

    com.apple.driver.AppleRTC    1.5

    com.apple.driver.AppleHPET    1.7

    com.apple.driver.AppleSMBIOS    1.9

    com.apple.driver.AppleACPIEC    1.6

    com.apple.driver.AppleAPIC    1.6

    com.apple.driver.AppleIntelCPUPowerManagementClient    196.0.0

    com.apple.nke.applicationfirewall    4.0.39

    com.apple.security.quarantine    2

    com.apple.driver.AppleIntelCPUPowerManagement    196.0.0

    com.apple.driver.DspFuncLib    2.3.1f2

    com.apple.iokit.IOAudioFamily    1.8.9fc10

    com.apple.kext.OSvKernDSPLib    1.6

    com.apple.kext.triggers    1.0

    com.apple.iokit.AppleBluetoothHCIControllerUSBTransport    4.0.9f33

    com.apple.nvidia.nv50hal    8.0.0

    com.apple.NVDAResman    8.0.0

    com.apple.iokit.IOFireWireIP    2.2.5

    com.apple.driver.AppleHDAController    2.3.1f2

    com.apple.iokit.IOHDAFamily    2.3.1f2

    com.apple.driver.AppleSMBusPCI    1.0.10d0

    com.apple.driver.AppleBacklightExpert    1.0.4

    com.apple.driver.AppleSMBusController    1.0.10d0

    com.apple.driver.IOPlatformPluginLegacy    1.0.0

    com.apple.driver.IOPlatformPluginFamily    5.2.0d16

    com.apple.iokit.IOSurface    86.0.3

    com.apple.iokit.IOSerialFamily    10.0.6

    com.apple.iokit.IOBluetoothFamily    4.0.9f33

    com.apple.driver.AppleSMC    3.1.4d2

    com.apple.driver.AppleGraphicsControl    3.2.11

    com.apple.iokit.IONDRVSupport    2.3.5

    com.apple.iokit.IOGraphicsFamily    2.3.5

    com.apple.iokit.IOSCSIBlockCommandsDevice    3.5.1

    com.apple.driver.AppleUSBMultitouch    235.7

    com.apple.iokit.IOUSBHIDDriver    5.2.5

    com.apple.iokit.IOUSBMassStorageClass    3.5.0

    com.apple.driver.AppleUSBMergeNub    5.2.5

    com.apple.driver.AppleUSBComposite    5.2.5

    com.apple.iokit.IOSCSIMultimediaCommandsDevice    3.5.1

    com.apple.iokit.IOBDStorageFamily    1.7

    com.apple.iokit.IODVDStorageFamily    1.7.1

    com.apple.iokit.IOCDStorageFamily    1.7.1

    com.apple.iokit.IOAHCISerialATAPI    2.5.0

    com.apple.iokit.IOSCSIArchitectureModelFamily    3.5.1

    com.apple.iokit.IOFireWireFamily    4.5.5

    com.apple.iokit.IOAHCIFamily    2.2.1

    com.apple.iokit.IO80211Family    500.15

    com.apple.iokit.IOUSBUserClient    5.2.5

    com.apple.iokit.IOEthernetAVBController    1.0.2b1

    com.apple.iokit.IONetworkingFamily    3.0

    com.apple.iokit.IOUSBFamily    5.4.0

    com.apple.driver.AppleEFIRuntime    1.6.1

    com.apple.iokit.IOHIDFamily    1.8.0

    com.apple.iokit.IOSMBusFamily    1.1

    com.apple.security.sandbox    220

    com.apple.kext.AppleMatch    1.0.0d1

    com.apple.security.TMSafetyNet    7

    com.apple.driver.DiskImages    344

    com.apple.iokit.IOStorageFamily    1.8

    com.apple.driver.AppleKeyStore    28.21

    com.apple.driver.AppleACPIPlatform    1.6

    com.apple.iokit.IOPCIFamily    2.7.2

    com.apple.iokit.IOACPIFamily    1.4

    com.apple.kec.corecrypto    1.0

  • jthrnbt Level 1 (0 points)

    Removed all libraries and copied them to an external drive. I have unistalled Iphoto and all the files associated with it. I reinstalled Iphoto and it still reboots the Imac when creating a new library. I removed PDAnet, & VMWare since they start up under normal boot up. Does anyone know of any other processes that Safe Boot turns off that I can check for? I am about to return to Apple and reformat HD and reload OS and start from scratch.

  • Old Toad Level 10 (135,512 points)

    I think you should pose your question in the iMac or Mt. Lion forums and link to this topic.  It might be a hardware or system issue.