Skip navigation

New version 3.4.2 crashes consistently.

1164 Views 17 Replies Latest reply: Nov 12, 2012 4:26 PM by sjtscott RSS
1 2 Previous Next
thomas bfromel dorado hills Calculating status...
Currently Being Moderated
Nov 5, 2012 4:02 PM

Just downloaded 3.4.2 - what a mistake. Should have heeded the prior comments on the App site. It crashes consistently. I even tried Option-Open and created a new (empty) library - still crashes. I'm on Lion 10.7.5 IMac 4Meg.

I need Aperture back and running - is there any way of restoring the old version? I am running Time Machine but apps dont seem to get backed up unless I'm looking in the wrong place.

Aperture 3, Mac OS X (10.7.5)
  • William Lloyd Level 6 Level 6 (19,205 points)

    I haven't seen a single crash with 3.4.2.  I wonder if there's something else affecting it; have you tried moving aside your Aperture plist and seeing if that fixes things?

  • léonie Level 8 Level 8 (46,410 points)

    How did you buy Aperture? From the AppStore, did you buy a serial number from the apple Store, or the CD/DVD version? If you have installation media, you can reinstall and upgrade to an earlier version.

     

    But it might help to know the reson for the crashes. Could you please post the crash log? The first 50 lines, plust the part with the crashed thread?

     

    And when does it crash; directly when launching or later while you are adjusting or importing images?

  • léonie Level 8 Level 8 (46,410 points)

    Thomas,

    I just looked at your crash report. That is showing all the typical signs of the crash of Aperture version 3.4. - a crash of publishing to Facebook.

    The problem with the Aperture 3.4 update is, that it does not install the correct "Account Configuration" plug-in, and so the FaceBook plug-in will not work. The solution has been to reinstall Aperture from the original installation media, see Aperture 3.4: May quit unexpectedly on launch after updating. This bug has been solved by the update 3.4.1.

     

    Do you use Facebook? And what version did you upgrade from to Aperture 3.4.2? Your installation must have still been using the wrong "Account Configuration" plugin, that has been causing the Aperture 3.4 crashes. Or are you using a third party facebook plug-in? Some plug-ins are no longer compatible, see Aperture 3.4 and later: Some third-party plug-ins are no longer compatible

     

    What version of Aperture have you been upgrading from to Aperture 3.4.2? That version should no longer crash when configuring FaceBook accounts.

     

    Regards

    Léonie

  • léonie Level 8 Level 8 (46,410 points)

    I removed all of them and it now works.

    Good to know. So now you have Aperture 3.4.2 up and running again?

  • sjtscott Calculating status...

    I just upgraded to Mac OSX 10.7.5 tonight and was prompted to update Aperture from the App store to version 3.4.2. I did so then after installing ran the program and was prompted to upgrade my library. Since this point it simply refuses to start without crashing. I've removed the app and reinstalled it from the App store directly, still no joy.

     

    This is the crash report

     

    Process:         Aperture [2718]

    Path:            /Applications/Aperture.app/Contents/MacOS/Aperture

    Identifier:      com.apple.Aperture

    Version:         3.4.2 (3.4.2)

    Build Info:      Aperture-310019000000000~2

    App Item ID:     408981426

    App External ID: 11722063

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [117]

     

     

    Date/Time:       2012-11-06 21:09:51.582 +0000

    OS Version:      Mac OS X 10.7.5 (11G63b)

    Report Version:  9

     

     

    Interval Since Last Report:          3923 sec

    Crashes Since Last Report:           10

    Per-App Interval Since Last Report:  16 sec

    Per-App Crashes Since Last Report:   10

    Anonymous UUID:                      993147D5-95D5-4611-8CA0-4A5F6557516E

     

     

    Crashed Thread:  0

     

     

    Exception Type:  EXC_BREAKPOINT (SIGTRAP)

    Exception Codes: 0x0000000000000002, 0x0000000000000000

     

     

    Application Specific Information:

    dyld: launch, loading dependent libraries

     

     

    Dyld Error Message:

      Library not loaded: @executable_path/../Frameworks/PrintServices.framework/Versions/A/PrintServices

      Referenced from: /Applications/Aperture.app/Contents/MacOS/Aperture

      Reason: image not found

     

     

    Binary Images:

           0x10099c000 -        0x1010f1fff  com.apple.Aperture (3.4.2 - 3.4.2) <C5C848C2-2D8D-3D45-B212-8F6B2F6452B6> /Applications/Aperture.app/Contents/MacOS/Aperture

           0x101311000 -        0x10131aff7  com.apple.PhotoFoundation (1.0 - 10.17) <C40F985F-9C0A-389A-9E21-684EB0A5B160> /Applications/Aperture.app/Contents/Frameworks/PhotoFoundation.framework/Versio ns/A/PhotoFoundation

           0x101396000 -        0x1018b6fff  com.apple.RedRock (1.9.4 - 310.33) <9B94495A-2267-3684-B6E8-9FE3D4B46495> /Applications/Aperture.app/Contents/Frameworks/RedRock.framework/Versions/A/Red Rock

           0x101bbd000 -        0x101c40fff  com.apple.iLifePageLayoutCore (1.0 - 200.9) <8AAC1EB9-5823-3624-A525-635C2A77C34E> /Applications/Aperture.app/Contents/Frameworks/iLifePageLayoutCore.framework/Ve rsions/A/iLifePageLayoutCore

           0x101ca5000 -        0x101caafff  com.apple.iLifePhotoStreamConfiguration (3.4 - 2.5) <906317D7-09FF-3B77-8F35-01BB74C0109C> /Applications/Aperture.app/Contents/Frameworks/iLifePhotoStreamConfiguration.fr amework/Versions/A/iLifePhotoStreamConfiguration

           0x101cb8000 -        0x101ce9ff7  com.apple.iLifeAssetManagement (2.7 - 40.34) <E4E1A39C-E8AE-31D5-9C50-B392EBAD7447> /Applications/Aperture.app/Contents/Frameworks/iLifeAssetManagement.framework/V ersions/A/iLifeAssetManagement

           0x101d1e000 -        0x101d2bff7  com.apple.iphoto.AccountConfigurationPlugin (1.2 - 1.2) <0F515DED-D77E-3E4F-876D-F5CE596A844C> /Applications/Aperture.app/Contents/Frameworks/AccountConfigurationPlugin.frame work/Versions/A/AccountConfigurationPlugin

           0x101d3a000 -        0x101dddff7  com.apple.MobileMe (13 - 1.0.4) <9A7FCC99-67CE-3F5E-98BB-9079B305087F> /Applications/Aperture.app/Contents/Frameworks/MobileMe.framework/Versions/A/Mo bileMe

           0x101e59000 -        0x101e67fff  com.apple.PluginManager (1.7.6 - 55) <ABA41202-6D4F-368A-BE19-BD1729AF074A> /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager

           0x101e76000 -        0x101e87fff  com.apple.AERegistration (1.2 - 401) <16C4537B-4989-3DF7-8263-588F5C882063> /Applications/Aperture.app/Contents/Frameworks/AERegistration.framework/Version s/A/AERegistration

           0x101ea5000 -        0x102120ff7  com.apple.prokit (7.2.3 - 1823) <0D6BA804-8262-3942-B84D-B4886082242F> /System/Library/PrivateFrameworks/ProKit.framework/Versions/A/ProKit

           0x1022a3000 -        0x102647fff  com.apple.iLifeSlideshow (3.1 - 1151.4) <61A831CA-B996-3762-B3DD-85A3CB46F28D> /Applications/Aperture.app/Contents/Frameworks/iLifeSlideshow.framework/Version s/A/iLifeSlideshow

           0x1027c9000 -        0x1027e0ff7  com.apple.iLifeFaceRecognition (1.0 - 30.11) <46E3C666-EE15-324E-85D0-E56ECA0A342D> /Applications/Aperture.app/Contents/Frameworks/iLifeFaceRecognition.framework/V ersions/A/iLifeFaceRecognition

        0x7fff6059c000 -     0x7fff605d0baf  dyld (195.6 - ???) <C58DAD8A-4B00-3676-8637-93D6FDE73147> /usr/lib/dyld

        0x7fff85e4e000 -     0x7fff86022ff7  com.apple.CoreFoundation (6.7.2 - 635.21) <62A3402E-A4E7-391F-AD20-1EF20236CE1B> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

        0x7fff87994000 -     0x7fff87cb9ff7  com.apple.AddressBook.framework (6.1.3 - 1091) <5A8BEED1-229C-3A9C-8281-581127A1B9B5> /System/Library/Frameworks/AddressBook.framework/Versions/A/AddressBook

        0x7fff88a2e000 -     0x7fff88bb8ff7  com.apple.WebKit (7534.57 - 7534.57.7) <15AA1A2E-DCAC-35CE-89DF-0FF7149198CD> /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit

        0x7fff88c10000 -     0x7fff88c5cff7  com.apple.SystemConfiguration (1.11.3 - 1.11) <0A7F1982-B4EA-3424-A0C7-FE46C6224F03> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfi guration

        0x7fff88cb6000 -     0x7fff88e56ff7  com.apple.QuartzCore (1.7 - 270.5) <19E5E0AB-DAA9-3F97-988C-D9A46AFB9C04> /System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore

        0x7fff895c3000 -     0x7fff895c3fff  com.apple.quartzframework (1.5 - 1.5) <2C13AE76-C86B-3D48-A583-121689190F74> /System/Library/Frameworks/Quartz.framework/Versions/A/Quartz

        0x7fff8964e000 -     0x7fff897d9ff7  com.apple.QTKit (7.7.1 - 2339) <2BC2CF44-CEAF-3D3B-A250-CA59D6AFB0B0> /System/Library/Frameworks/QTKit.framework/Versions/A/QTKit

        0x7fff89abb000 -     0x7fff89abbfff  com.apple.Accelerate (1.7 - Accelerate 1.7) <82DDF6F5-FBC3-323D-B71D-CF7ABC5CF568> /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate

        0x7fff89c84000 -     0x7fff89d17fff  com.apple.PDFKit (2.6.4 - 2.6.4) <4C58283C-3F45-31C6-9896-5EFFFF82D840> /System/Library/Frameworks/Quartz.framework/Versions/A/Frameworks/PDFKit.framew ork/Versions/A/PDFKit

        0x7fff8a49f000 -     0x7fff8a50aff7  com.apple.framework.IOKit (2.0 - ???) <FE838BB6-D42E-3291-A1A0-6F53FC970261> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit

        0x7fff8aa4a000 -     0x7fff8aa4afff  com.apple.Cocoa (6.6 - ???) <7EC4D759-B2A6-3A99-AC75-809FED1500C6> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa

        0x7fff8cb5b000 -     0x7fff8cb5bfff  com.apple.audio.units.AudioUnit (1.7.3 - 1.7.3) <04C10813-CCE5-3333-8C72-E8E35E417B3B> /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit

        0x7fff8cb63000 -     0x7fff8ccc0fff  com.apple.audio.toolbox.AudioToolbox (1.7.3 - 1.7.3) <5F1E4695-BC74-3ADD-8345-627BCD68201A> /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox

        0x7fff8d0f8000 -     0x7fff8d3edff7  com.apple.security (7.0 - 55148.6) <4535E500-973A-3BA7-AF65-DF5CF0658F02> /System/Library/Frameworks/Security.framework/Versions/A/Security

        0x7fff8d3ee000 -     0x7fff8d456ff7  com.apple.audio.CoreAudio (4.0.3 - 4.0.3) <9987DC46-2A96-3BA0-B88B-04E573C0AD9B> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio

        0x7fff8e659000 -     0x7fff8e668fff  com.apple.opengl (1.8.1 - 1.8.1) <51B34133-CEE3-3FC6-82AC-ADF567AE673C> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL

        0x7fff8e671000 -     0x7fff8e671fff  com.apple.ApplicationServices (41 - 41) <89B6AD5B-5C75-3E83-8C2B-AA7F4C55E400> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Application Services

        0x7fff8ebd0000 -     0x7fff8ee3cff7  com.apple.AOSKit (1.021 - 94) <530546F3-F01C-3A89-8477-C800EFE59593> /System/Library/PrivateFrameworks/AOSKit.framework/Versions/A/AOSKit

        0x7fff8f649000 -     0x7fff8f649fff  com.apple.CoreServices (53 - 53) <043C8026-8EDD-3241-B090-F589E24062EF> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices

        0x7fff90250000 -     0x7fff902defff  com.apple.iLifeMediaBrowser (2.6.4 - 502.4.5) <A19798B7-E1A6-3117-8094-8D3A2CAB417F> /System/Library/PrivateFrameworks/iLifeMediaBrowser.framework/Versions/A/iLifeM ediaBrowser

        0x7fff90a10000 -     0x7fff90a10fff  com.apple.Carbon (153 - 153) <C1A30E01-E113-38A0-95CA-99360F92A37A> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

        0x7fff92bbe000 -     0x7fff92bc4fff  com.apple.DiskArbitration (2.4.1 - 2.4.1) <CEA34337-63DE-302E-81AA-10D717E1F699> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration

     

     

    Model: MacBookPro8,2, BootROM MBP81.0047.B27, 4 processors, Intel Core i7, 2.2 GHz, 8 GB, SMC 1.69f3

    Graphics: AMD Radeon HD 6750M, AMD Radeon HD 6750M, PCIe, 512 MB

    Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In, 512 MB

    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1333 MHz, 0x859B, 0x435435313236344243313333392E4D313646

    Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1333 MHz, 0x859B, 0x435435313236344243313333392E4D313646

    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xD6), Broadcom BCM43xx 1.0 (5.106.198.19.22)

    Bluetooth: Version 4.0.8f17, 2 service, 11 devices, 1 incoming serial ports

    Network Service: Wi-Fi, AirPort, en1

    Serial ATA Device: TOSHIBA MK5065GSXF, 500.11 GB

    Serial ATA Device: HL-DT-ST DVDRW  GS31N

    USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x8509, 0xfa200000 / 3

    USB Device: hub_device, 0x0424  (SMSC), 0x2513, 0xfa100000 / 2

    USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0253, 0xfa120000 / 5

    USB Device: BRCM2070 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 4

    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x821a, 0xfa113000 / 8

    USB Device: hub_device, 0x0424  (SMSC), 0x2513, 0xfd100000 / 2

    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd110000 / 3

     

    Looking on here I've seen someone else got this but from an issue with 3.4 - against the solution given and as apple give is to remove aperture and reinstall - as I've already said I've done this, actually now 3 times.

     

    Any help or clues anyone can give? I did switch off my time machine backups done no more since I upgraded from 10.7.4 OSX earlier tonight.. so somewhere on the timemachine disk I should have the original pre-upgraded aperture library

  • léonie Level 8 Level 8 (46,410 points)

    A typical crash: The installer has a problem, that can cause missing frameworks, when installing on top of certain Aperture versions. See this support article.

     

    Aperture 3.4: May quit unexpectedly on launch after updating

     

    The recommended fix is indeed reinstalling, but since it is working now, I'd wait and see.

  • sjtscott Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2012 1:29 PM (in response to léonie)

    leonieDF - I think you're getting me confused with the OP

    I think the OP is stating his copy is working not me! I've read that article hence trying now multiple times to reinstall.

    For clarity my install of Aperture still isn't working.

    Any more ideas please?

  • léonie Level 8 Level 8 (46,410 points)
    Currently Being Moderated
    Nov 6, 2012 2:20 PM (in response to sjtscott)

    leonieDF - I think you're getting me confused with the OP

    Sorry, but that is the danger of thread jacking.

     

    It would be better for you to post your question in a new thread; you will not get many answers by others  in a thread that has been marked solved.

     

    When you post your question add the following information:

    What Aperture version you have upgraded from, what you already did to solve the problem, what kind of Aperture library you have managed/refererenced, what kind of images, do you have any plug-ins?

     

    And what exactly is happening now after you reinstalled Aperture?

    Any more error messages and crashes?

     

    Reagrds

    Léonie

  • sjtscott Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2012 2:36 PM (in response to léonie)

    Sorry about the jacking, but I don't think a new thread is needed now.

    As I had another idea removed aperture directly from the launchpad. This time went back to timemachine grabbed out the previous version I had - restored that. Went back to app store upgraded to 3.4.2.

    This time opened correctly and auto offered to repair my aperture library. After this completed I then got exactly the same problem as the OP in this thread. i.e. crash complaining about the facebook plugin.

    Removed that after searching how to do this and done aperture is now opening and running correctly except I can't obviously export to facebook right now.

    So yes now I can say thanks leonieDF for the headsup on the facebook plugin problem. 3.4.2 is now running fine

    Immediate problem resolved and I'm very happy I backup using timemachine.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.