7 Replies Latest reply: Mar 18, 2013 12:32 PM by Vinicius Sena
t123 Level 1 (10 points)

In Safari 6, I've noticed that when Gmail finishes loading my Inbox it will automatically become the active tab.  This can be pretty annoying at times.  Doesn't happen with other browsers (Chrome, Firefox).

 

Here is my example scenario: 

  • I have some tabs open already
  • I open a new tab and go to gmail.com
  • While I'm waiting for it to load (as the status bar fills; sometimes can take a little while, depending on connection) I switch to another tab
  • When Gmail finishes loading it automatically becomes the active tab, regardless of what I'm doing in any other tab

 

This can be a problem if I am, say, closing the tab I'm currently on (cmd+W) but it switches over so fast I accidentally close Gmail... which I was just trying to load.  I know, not the end of the world, but still annoying and so far Gmail is the only site that's ever done this for me (it is consistent though).  I've tried to reproduce it with other random sites, even Google ones like Youtube, by switching tabs really fast before they load, but they still don't become active.  I can (and should?) just be more patient and wait for Gmail to load and this won't be a problem, but I think others can relate to the need to zip around tabs when you're in the zone.

 

Any ideas on why this is happening?  Any workarounds?  Others noticing this problem?


MacBook Pro (17-inch 2.4 GHz), OS X Mountain Lion (10.8.2)
  • Juliette_K Level 1 (0 points)

    Hi, I'm experiencing the same issue. I believe this was since a recent update (Java or Adobe).

     

    I still haven't found out a real solution, but I did find a workaround: if you just click on the address bar and select the address (gmail in this case), then you're able to switch windows again.


    Hope this helps.

     

    Ciao

  • Juliette_K Level 1 (0 points)

    Guess I found out.

    It is a JavaScript problem. Just disable JavaScript from Safari Preferences.

     

    Pls let me know if this works for you.

     

    J

  • Sapora Level 1 (0 points)

    Hmm, it worked. But now facebook won't load. hahaha.

  • Juliette_K Level 1 (0 points)

    I know. I'm having the same problem with other apps.

  • t123 Level 1 (10 points)

    Just disabling javascript is not the solution.  As you point out, Gmail's javascript is indeed what is causing Safari to make it the active tab, but many webpages need javascript in order to function properly, so disabling it makes your browser pretty limited.

     

    I guess the point of my original question was:  why does Safari interpret the javascript to make this happen, and other browsers do not?  Seems like something Apple should change.

  • Juliette_K Level 1 (0 points)

    I know.

     

    It only happens with Safari because Safari is WebKit-based now.


    Apple *should* change this, but many issues caused by the WebKit have still not been solved. So I don't know how long we'll have to wait fot this specific issue to be solved.

     

    I guess Apple is concentrating too much on the entertainement side of its SW (iOS), and this is the nasty result.

  • Vinicius Sena Level 1 (0 points)

    That is disgusting! Hope Apple fix that