9 Replies Latest reply: Nov 9, 2012 3:20 AM by Roger Price
Roger Price Level 1 Level 1

I am running Aperture 3.4.2 on my desktop and laptop.  All machines running latest 10.8.2 and all patches/upgrades.

 

Whenn I export projects as library on the laptop and import them on the desktop - it looks like it it importing but nothing happens!!  The files are not imported and there is no error or warning of any sort.

 

Anybody experiencing anything similar or know how to fix this or is it somethat that Apple broke with the recent upgrades - this used to work just fine

Solved by léonie on Nov 7, 2012 6:45 AM Solved

I get no option to add or merge though I have seen it before.

If there are no conflicts (duplicates or adjusted images) recognized, Aperture may skip the add/merge question.

 

- I did Repair database....am doing REBUILD now. 

Don't forget "repair Permissions". Sometimes it is simply a permissions problem.

 

Regards

Reply by Aye Es Oh on Nov 8, 2012 9:46 AM Helpful

Roger, did you try to repair permissions? AFAIK, rebuilding/repairing the database does not fix permissions issues.

All replies

  • léonie Level 10 Level 10
    expertise.photosformac
    Photos for Mac

    Roger,

    does the exported library actually contain the exported projects? Have you tried to open the exported library in Aperture and inspected the projects?

     

    Regards

    Léonie

  • Roger Price Level 1 Level 1

    Yes - the exported library is fine.  I can open it on the computer on which I am trying the import.  I contains everything, including the original images.

  • léonie Level 10 Level 10
    expertise.photosformac
    Photos for Mac

    Does really nothing happen, when you import? Does the size of the Library package stay the same? Do you import with "merge" or "add"? Do both options  "merge" or "add" do nothing? I once had the problem, that "merge" did not work, but "add" did. And this was solved by rebuilding the library.

     

    And have you tried to repair the library on your Desktop that you are importing to? I'd try all "Library First Aid Tools" Aperture 3 User Manual: Repairing and Rebuilding Your Aperture Library

  • Roger Price Level 1 Level 1

    No luck.  I did a rebuild of my main libarary and try the import again.

     

    I get no option to add or merge though I have seen it before.  It just says "merging libraries" and works away and when the dialog strip disappears, nothing has happened!

  • Roger Price Level 1 Level 1

    Correction - I did Repair database....am doing REBUILD now.  It will take a while....news to follow

  • léonie Level 10 Level 10
    expertise.photosformac
    Photos for Mac

    I get no option to add or merge though I have seen it before.

    If there are no conflicts (duplicates or adjusted images) recognized, Aperture may skip the add/merge question.

     

    - I did Repair database....am doing REBUILD now. 

    Don't forget "repair Permissions". Sometimes it is simply a permissions problem.

     

    Regards

  • Roger Price Level 1 Level 1

    Did a rebuild of the library overnight and tried the import again.

     

    No change.  It looks like it is importing but the projects do not get imported and there is no message of any sort.

     

    Saw the other import question - these are not photostream pics and photostream is on in both the source and destination library.

  • Aye Es Oh Level 2 Level 2

    Roger, did you try to repair permissions? AFAIK, rebuilding/repairing the database does not fix permissions issues.

  • Roger Price Level 1 Level 1

    Amazing!  Thanks Aye Es Oh.  That fixed it.  SOmehow I had assumed that Fix permissions was the least of the three options.  In the end I have run all three on the library and that one fixed it.  Thanks.