8 Replies Latest reply: Feb 8, 2013 12:49 AM by th0rb3n
peterobinson Level 1 (0 points)

Hi All,

Yesterday (Nov 6th) I updated my mid-2011 iMac from 10.8.1 to 10.8.2 and restarted after the update was complete.

 

Ever since then, the right click (secondary click) button on my magic mouse has completely stopped working.

 

I've tried everything obvious - checking that secondary click is enabled in the mouse preferences, deleting the magic mouse and bluetooth plist files to allow OS X to regenerate them on reboot, set the secondary click to off, rebooted then turned it on again, reset the NVRAM, I've even tried it with multiple magic mice to see if that would fix the problem.

 

Nothing I've tried works. Still stuck with no right click.

 

As I'm sure you can imagine, this is infuriating. I know that I can get the right click menu up by holding ctrl+left click but years of habit of just being able to right click leaves me fumbling around for the ctrl key when I need to right click and in all honest, this is an Apple product - it should "just work".

 

I've submitted a bug report to Apple and have as of yet, received no response.

 

Has anybody else had this issue? Has anybody found a fix for the issue?

 

Any help would be much appreciated.

 

Thanks

Pete


Magic Mouse, OS X Mountain Lion (10.8.2), Secondary Click not working
  • Barry Hemphill Level 8 (37,327 points)

    Hello:

     

    Have you reset the PRAM and SMC?  If not, try it.

     

    Barry

     

    P.S.  I doubt if it is a bug or many more of us would have experienced it.

  • peterobinson Level 1 (0 points)

    Yep, have reset PRAM and SMC. Same issue.

     

    It's actually fairly common - I've found at least 15 topics on this forum about it and a bit of Googleing revealed it wasn't just me. Can't find any topics that have a proper resolution though.

     

    I did a fair bit of research before posting on here because I didn't want to post a problem that was specific to just me. It seems like it's a fair few people.

     

    One "solution" is to install a 3rd party piece of software and assign right click to a right "tap" (not a full click) - that's not really a solution, more of a workaround.

  • Tnapuppercut Level 1 (0 points)

    I'm having a similar issue....none of my Magic gestures work...I've tried resetting the PRAM and SMC and it seems to try to work for a split second and quits...I've also tried deleting the bluetooth.plist files and other suggestions...

     

    Barry, I've seen you post on numerous complaints about the magic mouse not working properly, so I'm sort of amazed you said many more of us would have experienced this problem.

  • oldmacgeek Level 1 (0 points)

    I have posted this same problem in multiple ways. I have found that many others have the same problem. And I have presented the problem to an Apple genius and he tried the obvious and admitted that he did not know how to fix this problem. No one has provided a solution.

  • peterobinson Level 1 (0 points)

    I've just managed to fix it :-D

     

    Hold Alt when your machine boots, that'll take you to the recovery utility. Reinstall OS X from the recovery partition (it'll take a while to download if you've not got fast internet and then about 30mins to install).

     

    That'll revert you back to 10.8. Then go to the app store app and update to 10.8.2 (the most recent update) and that fixes it :-D.

     

    You don't loose any data when restoring from a recovery partition.

  • oldmacgeek Level 1 (0 points)

    Thank you!!! It worked. I knew the problem was not with my mousej, since when rebooting from a Snow Leopard drive, the alt (right) click worked.

     

    Again thank you.  This solved my problem.

  • kg23 Level 1 (115 points)

    See this thread. There are a few suggestions in there.

    https://discussions.apple.com/thread/4322019?start=75&tstart=0

     

    I ended up reinstalling Mountain Lion on my mac mini and that fixed the problem. The machine was less than 3 weeks old,