2 Replies Latest reply: Nov 8, 2012 2:55 AM by hanneh217
hanneh217 Level 1 Level 1 (0 points)

Hi,

 

I recently upgraded to iPhoto11 and when I launched it again it told me that I had to update my library. I clicked ok, and when the updating was done - all my photos had disappeared! The albums/folders where still there, but empty. And when I look in the library (Events/Photos) I get the message "to get started with iPhoto, do any of the following: connect camera... / drag photos... / import to Library..."

 

However, when I check out the iPhoto Library in  Finder it has 4.6GB and all the photos are still there (I checked with "Show Package Contents"). Somehow iPhoto11 just doesn't seem to recognise that it is all there!

 

I've already tried with a backup version of the library through time machine, but it does not change anything: when I want to open the original (old) library file it says that the library has to be upgraded and then it is the same problem.

 

Any idea what might have happened and how to fix it?

 

(I've tried the Library rebuild - no effect.)

 

Many thanks in advance!


iPhoto '11, Mac OS X (10.7.5)
  • Terence Devlin Level 10 Level 10 (134,580 points)

    Download iPhoto Library Manager and use its rebuild function. (In Library Manager it's the FIle -> Rebuild command)

     

     

    This will create an entirely new library. It will then copy (or try to) your photos and all the associated metadata and versions to this new Library, and arrange it as close as it can to what you had in the damaged Library. It does this based on information it finds in the iPhoto sharing mechanism - but that means that things not shared won't be there, so no slideshows, books or calendars, for instance - but it should get all your events, albums and keywords, faces and places back.

     

     

    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one.  

  • hanneh217 Level 1 Level 1 (0 points)

    Hi,

     

    I just talked to Apple Support. There seems to have been an problem with the update of the library. I needed to go back with time machine and restore the old version of the library.

     

    Then start iPhoto with the ALT key pressed: gives you the option with which library you want to start. I went back to the original, which then also had to be updated as "this version does not work with iPhoto11".

     

    And then the old library worked!

     

    (The rebuild did not change anything...)